1

I have 3 routers in my topology, and two of them have loop backs.Let's say R0 is the one without the loo back. I have configured rip with no auto-summary just to make sure I can ping from R1 to the loop back address of R2. The ping does not succeed.How is this possible considering I have enabled rip with no auto-summary?The loop back addresses are for R1: 192.168.1.65 and for R2:192.168.1.129

Here are is the routing table for R1:

    Gateway of last resort is not set

       172.17.0.0/24 is subnetted, 1 subnets
  C       172.17.1.0 is directly connected, Serial1
          172.16.0.0/30 is subnetted, 1 subnets
  C       172.16.1.0 is directly connected, Ethernet0
          10.0.0.0/30 is subnetted, 1 subnets
  R       10.1.1.0 [120/1] via 172.17.1.2, 00:00:23, Serial1
    192.168.1.0/26 is subnetted, 1 subnets
  C       192.168.1.64 is directly connected, Loopback1

and here is the routing table for R2:

    Gateway of last resort is not set

    172.17.0.0/24 is subnetted, 1 subnets
 C       172.17.1.0 is directly connected, Serial1
         172.16.0.0/30 is subnetted, 1 subnets
 R       172.16.1.0 [120/1] via 172.17.1.1, 00:00:03, Serial1
         10.0.0.0/30 is subnetted, 1 subnets
 C       10.1.1.0 is directly connected, Serial0
         192.168.1.0/26 is subnetted, 1 subnets
 C       192.168.1.128 is directly connected, Loopback1
  • You need to edit your question to include the full router configurations. – Ron Maupin May 14 '17 at 19:34
  • Did any answer help you? if so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you could provide and accept your own answer. – Ron Maupin Aug 12 '17 at 17:25
1

To answer your question...

.How is this possible considering I have enabled rip with no auto-summary?

I would need to see the routing commands and tables of all 3 to tell you why it didn't route.

no auto-summary is a command used to keep the router from summarizing classes of networks. It doesn't add information for networks that aren't advertised in the router rip command. I'm a bit confused on your interpretation of what it should do or maybe I could explain better.

Basic examples with and without auto-summary.

If you use Rip or EIGRP as with auto-summary (by leaving it as is) and you put network 10.10.10.0 255.255.255.0 the router will interpret that as 10.0.0.0 and that's what will be in the routing table because the 10 network is a class A address. If you had 'network 10.10.10.0 255.255.255.0' and network '10.10.20.0 255.255.255.0' on two diffrent rows and didn't add the command no-auto summary both routers would advertise 10.0.0.0 basically ignoring the subnet address and the routing wouldn't work properly.

If you use no-auto summary it will interpret the address as is if you use the subnet address. network 10.10.10.0 255.255.255.0 will advertise 10.10.10.0/24 and show properly in the routing table on one router and network 10.10.20.0 255.255.255.0 would advertise 10.10.20.0/24 and show properly as well.

1

You need to include the Loopback interfaces in the RIP Network statements. right now Router 1 knows about network 192.168.1.64/26 but does not know how to get to network 192.168.1.128/26.

So on router 1 you would add a network statement something like NETWORK 192.168.1.64 to your RIP configuration.

You would do the reverse on Router 2

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.