2

I was wondering if someone could help me with something. I am trying to set up SNMP v3 but with access control. Now, I have made the user and group. That's all fine, but I can't seem to get the access control part working.

When I attempt to add it at the end the switch throws a paddy saying it's not possible.

Here is what I am putting in: snmp-server user User1 Group1 v3 auth md5 BeepBoop access 10

The access list I am trying to make is 10. I have made the list with the IP addresses within the list.

edit:

snmp-server user User1 Group1 v3 auth md5 BeepBoop access 10
                                                   ^
ERROR: % Invalid input detected at '^' marker.

Cisco Adaptive Security Appliance Software Version 9.8(1) Firepower Extensible Operating System Version 2.2(1.47) Device Manager Version 7.8(1)

4
  • You need to give the exact message you are getting.
    – Ron Maupin
    May 19, 2017 at 19:04
  • @RonMaupin I have just added it.
    – CLGREEN
    May 19, 2017 at 19:10
  • OK. Also, what is you IOS version (sh version)?
    – Ron Maupin
    May 19, 2017 at 19:10
  • Cisco Adaptive Security Appliance Software Version 9.8(1) Firepower Extensible Operating System Version 2.2(1.47) Device Manager Version 7.8(1)
    – CLGREEN
    May 19, 2017 at 19:13

1 Answer 1

2

The problem is that you don't have the access option on the ASA snmp-server user command like you do on IOS.

snmp-server user username group-name { v3 [ encrypted ]] [ auth { md5 | sha ]} auth-password [ priv [ des | 3des | aes ] [ 128 | 192 | 256 ] priv-password

As Ricky Beam points out, you use the snmp-server host command to restict the host access:

snmp-server host interface { hostname | ip_address } [ trap | poll ] [ community community-string ] [ version { 1 | 2c | 3 username }] [ udp-port port ]

See the Cisco ASA Series CLI Configuration Guide, 9.0:

enter image description here

1
  • snmp-server host ... is where access is restricted. (cisco urls rarely stay static.)
    – Ricky
    May 19, 2017 at 20:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.