1

I want to apply static NAT to highlighted servers on the KLRTR router but the issue is the interface s0/0/0 has sub-interface (S0/0/0.203) of frame relay on it. So I applied the NAT on the sub-interface on S0/0/0.203 but then the sub-interface s0/0/0.203 already has an IP assigned (NAT IP is different from the IP between KL_ISP and KLRTR) to it so it didnt work as NAT translations worked but the sender doesn't get a ping response.

In simulation mode mode the packets fail at KL_ISP, not sure why even though I have static route set on KL_ISP to enter the network and other devices are able to ping.

If I ping from Internet Web Server to DHCP server on its inside local IP, the ping is successful but fails on pinging on the outside global IP.

I applied IP address to S0/0/0 and then I applied NAT on it which didnt work either.

Is there any other way to solve this issue.

enter image description here

Thank You

KLRTR Config:

KLRTR#sh run
Building configuration...

Current configuration : 2077 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
service password-encryption
!
hostname KLRTR
!
enable secret 5 $1$mERr$hx5rVt7rPNoS4wqbXKX7m0
!
ip dhcp excluded-address 10.11.2.1 10.11.2.3
!
ip dhcp pool VLANSalesOnly
 network 10.11.2.0 255.255.255.0
 default-router 10.11.2.1
 dns-server 10.11.5.11
!
no ip cef
no ipv6 cef
!
username KLISP password 7 0822455D0A16
!
no ip domain-lookup
!
spanning-tree mode pvst
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet0/1.19
 description Subinterface for VLAN 19 WLAN for security group
 encapsulation dot1Q 19
 ip address 10.11.4.225 255.255.255.248
!
interface FastEthernet0/1.188
 description Subinterface for VLAN 188 SalesOnly group
 encapsulation dot1Q 188
 ip address 10.11.2.1 255.255.255.0
!
interface FastEthernet0/1.199
 description Subinterface for VLAN 199 switch Management
 encapsulation dot1Q 199
 ip address 10.11.4.201 255.255.255.248
!
interface Serial0/0/0
 ip address 172.168.0.10 255.255.0.0 *ADDED FOR TESTING PURPOSE ONLY
 encapsulation frame-relay
 ip nat inside
!
interface Serial0/0/0.201 point-to-point
 ip address 10.11.4.250 255.255.255.252
 frame-relay interface-dlci 201
 clock rate 2000000
!
interface Serial0/0/0.203 point-to-point
 ip address 10.11.4.253 255.255.255.252
 frame-relay interface-dlci 203
 clock rate 2000000
!
interface Serial0/0/1
 ip address 195.9.16.18 255.255.255.252
 encapsulation ppp
 ppp authentication chap
 ip nat outside
!
interface Vlan1
 no ip address
 shutdown
!
router eigrp 1
 redistribute static 
 network 10.0.0.0
 network 195.9.16.0
 no auto-summary
!
ip nat inside source static 10.11.4.242 160.12.0.1 
ip nat inside source static 10.11.4.243 160.12.0.2 
ip classless
ip route 0.0.0.0 0.0.0.0 195.9.16.17 
!
ip flow-export version 9
!
line con 0
 password 7 0822455D0A16
 login
!
line aux 0
!
line vty 0 4
 password 7 0822455D0A16
 login
line vty 5 15
 password 7 0822455D0A16
 login
!
end

KL_ISP Config:

KLISP#sh run
Building configuration...

Current configuration : 877 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname KLISP
!
no ip cef
no ipv6 cef
!
username KLRTR password 0 cisco
!
no ip domain-lookup
!
spanning-tree mode pvst
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface FastEthernet0/1
 ip address 154.10.12.49 255.255.255.240
 duplex auto
 speed auto
!
interface Serial0/0/0
 ip address 195.9.16.17 255.255.255.252
 encapsulation ppp
 ppp authentication chap
 clock rate 2000000
!
interface Serial0/0/1
 no ip address
 clock rate 2000000
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
ip classless
ip route 10.11.0.0 255.255.0.0 Serial0/0/0 
!
ip flow-export version 9
!
no cdp run
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
end
  • You need to edit your question to include the full configurations of the network devices involved. We cannot guess where you went wrong in your configuration. – Ron Maupin May 24 '17 at 13:26
  • Please do let me know if anything else is needed, I can provide PT file if needed. – tryllz May 24 '17 at 14:07
0

Your inside interface is assigned to an interface with no IP addressing. In fact, you have no address with the addressing for either of your NAT statements, so the packets with those source addresses must be coming into one of your interfaces from somewhere else. You need to put the ip nat inside statement on the interface(s) where that traffic comes into the router, and that cannot possibly be an interface with no IP address assigned.

Edit:

You have now assigned an IP address to the inside interface, but is that the interface where the packets with the source addresses listed in your NAT statements come into the router?

Edit:

Based on you comments, your outside router (KLISP) has no route to the translated addresses, so it will drop packets destined to those addresses. You must inform KLISP to send packets destined to those addresses to 195.9.16.18. You can do that with statically configured route(s) or dynamically with a routing protocol.

| improve this answer | |
  • Sorry misunderstood, yes that is the interface that the packets come into the router from S0/0/0 connected to Frame Relay, packets get a NAT IP from s0/0/1 which is the route from KLRTR to KLISP. Am I misunderstanding and have incorrectly implemented NAT ? as I understand the inside is the inside of the network and the outside is the outside of the network connected to foreign networks. – tryllz May 24 '17 at 14:20
  • Right, you have configured that interface as the outside interface, but you must configure inside on the interfaces where the packets enter the router. Also, you are going to have a difficult time with return traffic if there is no route for the new addresses that points back to your outside interface. – Ron Maupin May 24 '17 at 14:23
  • I have configured and applied IP to s0/0/0 but then the packets go and return and ping successfully but not NAT translations happen. There is a static route from KLISP to KLRTR as well – tryllz May 24 '17 at 14:25
  • Translations only happen between traffic coming into an interface configured as inside, and an interface configured as outside, with the source addresses you have specified in your NAT statements. If the packets with those source addresses are not coming into the router through interface Serial0/0/0, going out through interface Serial0/0/1, then there will be no NAT. – Ron Maupin May 24 '17 at 14:28
  • Frankly Im confused on the inside and outside because if I look at it, traffic coming inside the router can be from inside the network and from outside as well, then how do I decide which is the inside and which the outside – tryllz May 24 '17 at 14:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.