1

I have a Cisco 3560 48-PoE. I am trying to use it for imaging computers. I can make it work but I only get 1gb a minute. I have tried various tweaking but that's about has high as I can get.

What is the max I should be able to get on a closed network. This is for one server and one client for the entire switch, same vlan, all stock out of the box.

I tried jumbo frames and used ifconfig to change the mtu on the machines. Didn't help.

  • Depending on which ports you're plugged into, you can be oversubscribed. But that's way too slow. You have something else going on. – Ron Trunk May 25 '17 at 14:48
  • How do you know the bottleneck is your switch? – Andriy Berestovskyy May 25 '17 at 14:48
  • 3
    @AndriyBerestovskyy Because it's always the network ;-p – Ron Trunk May 25 '17 at 14:48
  • @RonTrunk right, but you also have a network part in your imaging computers... Do you have duplex/speed set to auto on your computers? – Andriy Berestovskyy May 25 '17 at 14:55
  • 1
    Jumbo frames offer very, very little benefit at speeds < 10G and often create more problems than they solve. That 3560 is certainly good to run at some fairly close approximate of line rate for many traffic loads. 1 gigabit is good for a nominal 125 megaBYTES per second, although in practice top performance is usually ~95% of this. A properly tuned and configured set of endpoints without other I/O bottlenecks should be good for 5-6 gigabytes per minute on a gigabit switch without too much drama. – rnxrx May 27 '17 at 4:56
2

When I see a problem such as you describe, it is almost always a duplex mismatch. Look at the statistics on your switch interfaces. If you see a lot of collisions (should not exist on a full-duplex switch interface) and/or FCS, then you have a duplex mismatch.

A duplex mismatch usually occurs when on side of a link is set to auto-negotiate, but the other side of the link is set to a fixed speed. When this is the case, the side set to auto-negotiate cannot negotiate. It will detect the fixed speed, and it will default to the duplex for the speed (half duplex for 10 or 100 Mbps).

Cisco has a document, Troubleshooting Cisco Catalyst Switches to NIC Compatibility Issues, that describes this, that includes a table that tells you what happens at various settings.

  • 2
    Generally, you should never manually set a port's speed. The only exception is when a) you've verified that it is absolutely necessary, b) you set up both link ends the very same way, and c) you verify correct function after deployment. – Zac67 Jun 24 '17 at 19:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.