1

I have a switch that is counting "output errors". A "show interface gi1/0/46 controller" shows up "2963657 Excess Defer frames" but I really can't find any documentation about "excess defer frames". Can some one tell me what kind of error this is and what circumstance can cause that?

Hardware is WS-C3650-48TS, Software 03.06.05E. Do you need any more information?

Thanks in advance,

Flo

1
  • Did any answer help you? If so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you can provide and accept your own answer.
    – Ron Maupin
    Feb 19 '18 at 4:28
1

Check https://supportforums.cisco.com/discussion/13203691/excess-defer-frames-or-xmit-errors - frames that are deferred can't be sent out the destination port right away and get queued. Excess deferred frames are those dropped when the output queue is overloaded.

There are several possible causes:

  • the output port is linking at a slower speed than expected
  • a stream from a faster link is funneled through a trunk group (usually, you can't successfully run a fullspeed 10G link through a 10x 1G trunk)
  • your network architecture has a bottleneck and might need rethinking
5
  • Hi Zac, the switch is connected via 1G with one of our core-switches, not much traffic on the link:sh int gi1/0/46 human-readable | inc 30 30 second input rate 1.34 mega-bits/sec , 936 pps 30 second output rate 2.54 mega-bits/sec , 846 pps both sides have negotiated 1g fullduplex... i have no clue anymore
    – flo
    May 29 '17 at 12:07
  • Strange... The frame drops are continous? Are you using flow control somewhere? Multicast traffic? Do you experience any problems apart from the drop counter? That's 1000BASE-T? Have you tried another cable?
    – Zac67
    May 29 '17 at 13:09
  • Hi Zac, what I've done so far: Changed the cable, changed the port (was 1/0/48, now 1/0/46. 1/0/47 is the second uplink but had no errors while active. So I guess it's not the packet forwarding engine who causes problems). I can see multicast traffic there, but I'm not sure where it comes from...need to ask the server guys. I know of a SQL-Server behind that switch...but sql shouldn't generate multicast traffic?...) Frame drops are continous. Flow control is deactivated on both devices. Auto-Qos is configured with its defaults....
    – flo
    May 29 '17 at 13:54
  • And yes, it's a copper connection. Cable length is 2m. No patchpanel between. No errors on the other device.... I'm thinking of replacing the switch but I think that won't change anything because error is port-independent...
    – flo
    May 29 '17 at 13:58
  • Multicast was just a wild guess - if it's not excessive, there shouldn't be a problem. I don't think it's the switch either, but am at a loss, sorry.
    – Zac67
    May 30 '17 at 16:35
2

Excess Defer frames: According to Cisco documentation it is the number of frames that are not sent after the time exceeds the maximum-packet time.

It means that the port is under heavy load.

The device connected to the port is transmitting or receiving more traffic that can be handled by the port. Verify if the port is configured as half-duplex or full-duplex.

1
  • Hi jcbermu, thanks for your help. But the port is Full Duplex 1G, peer port is 1G fullduplex, too....Load isn't that heavy for 1g: #sh int gi1/0/46 human-readable | inc 30 30 second input rate 1.34 mega-bits/sec , 936 pps 30 second output rate 2.54 mega-bits/sec , 846 pps
    – flo
    May 29 '17 at 11:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.