-1

I mounted a ring network with ospf with the topology that follows. What is happening is that I disconnect an interface (Fa5/0 R1) to verify redundancy and the two routers (R1 and R4) involved lose the OSPF instance completely. I realize this by checking the routing table and finding that it is empty..

The following log is displayed.

% LINK-5-CHANGED: FastEthernet5 / 0 interface, changed state to down

% LINEPROTO-5-UPDOWN: Line protocol on FastEthernet5 / 0 interface, changed state to down

: OSPF-5-ADJCHG: Process 1, Nbr 10.99.99.1 on FastEthernet5 / 0 from FULL to DOWN, Neighbor Down: Interface down or detached

Topology enter image description here

and as following configs in my routers (R1, R2, R3 and R4)

R1:

Current configuration : 1260 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R1
!
!
!
!
!
!
!
!
no ip cef
no ipv6 cef
!
[...]
!
interface Loopback0
ip address 10.99.99.1 255.255.255.255
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
shutdown
!
interface FastEthernet1/0
no ip address
duplex auto
speed auto
shutdown
!
interface Serial2/0
ip address 2.0.1.2 255.255.255.252
!
interface Serial3/0
no ip address
clock rate 2000000
shutdown
!
interface FastEthernet4/0
ip address 1.0.0.1 255.255.255.252
!
interface FastEthernet5/0
ip address 1.0.0.14 255.255.255.252
!
!
router ospf 1
router-id 10.99.99.1
log-adjacency-changes
redistribute static subnets 
passive-interface Loopback0
network 1.0.0.0 0.0.0.3 area 0
network 10.99.99.1 0.0.0.0 area 0
network 1.0.0.12 0.0.0.3 area 0
default-information originate
!
router bgp 100
bgp log-neighbor-changes
no synchronization
neighbor 2.0.1.1 remote-as 200
network 1.0.0.0
!
ip classless
ip route 1.0.0.0 255.0.0.0 Loopback0 
ip route 0.0.0.0 0.0.0.0 Loopback0 
!
ip flow-export version 9
!
!
access-list 1 permit any
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
!
end

R4:

Current configuration : 995 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R4
!
!
!
!
!
!
!
!
ip cef
no ipv6 cef
!
[...]
!
interface Loopback0
 ip address 10.99.99.4 255.255.255.255
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface FastEthernet1/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial2/0
 no ip address
 clock rate 2000000
 shutdown
!
interface Serial3/0
 no ip address
 clock rate 2000000
 shutdown
!
interface FastEthernet4/0
ip address 1.0.0.10 255.255.255.252
! 
interface FastEthernet5/0
ip address 1.0.0.13 255.255.255.252
!
router ospf 1
 router-id 10.99.99.4
 log-adjacency-changes
 passive-interface Loopback0
 network 10.99.99.4 0.0.0.0 area 0
 network 1.0.0.12 0.0.0.3 area 0
 network 1.0.0.8 0.0.0.3 area 0
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end

R1 Router Table

     1.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
S       1.0.0.0/8 is directly connected, Loopback0
C       1.0.0.0/30 is directly connected, FastEthernet4/0
O       1.0.0.4/30 [110/2] via 1.0.0.2, 00:00:00, FastEthernet4/0
O       1.0.0.8/30 [110/2] via 1.0.0.13, 00:03:08, FastEthernet5/0
C       1.0.0.12/30 is directly connected, FastEthernet5/0
     2.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
B       2.0.0.0/24 [20/0] via 2.0.1.1, 15:23:41
C       2.0.1.0/30 is directly connected, Serial2/0
     10.0.0.0/32 is subnetted, 4 subnets
C       10.99.99.1 is directly connected, Loopback0
O       10.99.99.2 [110/2] via 1.0.0.2, 00:00:00, FastEthernet4/0
O       10.99.99.3 [110/3] via 1.0.0.2, 00:00:00, FastEthernet4/0
                   [110/3] via 1.0.0.13, 00:00:00, FastEthernet5/0
O       10.99.99.4 [110/2] via 1.0.0.13, 00:03:55, FastEthernet5/0
S*   0.0.0.0/0 is directly connected, Loopback0

R4 Router Table

     1.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
O E2    1.0.0.0/8 [110/20] via 1.0.0.14, 00:07:42, FastEthernet5/0
O       1.0.0.0/30 [110/2] via 1.0.0.14, 00:03:46, FastEthernet5/0
O       1.0.0.4/30 [110/2] via 1.0.0.9, 00:03:46, FastEthernet4/0
C       1.0.0.8/30 is directly connected, FastEthernet4/0
C       1.0.0.12/30 is directly connected, FastEthernet5/0
     10.0.0.0/32 is subnetted, 4 subnets
O       10.99.99.1 [110/2] via 1.0.0.14, 00:07:42, FastEthernet5/0
O       10.99.99.2 [110/3] via 1.0.0.14, 00:03:46, FastEthernet5/0
                   [110/3] via 1.0.0.9, 00:03:46, FastEthernet4/0
O       10.99.99.3 [110/2] via 1.0.0.9, 00:06:55, FastEthernet4/0
C       10.99.99.4 is directly connected, Loopback0

R1 Database

           OSPF Router with ID (10.99.99.1) (Process ID 1)

               Router Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum Link count
10.99.99.4      10.99.99.4      267         0x8000003d 0x0067df 3
10.99.99.1      10.99.99.1      81          0x8000004f 0x001835 3
10.99.99.2      10.99.99.2      78          0x80000057 0x00cf83 3
10.99.99.3      10.99.99.3      78          0x8000003e 0x009fb8 3

                Net Link States (Area 0)
Link ID         ADV Router      Age         Seq#       Checksum
1.0.0.13        10.99.99.4      317         0x8000004c 0x0024cc
1.0.0.10        10.99.99.4      267         0x8000004b 0x004ea4
1.0.0.1         10.99.99.1      81          0x80000001 0x004308
1.0.0.6         10.99.99.3      78          0x80000027 0x00e633

                Summary ASB Link States (Area 0)
Link ID         ADV Router      Age         Seq#       Checksum
10.99.99.1      10.99.99.1      1318        0x8000001d 0x009509

                Type-5 AS External Link States
Link ID         ADV Router      Age         Seq#       Checksum Tag
1.0.0.0         10.99.99.1      1317        0x80000024 0x004387 0

R4 Database OSPF Router with ID (10.99.99.4) (Process ID 1)

                Router Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum Link count
10.99.99.4      10.99.99.4      494         0x8000003d 0x0067df 3
10.99.99.1      10.99.99.1      308         0x8000004f 0x001835 3
10.99.99.2      10.99.99.2      305         0x80000057 0x00cf83 3
10.99.99.3      10.99.99.3      305         0x8000003e 0x009fb8 3

                Net Link States (Area 0)
Link ID         ADV Router      Age         Seq#       Checksum
1.0.0.13        10.99.99.4      544         0x8000004c 0x0024cc
1.0.0.10        10.99.99.4      494         0x8000004b 0x004ea4
1.0.0.1         10.99.99.1      308         0x80000001 0x004308
1.0.0.6         10.99.99.3      305         0x80000027 0x00e633

                Summary ASB Link States (Area 0)
Link ID         ADV Router      Age         Seq#       Checksum
10.99.99.1      10.99.99.1      1545        0x8000001d 0x009509

                Type-5 AS External Link States
Link ID         ADV Router      Age         Seq#       Checksum Tag
1.0.0.0         10.99.99.1      1544        0x80000024 0x004387 0

R1 OSPF Interfaces

Loopback0 is up, line protocol is up
  Internet address is 10.99.99.1/32, Area 0
  Process ID 1, Router ID 10.99.99.1, Network Type LOOPBACK, Cost: 1
  Loopback interface is treated as a stub Host
FastEthernet4/0 is up, line protocol is up
  Internet address is 1.0.0.1/30, Area 0
  Process ID 1, Router ID 10.99.99.1, Network Type BROADCAST, Cost: 1
  Transmit Delay is 1 sec, State DR, Priority 1
  Designated Router (ID) 10.99.99.1, Interface address 1.0.0.1
  Backup Designated Router (ID) 10.99.99.2, Interface address 1.0.0.2
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    Hello due in 00:00:00
  Index 2/2, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 1
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 10.99.99.2  (Backup Designated Router)
  Suppress hello for 0 neighbor(s)
FastEthernet5/0 is up, line protocol is up
  Internet address is 1.0.0.14/30, Area 0
  Process ID 1, Router ID 10.99.99.1, Network Type BROADCAST, Cost: 1
  Transmit Delay is 1 sec, State BDR, Priority 1
  Designated Router (ID) 10.99.99.4, Interface address 1.0.0.13
  Backup Designated Router (ID) 10.99.99.1, Interface address 1.0.0.14
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    Hello due in 00:00:08
  Index 3/3, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 1
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 10.99.99.4  (Designated Router)
  Suppress hello for 0 neighbor(s)

R4 OSPF Interfaces

Loopback0 is up, line protocol is up
  Internet address is 10.99.99.4/32, Area 0
  Process ID 1, Router ID 10.99.99.4, Network Type LOOPBACK, Cost: 1
  Loopback interface is treated as a stub Host
FastEthernet5/0 is up, line protocol is up
  Internet address is 1.0.0.13/30, Area 0
  Process ID 1, Router ID 10.99.99.4, Network Type BROADCAST, Cost: 1
  Transmit Delay is 1 sec, State DR, Priority 1
  Designated Router (ID) 10.99.99.4, Interface address 1.0.0.13
  Backup Designated Router (ID) 10.99.99.1, Interface address 1.0.0.14
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    Hello due in 00:00:00
  Index 2/2, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 1
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 10.99.99.1  (Backup Designated Router)
  Suppress hello for 0 neighbor(s)
FastEthernet4/0 is up, line protocol is up
  Internet address is 1.0.0.10/30, Area 0
  Process ID 1, Router ID 10.99.99.4, Network Type BROADCAST, Cost: 1
  Transmit Delay is 1 sec, State DR, Priority 1
  Designated Router (ID) 10.99.99.4, Interface address 1.0.0.10
  Backup Designated Router (ID) 10.99.99.3, Interface address 1.0.0.9
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    Hello due in 00:00:05
  Index 3/3, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 1
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 10.99.99.3  (Backup Designated Router)
  Suppress hello for 0 neighbor(s)
7
  • Please clarify what you are asking. Be specific. What interface, what router, what configuration, etc.?
    – Ron Maupin
    Commented Jun 5, 2017 at 3:07
  • I gave a brief example
    – SoabTI
    Commented Jun 5, 2017 at 11:58
  • I don't understand what you are asking. Are you asking why OSPF shows down on a down interface?
    – Ron Trunk
    Commented Jun 5, 2017 at 12:11
  • I'm wondering why the instance of ospf crashes if I turn off a neighboring interface.
    – SoabTI
    Commented Jun 5, 2017 at 12:19
  • This is not normal behavior, is it?
    – SoabTI
    Commented Jun 5, 2017 at 12:19

2 Answers 2

5

The message you got is perfectly normal. That is not OSPF crashing, but it is telling you that the neighbor is no longer there. The interface is down, so OSPF cannot communicate with that neighbor. When an interface is down, the network attached to it no longer exists for OSPF, and it cannot exchange hellos with any neighbor through that interface.

8
  • Certainly, but this fall affects other OSPF routes, since it loses all routes even though it is not related to the interface. As for example R2 and R3 would be inaccessible by OP1
    – SoabTI
    Commented Jun 5, 2017 at 14:55
  • That is correct. It is as if the connection never existed. That is how dynamic routing protocols work. They are dynamic, and they respond to changes in the network. If a link comes up, and the protocol is configured to respond to it, then routes may be added. As links go down, routes are removed. That is the entire point of a dynamic routing protocol.
    – Ron Maupin
    Commented Jun 5, 2017 at 14:57
  • But are they even removed to routes that are not related to the disconnected interface? Because there are no ospf routes remaining on R1.
    – SoabTI
    Commented Jun 5, 2017 at 15:00
  • 1
    You have not shown any routing tables, so we don't' know what is happening where. As I have tried to tell you multiple times, you need to include all relevant information in your question, and you need to be very specific. We cannot guess or speculate what you mean or what you see. If you want a good answer then you need to give us everything.
    – Ron Maupin
    Commented Jun 5, 2017 at 15:06
  • 1
    I agree with Ron. Topology is inconsistent with the configurations. I even tried to simulate it... Messy work. Ignoring that I'd recommend removal of those pointless statics on R1 with Loopback interface as an exit point and enabling cef. If you are using packet tracer this might be the root cause of the issues experienced. Commented Jun 5, 2017 at 16:21
0

I created the same lab in GNS3 and found that the problem is in the Packet Tracer.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.