1

I have a simple question - I am a novice to networking and trying to understand if there is a GUI way to configure the switch (default UI / SNMP, etc.). I do not have any advanced needs but to simply connect two switches in such a way that they create a flat network. The default config (I thought will work by connecting two switches with a simple cable) doesn't work.

Any help will be appreciated.

1
  • Did any answer help you? If so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you could provide and accept your own answer.
    – Ron Maupin
    Feb 21 '18 at 16:39
1

To enable the web interface, you will first need to connect to the switch using a serial cable, connect to the port marked Console on the back of the switch. Use a terminal emulator (e.g. Putty if you are using Windows) and open up the COM port the serial cable is connected to. If you are using a USB-Serial cable, you may need to install a driver first to virtualise the COM port.

Once you are connected to the CLI, enter the following to enable the web interface (replacing the IP address with something on your network, and the interface number with one of the free interfaces)

Press Contol + D (i.e hold down Control and then press D)

sys

interface Vlan-interface1
 ip address 192.168.1.80 255.255.255.0
 undo shut

interface GigabitEthernet1/0/1
 port link-mode bridge
 port link-type access
 undo port access vlan
 undo shut

ip http enable
ip https enable

local-user admin
 password simple admin
 service-type http https
 authorization-attribute user-role network-admin

Now connect a cable to the port in the above and connect to https://192.168.1.80 (or whichever IP you have used)

The web interface may not give you many configuration options, so may not be of much use (I haven't used it before).

The real question though is why is the switch not allowing a flat network by default? It may be that the connection between the two switches is not working. Is it copper or fibre? Are you getting a link light on both ports. if not, check the cable. If the connection is fibre have you tried crossing over the fibre?

Is the switch new? If someone else has used it before and it contains their config, you could try the following to wipe the config. From the CLI, using the serial cable as mentioned earlier:

From user-mode (prompt should be <SWITCH>, if prompt is [SWITCH], type "return" and press enter)

delete startup.cfg
enter Y when prompted

delete startup.mdb
enter Y when prompted

reboot

enter N when asked to save config
enter Y when asked to reboot

When switch reloads it will have a default config and should allow a flat network out of the box. You may also be able to wipe the config using the web interface.

1

With only a single segment and a really 'flat' network there's no need to configure a switch, running a simple cable should be fine. If the links don't turn on, you might need a crossover cable, but the 5900 should support Auto MDI-X unless it's explicitly turned off.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.