1

I have a small home lab setup.

I can ping 192.168.2.1 from a guest wireless client. I can ping google from the 2600 router.

#ping google.ca

Translating "google.ca"...domain server (8.8.8.8) [OK]

Type escape sequence to abort. Sending 5, 100-byte ICMP Echos to
172.217.10.99, timeout is 2 seconds: !!!!! Success rate is 100 percent (5/5), round-trip min/avg/max = 20/23/24 ms

For some reason the wireless guest client cannot resolve DNS? The client gets DHCP from the router.

Cisco 2600 config.

no network-clock-participate slot 1
no network-clock-participate wic 0
no aaa new-model
ip subnet-zero
ip cef
!
!
ip name-server 8.8.8.8
ip dhcp excluded-address 10.2.0.1 10.2.0.64
ip dhcp excluded-address 10.3.0.1 10.3.0.64
!
ip dhcp pool GUEST_POOL
   network 10.2.0.0 255.255.255.0
   default-router 10.2.0.1
   dns-server 10.1.0.1
   domain-name net.guest
!
ip dhcp pool NET_POOL
   network 10.3.0.0 255.255.255.0
   domain-name net.net
   dns-server 10.3.0.1
   default-router 10.3.0.1
!
!
!
!
 !
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet0/0.1
 description MGMT
 encapsulation dot1Q 1 native
 ip address 10.1.0.1 255.255.255.0
 no ip redirects
 ip nat inside
!
interface FastEthernet0/0.2
 encapsulation dot1Q 2
 ip address 10.2.0.1 255.255.255.0
 no ip redirects
 ip nat inside
!
interface FastEthernet0/0.3
 encapsulation dot1Q 3
 ip address 10.3.0.1 255.255.255.0
 no ip redirects
!
interface FastEthernet0/1
 description Outside
 ip address dhcp
 ip nat outside
 duplex auto
 speed auto
!
ip nat inside source list NAT-2-INTERNET interface FastEthernet0/1 overload
no ip http server
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.2.1
!
!
!
ip access-list extended NAT-2-INTERNET
 permit ip 10.2.0.0 0.0.0.255 any
1
  • If you use the Quoted text feature for the router ping, you are going to get people constantly trying to change it to Preformatted text, which is what it properly is.
    – Ron Maupin
    Jun 8 '17 at 1:00
1

You have the router interfaces as what the DHCP client gets for it DNS server, but you do not have a DNS server running on the router, which is really a bad idea, anyway.

You could do something like:

ip dhcp pool GUEST_POOL
   network 10.2.0.0 255.255.255.0
   default-router 10.2.0.1
   dns-server 8.8.8.8
   domain-name net.guest
!
ip dhcp pool NET_POOL
   network 10.3.0.0 255.255.255.0
   domain-name net.net
   dns-server 8.8.8.8
   default-router 10.3.0.1
!

That will assign the same DNS server to the clients that you are using for the router's DNS server, which you proved works because you can use it from the router.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.