0

We've setup LACP (802.3ad) on our Juniper switch and a Linux host, connected to the switch with 3x 1Gbps links. We are able to download from multiple sources at a rate of 3 Gbps, but when uploading files to different destinations, we get a maximum of 1 Gbps. Interestingly, only 1 uplink appears to be used by the Linux host to upload (to different destinations) :

Interface: ge-0/0/34, Enabled, Link is Up
Encapsulation: Ethernet, Speed: 1000mbps
Traffic statistics:
  Input bytes:             9874189047641 (981736896 bps)
  Output bytes:            5641687864781 (440210816 bps)

Interface: ge-0/0/36, Enabled, Link is Up
Encapsulation: Ethernet, Speed: 1000mbps
Traffic statistics:
  Input bytes:                6194266205 (1016 bps)                    
  Output bytes:            5368956712475 (400087456 bps)

Interface: ge-0/0/44, Enabled, Link is Up
Encapsulation: Ethernet, Speed: 1000mbps
Traffic statistics:
  Input bytes:             1494878289802 (1016 bps)
  Output bytes:           11897014259103 (469673216 bps)

Input and output are flipped over.

We basically followed this tutorial : http://phreek.org/blog/2014/11/centos-7-lacp-network-bonding

And setup LACP as usual on our switch.

# show system rollback 2 compare 1
[edit chassis]
-   aggregated-devices {
-       ethernet {
-           device-count 1;
-       }
-   }
[edit interfaces ge-0/0/34]
-    ether-options {
-        802.3ad ae0;
-    }
[edit interfaces ge-0/0/34]
+    unit 0 {
+        family ethernet-switching;
+    }
[edit interfaces ge-0/0/36]
-    ether-options {
-        802.3ad ae0;
-    }
[edit interfaces ge-0/0/36]
+    unit 0 {
+        family ethernet-switching;
+    }
[edit interfaces ge-0/0/44]
-    ether-options {
-        802.3ad ae0;
-    }
[edit interfaces ge-0/0/44]
+    unit 0 {
+        family ethernet-switching;
+    }
[edit interfaces]
-   ae0 {
-       aggregated-ether-options {
-           lacp {
-               active;
-               periodic fast;
-           }
-       }
-       unit 0 {
-           family ethernet-switching;
-       }
-   }
[edit vlans SERVER-130 interface]
+    ge-0/0/44.0;
+    ge-0/0/36.0;
+    ge-0/0/34.0;
-    ae0.0;

Any idea?

  • Did any answer help you? If so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you can provide and accept your own answer. – Ron Maupin Feb 19 '18 at 4:36
1

Try to change transmit hash policy to layer3+4

More info here.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.