1

I've got a few questions related to networking, more specifically VLAN'ing.

I've got a Gateway/Router - Ubiquiti USG

I've got a 48Port Netgear Switch - Netgear GS748Tv5 L2+/L3 Lite

I've got 5 Ubiquiti UniFi Wireless Access Points connected to the Netgear switch

Can someone give me some basic documentation on how I should go about setting up multiple VLAN's on both devices.

I have created the 4 Networks that I wish to operate. All have DHCP on for their respective IP ranges. Network A - Private | 192.168.15.x | VLAN ID 1

Network B - Guest | 192.168..x | VLAN ID 50

Network C - AV | 192.168..x | VLAN ID 20

Network D - POS | 192.168..x | VLAN ID 10

I need Network A to be able to access the WAN & Network D I need Network B to be able to access the WAN Only I need network C to be able to access the WAN and potentially a device on Network A I need network D to be able to access Network A and one device to access the WAN.

Each Network is going to be accessible via Wifi, and the Wifi Points are Ubiquiti devices, so they seem to integrate quite easily into the Ubiquiti controller and have had the VLAN ID's associated with the respective Wifi networks.

For wired devices I know I can set certain ports on the switch to automatically assign those devices to a certain VLAN so that will solve the issue of handling wired devices in a VLAN scenario.

Currently I'm not getting any DHCP out of the router when I connect to a Wifi network other than the default one.

I know I must be missing a step somewhere but I'm not confident on what I've missed. I have created the VLAN's in the switch but I'm not sure if the switch is letting the DHCP traffic go from the USG port to the Wifi devices?

Any help with this is greatly appreciated.

  • Sorry network B is 192.168.3.x Sorry network C is 192.168.10.x Sorry network D is 192.168.0.x – WellConnectedIT Jun 29 '17 at 7:04
  • Did any answer help you? If so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you could provide and accept your own answer. – Ron Maupin Aug 29 '17 at 3:51
1

Well, there is a lot here and a few different places it could be:

  1. Make sure the interfaces on your USG are set as tagged interfaces so they are dropping their info tagged into the switch.

  2. You said you need some east/west (vlan to vlan) communication blocked. Do you have any rules on the USG preventing that now?

  3. Make sure the interface going to your USG and to your APs are setup as trunks and are configured to pass the tagged traffic (have the VLANs configured on them). If the USG configured anything like the Ubiquity switch I've configured, the interfaces are a little tricky from the GUI. Configure the VLAN and then make sure on the interface facing your Netgear they are set to "T" for trunk (if I remember right - I can't get into my switch for some reason right now...)

  4. Have you verified you get DHCP addresses on those other VLANs when wired? If so, then it's an issue with tagging to your APs (we #3). If not, you might have a tagging issue or interface configuration issue going to your USG (#1, #2 or even possibly #3).

  • Thanks for your response @DangerZone I just got a chance to take a look onsite now, – WellConnectedIT Jul 3 '17 at 7:30
  • I'm still getting an issue with this, the Netgear switch has two VLAN configuration modes, one is under the switching menu option and the other is under the routing menu option. Excuse my ignorance, I tried using the switching option , I set the USG & the POE Switch(AP's) to Tagged on all VLAN's, as soon as I did that I seemed to lose internet access(only on the primary VLAN - as I still can't get DHCP working, to test on any other VLANs) The USG doesn't have an interface to set as tagged from what i've googled. There are no rules restricting traffic E2W on the USG. – WellConnectedIT Jul 4 '17 at 23:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.