1

Debugging an issue where I'm trying to get q-in-q working on an Arista 7050S with a loopback.

I’ve got packets egressing the switch double tagged but in ingress, I can see them on the STAG’s SVI. I’m assuming that they’re being punted to the control-plane. Both TPID’s are 0x8100.

interface Ethernet1
   description QINQ PORT
   switchport trunk allowed vlan 1001
   switchport mode trunk
   spanning-tree bpduguard disable
   spanning-tree bpdufilter disable
   spanning-tree guard none

interface Ethernet2
   description LOOPBACK CONNECTED TO ET3
   switchport access vlan 1001
   switchport mode dot1q-tunnel
   spanning-tree bpduguard disable
!
interface Ethernet3
   description LOOPBACK CONNECTED TO ET2
   switchport trunk allowed vlan 100-104
   switch port mode trunk
   spanning-tree bpduguard disable

Correctly formatted packets being received on a host connected to Et1:

tcpdump: listening on ens2f1np1, link-type EN10MB (Ethernet), capture size 262144 bytes
23:02:56.339095 00:1c:73:68:50:a1 (oui Unknown) > 00:0f:53:3f:1e:31 (oui Unknown), ethertype 802.1Q (0x8100), length 122: vlan 1001, p 0, ethertype 802.1Q, vlan 103, p 0, ethertype IPv4, (tos 0x0, ttl 64, id 32392, offset 0, flags [none], proto ICMP (1), length 100)

Packets being recieved on SVI 1001 on the 7050:

tcpdump: listening on vlan1001, link-type EN10MB (Ethernet), capture size 65535 bytes
13:12:00.776276 00:0f:53:3f:1e:31 (oui Unknown) > 00:1c:73:68:50:a1 (oui Arista Networks), ethertype 802.1Q (0x8100), length 102: vlan 103, p 0, ethertype IPv4, (tos 0x0, ttl 64, id 37014, offset 0, flags [DF], proto ICMP (1), length 84)
    1.0.0.4 > 1.0.0.3: ICMP echo request, id 4856, seq 1973, length 64

Any ideas? Hair is being pulled.

1 Answer 1

0

In the end it was discovered the switch was performing as expected but the internal SVI was unable respond. It appears as if it's not possible to present QinQ SVI over the TridentII capable Aristas.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.