1

That title is kind of cluttered so let me try and clear it up.

My equipment:

  • Two IP Codecs (I'll just refer to them as hosts from here on out)
  • Cisco 3560-x Catalyst Switch

The problem:

I work in radio IT, and I have one main AOIP switched network (192.168.87.0/24) for the majority of our end devices (nodes, automation machines, consoles, etc...), but (and had I been here when the network was designed, I would not have done it this way) there are two devices, our AOIP STLs that take audio from the studio to the transmitter. Those are my two hosts in question. Their network is 192.168.100.0/24, with the two hosts being 192.168.100.100/24 and 192.168.100.101/24. I want to ping 192.168.100.0 from 192.168.87.0. The management VLAN is VLAN 1 with the ip address 192.168.87.21.

What I've tried:

I know intervlan routing is probably the answer here, but I'm not sure how to implement it with just a lone switch.

I tried just a simple:

en
conf t
vlan 50
name Trango
exit
int vlan 50
descr Vlan for the Trango systems
ip add 192.168.100.105 255.255.255.0
no sh

And obviously I wasn't able to ping 192.168.100.105. What part of the process am I missing?

5 Answers 5

1

To send traffic between VLANs, you need to route it between the VLANs (hence, router). If your switch has the proper licensing (IP Base or above license) to be a layer-3 switch (can route), then you need to enable it with the ip routing command. You will also need to create the layer-3 interfaces (SVIs) for each VLAN for which you want to route. Then assign each interface to the proper VLAN. Each host will need to have the IP address of the SVI for its VLAN configured as its gateway.

In the case of a layer-2 switch (LAN Base license), you will need to have an external router. You can trunk the VLANs to the router, where you will create subinterfaces for each VLAN, and the router can route between the VLANs. Each host will need to have the IP address of the router VLAN interface for its VLAN configured as its gateway.

1

Backup your current config and use the following commands after your own research and your own risk. I typed all this on the fly so I may have missed something. Please backup your config before testing this. After setting these commands you need to add the gateway address to your devices. The VLAN interfaces we create below will be the gateways for those networks. If you already use a gateway for your current network do not add the interface vlan command for that vlan. Add another route like I did at the bottom. I'll put an example. Also, just a note, vlan 1 isn't suggested to use as a security measure. Most sites do, but I wanted to make the note.

enable
config t
ip routing
interface vlan 1 (use your vlan numbers)
ip address 192.168.87.1 255.255.255.0 (use the IP address you want to be your gateway)
exit
interface vlan 2 (use your vlan numbers)
ip address 192.168.100.1 255.255.255.0 (use the IP address you want to be your gateway)
exit
int g0/1 (use your interface number)
switchport mode access
switchport access vlan 1 (use your vlan)
exit
int g0/2 (use your interface number of your vlan 2 devices)
switchport mode access
switchport access vlan 2 (use your vlan)
exit
(if you have an uplink to another switch)
int g0/24 (use your uplink interface number)
switchport mode trunk (do this on both switches)
exit
ip route 0.0.0.0 192.168.#.# (ip of your next hop toward the internet. If this is your current vlan 1 gateway for 192.168.87.0 network do not give the interface vlan 1 the same IP address as your next hop. Give it an IP address different than your next hop like 192.168.87.2 or no ip address at all if you have a management IP address already)
exit
exit
copy run start (this saves the config so at a reboot you don't loose it)

Then backup your switch somewhere.

0

Both of those answers were helpful and interesting to see the viewpoints. They helped me understand more about networking...here is what I ultimately did:
I assigned g0/38 an IP address of 192.168.100.105 and I created VLAN 50. I assigned g0/38 to access VLAN 50 and I was able to ping both the hosts that were connected to that interface.
So now, when I need to ping those hosts, I just wrote a script that gets into the switch and pings it for me. Not ideal, but best case considering IP routing can't be enabled and I don't have a router that can be connected to that network.

4
  • This is not routing. You are simply pinging from one host to another host on the same VLAN.
    – Ron Maupin
    Jul 6, 2017 at 15:37
  • @RonMaupin I get that it's not routing, but ip routing isn't avaliable on the switch and I don't have a router with which to do inter vlan routing, so I figured this was probably the best I could do. Jul 6, 2017 at 15:38
  • It may be the best, or you could put another PC on the same VLAN too, but I just wanted to point out that you aren't really routing. In any case, you should accept your answer, or one of the others, so that the question doesn't keep popping up forever, looking for an answer.
    – Ron Maupin
    Jul 6, 2017 at 15:41
  • Probably not a bad idea to put a PC on there. And I want to accept my answer, but it says I can't until tomorrow. Jul 6, 2017 at 15:42
0

! THESE ARE COMMENTS AND WON'T BE ADDED TO THE SWITCH CONFIG

! MAKE SURE THE SWITCH PORTS CONNECTING YOUR HOSTS ON THE SAME SUBNET ARE ON THE SAME VLAN

! VLAN 1 IS CONFIGURED BY DEFAULT AND IS YOUR VLAN FOR SUBNET 192.168.87.0

! YOU NEED TO MAKE SURE THE HOSTS ON THAT SUBNET ARE ON VLAN 1

show vlan brief

! OR

show vlan

CHECK TO MAKE SURE YOUR HOSTS ON THE 192.168.87.0 IS MEMBER OF VLAN 1

conf t
vlan 2
 description VLAN FOR 192.168.100.0 SUBNET
vlan 1
 description VLAN FOR 192.168.87.0 SUBNET
interface vlan 1
 description GATEWAY IP OF YOUR 192.168.87.0 HOSTS
ip address 192.168.87.1 255.255.255.0
 no shutdown
interface vlan 2
 description GATEWAY IP OF YOUR 192.168.100.0 HOSTS
 ip address 192.168.100.1 255.255.255.0
 no shutdown
ip routing

CONFIGS BELOW ARE FOR YOUR 192.168.87.0 HOSTS a/b-e are switchport numbers so substitute them with real port numbers!

interface a/b
 switchport access vlan 1
 no shutdown
interface a/c
 switchport access vlan 1
 no shutdown

CONFIGS BELOW ARE FOR YOUR 192.168.100.0 HOSTS

interface a/d
 switchport access vlan 2
 switchport mode access
 no shutdown
interface a/e
 switchport access vlan 2
 switchport mode access
 no shutdown
0

No routing or inter-Vlan is required when different hosts on same VLANs wants to communicate .

As per your configuration

int vlan 50

descr Vlan for the Trango systems

ip add 192.168.100.105 255.255.255.0

Different hosts connected to same Vlan should communicate without any routing between them .

If your are still unable to communicate check network adapter properties configuration on both hosts

Ip address

Subnet mask

Gateway

And check further correct Vlan is passed in switch port that is Vlan 50.

2
  • The question was asked in july 2017. I doubt it is still relevant to ask OP to check anything.
    – JFL
    Dec 10, 2020 at 14:04
  • Its irrelavent when users is asking question . It's my analysis and opinions towards question . Moreover question is still open to answer . Dec 10, 2020 at 16:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.