2

I checked the vrf routing tables and the CE's network is present but I cannot ping it from anywhere. I will provide the PEs' configuration files and the CEs'. Any ideas?My topology

PE1 configuration file(R2)

Current configuration : 1892 bytes
!
version 12.4
!
hostname R2
!
!
ip cef
no ip domain lookup
!
!
ip vrf customer1
 rd 1111:1
 route-target export 1111:1
 route-target import 1111:1
ip tcp synwait-time 5
interface Loopback1
 ip address 2.0.0.1 255.255.255.0
!
interface FastEthernet0/0
 ip vrf forwarding customer1
 ip address 195.160.1.2 255.255.255.252
 duplex half
!
interface FastEthernet1/0
 ip address 192.168.2.1 255.255.255.0
 duplex auto
 speed auto
 mpls ip
!
interface FastEthernet1/1
 ip address 192.168.1.1 255.255.255.0
 duplex auto
 speed auto
 mpls ip
!
router ospf 1
 router-id 2.2.2.2
 log-adjacency-changes
 redistribute connected
 network 2.0.0.0 0.0.0.255 area 0
 network 192.168.1.0 0.0.0.255 area 0
 network 192.168.2.0 0.0.0.255 area 0
!
router bgp 1111
 no synchronization
 bgp log-neighbor-changes
 neighbor 3.0.0.1 remote-as 1111
 neighbor 3.0.0.1 update-source Loopback1
 no auto-summary
 !
 address-family vpnv4
 neighbor 3.0.0.1 activate
 neighbor 3.0.0.1 send-community extended
 exit-address-family
 !
 address-family ipv4 vrf customer1
 redistribute connected
 no synchronization
 exit-address-family
!
ip route vrf customer1 195.160.1.0 255.255.255.252 192.168.2.1

PE2 configuration file(R3)

Current configuration : 1928 bytes
!
version 12.4
!
hostname R3
!
ip cef
no ip domain lookup
!
!
ip vrf customer1
 rd 1111:1
 route-target export 1111:1
 route-target import 1111:1
!
ip tcp synwait-time 5
!
!
interface Loopback1
 ip address 3.0.0.1 255.255.255.0
!
interface FastEthernet0/0
 ip vrf forwarding customer1
 ip address 196.170.2.1 255.255.255.252
 duplex half
!
interface FastEthernet1/0
 ip address 192.168.4.1 255.255.255.0
 duplex auto
 speed auto
 mpls ip
!
interface FastEthernet1/1
 ip address 192.168.1.2 255.255.255.0
 duplex auto
 speed auto
 mpls ip
!
router ospf 1
 router-id 3.3.3.3
 log-adjacency-changes
 redistribute connected
 network 3.0.0.0 0.0.0.255 area 0
 network 192.168.1.0 0.0.0.255 area 0
 network 192.168.4.0 0.0.0.255 area 0
 network 196.170.2.0 0.0.0.3 area 3
!
router bgp 1111
 no synchronization
 bgp log-neighbor-changes
 neighbor 2.0.0.1 remote-as 1111
 neighbor 2.0.0.1 update-source Loopback1
 no auto-summary
 !
 address-family vpnv4
 neighbor 2.0.0.1 activate
 neighbor 2.0.0.1 send-community extended
 exit-address-family
 !
 address-family ipv4 vrf customer1
 redistribute connected
 no synchronization
 exit-address-family
!
ip route vrf customer1 196.170.2.0 255.255.255.252 192.168.4.1

CE1 configuration file(R1)

version 12.4
!
hostname R1
!
ip cef
interface Loopback1
 ip address 1.0.0.1 255.255.255.0
!
interface FastEthernet0/0
 ip address 195.160.1.1 255.255.255.252
 duplex half
ip route 196.170.2.0 255.255.255.252 195.160.1.2

CE2 configuration file(R6)

version 12.4
!
hostname R6
!
!
ip cef
no ip domain lookup
ip tcp synwait-time 5
interface Loopback1
 ip address 6.0.0.1 255.255.255.0
!
interface FastEthernet0/0
 ip address 196.170.2.2 255.255.255.252
 duplex half
!
!
interface FastEthernet1/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
ip route 195.160.1.0 255.255.255.252 196.170.2.1
  • I advertised the loopback interfaces as '/32 networks' and pinging between the customer edges was successful, but only if I connect the two PEs directly. Is this due to iBGP not being able to work properly without a Route Reflector? – Kostas Dimitras Jul 18 '17 at 15:22
  • You don't even seem to run BGP on R4 and R5 At least, you are not forming neighbors with R2 and R3, based on your posted configurations. You simply didn't give us the R4 and R5 configurations. – Ron Maupin Jul 18 '17 at 15:26
  • I had eBGP configured between CE-PE but I switched that for static routing. The iBGP is running only between the 2 PEs. – Kostas Dimitras Jul 18 '17 at 15:36
  • Part of the problem is the incomplete configurations you have. We don't even see how you are getting the CE loopbacks into the PE routing table, nor do we see how routing is configured on R4 and R5. If you want help, you should include the full router configurations for all the routers. – Ron Maupin Jul 18 '17 at 15:50
  • Remember though: by default, BGP assumes that external peers are exactly one hop away. Using the loopback as a source interface puts Router1 two hops away from Router2. Thus, the ebgp-multihop feature must be enabled. – user3476261 Jul 18 '17 at 18:37
1

You don't have the 195.160.1.0/30 network in OSPF for R2. You are advertising the network connection for R6 into OSPF, but not the network connection for R1, so OSPF will not have the route to R1, but it will have the route to R2.

This is a problem because you are sending traffic for the other network through R4 and R5, but R4 and R5 have no way to know about this network.


Assuming you want to use iBGP to advertise the routes, R5 would never learn this route through iBGP because the iBGP speaker (R5) cannot learn iBGP originated routes (originated by R2) from another iBGP speaker (R3 or R4), which is why iBGP requires a full mesh or a mitigation (route reflectors or confederations).


Also, why are you using half duplex for the connections to R1 and R6? You should use auto, except under extraordinary circumstances that require half duplex.

  • You 're right I accidentally didn't advertise 195.160.1.0/30 but now I added it to the routing table but it's not showing up. I include it in the same area as the rest of them and I did the same thing for 196.170.2.0/30 ... (both are now in area 0) I didn't get why iBGP does not work that way. I have been told in the past that a Route Reflector is optional so I didn't add one. Could you elaborate briefly? The interfaces were set by the ios that way I didn't mess with them, I only noticed it just now 'cause you pointed out! @Ron_Maupin – Kostas Dimitras Jul 17 '17 at 17:55
  • Well, you are not using VRFs in OSPF. As far as iBGP goes, the rule is that an iBGP speaker cannot learn iBGP originated routes from another iBGP speaker. That is a requirement for loop prevention. That forces you to implement a full mesh, or use a mitigation. If you have an IGP, like OSPF, you can create a full mesh with your four routers by creating neighborships with each of the other three routers. That doesn't scale for large implementations, which is where route reflectors and/or confederations come into play. – Ron Maupin Jul 17 '17 at 18:06
  • The VRF routing tables do contain the two afformentioned networks though. So, in this scenario, if i connect R2 with R3 will and R4 with R5 it's gonna work? – Kostas Dimitras Jul 17 '17 at 18:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.