1

enter image description here

Everything works other than the fact that HOST cannot ping the DNS server or anything beyond Router1. I can ping all hosts and Google from both Router1 and Router 2. Host can ping FE0/1 on Router1 and everything else in between. Just can't ping beyond Router1. I think I may have a routing table issue on the host but cant figure it out.

Router1

hostname Router1  

ip source-route     
!  
ip dhcp excluded-address 192.168.1.100 192.168.1.200  
!  
ip dhcp pool CLIENT  
 import all  
 network 192.168.1.0 255.255.255.0  
 default-router 192.168.1.1   
 dns-server 75.114.81.1 75.114.81.2   
!  
!  
!  
ip name-server 75.114.81.1  
ip name-server 75.114.81.2  
!  
interface FastEthernet0/0  
 ip address 192.168.1.1 255.255.255.0  
 ip nat inside  
 ip virtual-reassembly in  
 duplex auto  
 speed auto  
 no mop enabled  
!    
interface FastEthernet0/1  
 ip address dhcp  
 ip nat outside  
 ip virtual-reassembly in  
 duplex auto  
 speed auto  
!         
ip forward-protocol nd  
!  
no ip http server  
no ip http secure-server  
!   
ip nat inside source list 1 interface FastEthernet0/1 overload  
ip route 0.0.0.0 0.0.0.0 FastEthernet0/1  
ip route 192.168.2.0 255.255.255.0 192.168.1.100  
!  
access-list 1 permit 192.168.1.0 0.0.0.255  
access-list 2 permit 192.168.2.0 0.0.0.255  
!  
!  

Router2

!  
hostname Router2
!  

!  
ip source-route     
!  
!  
!  
ip name-server 75.114.81.1  
ip name-server 75.114.81.2  
!  
interface FastEthernet0/0  
 ip address 192.168.1.100 255.255.255.0  
 duplex auto  
 speed auto  
 no mop enabled  
!  
interface FastEthernet0/1  
 ip address 192.168.2.1 255.255.255.0  
 duplex auto  
 speed auto  
!  
ip forward-protocol nd  
!  
no ip http server  
no ip http secure-server  
!  
ip default-network 192.168.1.0   
ip route 0.0.0.0 0.0.0.0 192.168.1.1  

**Host**  
Kernel IP routing table  
Destination           Gateway         Genmask            Flags Metric Ref    Use Iface  
0.0.0.0            192.168.2.1        0.0.0.0         UG    0      0        0 enp0s25  
192.168.2.0        0.0.0.0            255.255.255.0   U     0      0        0 enp0s25  
192.168.122.0      0.0.0.0            255.255.255.0   U     0      0        0 virbr0  
1
  • Did any answer help you? If so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you could provide and accept your own answer.
    – Ron Maupin
    Aug 29 '17 at 18:57
0

Your NAT does not include the 192.168.2.0/24 network. You should either put that in access list 1 (you have it in access list 2), or add a NAT statement for access list 2.

For example (Router1):

ip nat inside source list 1 interface FastEthernet0/1 overload
!
access-list 1 permit 192.168.1.0 0.0.0.255
access-list 1 permit 192.168.2.0 0.0.0.255
!

or

ip nat inside source list 1 interface FastEthernet0/1 overload
ip nat inside source list 2 interface FastEthernet0/1 overload
!
access-list 1 permit 192.168.1.0 0.0.0.255
access-list 2 permit 192.168.2.0 0.0.0.255
!

You should not use the ip default-gateway commands on a router that is acting as a router, and the ip default-network command is really for IGRP, which doesn't understand the default route; you can use a static default route, as you have configured.

Cisco has a document that explains the differences: Configuring a Gateway of Last Resort Using IP Commands.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.