2

I am looking to reproduce a configuration that I have quite easily achieved on the Cisco Small Business Series SG500 family of switches. The configuration is for Auto Voice VLAN, triggered by CDP and/or LLDP, which results in dynamic interface configuration for a compatible device (i.e. Cisco phone) such that said interface sets the appropriate voice VLAN, native VLAN, and DSCP and CoS Values (46 and 5 respectively) are set for traffic on the Voice VLAN.

The resulting behavior is a compatible phone can be plugged into a port and will operate in the Voice VLAN while a computer connected to the phones switch port will enter the native VLAN. Again, voice traffic has DSCP/CoS values set as mentioned above.

I am comfortable with basic configuration of the Catalyst and have a CCNA in Routing and Switching...which does not cover these topics. From my research I gather that there are at least two separate components to achieving this configuration:

  1. Configuration of the Voice VLAN: http://www.cisco.com/c/en/us/td/docs/switches/lan/catalyst2960x/software/15-0_2_EX/vlan/configuration_guide/b_vlan_152ex_2960-x_cg/b_vlan_152ex_2960-x_cg_chapter_0110.html

  2. Configuration of Auto Smartport: http://www.cisco.com/c/en/us/td/docs/switches/lan/catalyst2960x/software/15-0_2_EX/autosmartports/configuration_guide/iosaspcg2960X/configure.html

By coupling these concepts together, should I be able to craft a configuration that achieves my objectives?

Is there anything else I should consider?

  • You port will only need the configuration switchport access vlan <PC vlan> and switchport voice vlan <phone vlan> to achieve what you want, assuming you've set the switchport mode to access. – user36472 Aug 4 '17 at 10:49
3

This is done all the time. Under a switch interface, you simply define a voice VLAN with the switchport voice vlan command. Something like this:

interface range GigabitEthernet1/0/1
 switchport access vlan 10
 switchport voice vlan 110
 switchport mode access
 no shutdown
!

The switchport access vlan command defines the data VLAN, and the switchport voice vlan command defines the voice VLAN. With Cisco phones, CDP will negotiate a trunk (the phone acts as a switch), or if there is no phone, then the interfaces acts as an access interface. You can enable LLDP on the interface for non-Cisco phones:

lldp run
!
interface range GigabitEthernet1/0/1
 switchport access vlan 10
 switchport voice vlan 110
 switchport mode access
 lldp transmit
 lldp receive
 no shutdown
!
  • Thanks @Ron Maupin, how is QoS handled by default on the Voice VLAN if I simply execute the above captioned commands? Or is it not at all? In general besides voice traffic traveling in the Voice VLAN will anything in terms of QoS or queuing behavior of voice traffic be impacted? – sardean Aug 4 '17 at 18:22
  • 1
    That varies by IOS version. The 2960 series has historically needed to use port-based QoS, not VLAN-based QoS available on some other switch models. I also believe that unless you specifically mark the traffic or trust on the interface, the switch will reset all traffic to BE. You can create ACLs to use with a service policy to mark the traffic, and you can do layer-2 queuing on the interfaces. – Ron Maupin Aug 4 '17 at 19:22
  • it looks like leveraging the Auto Smartport feature that I linked to in my original post might be the easiest way to achieve both the VLAN config and port based QoS config in a single shot dynamically by the triggering of the appropriate macro. Thoughts? – sardean Aug 4 '17 at 20:30
  • 1
    If you are marking the traffic before it enters the switch, you could simply configure mls qos trust dscp on the switch interface. – Ron Maupin Aug 4 '17 at 21:42
  • 1
    A phone should mark the VoIP traffic. You will get two different markings from the phone: the VoIP traffic, and the VoIP control traffic (which should not be marked EF like the VoIP traffic). You can trust the phone traffic. – Ron Maupin Aug 4 '17 at 21:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.