1

I have a Linux device with two NICs, but they seem to share one MAC address. I want to configure a redundant network connection to a switch stack. Whenever I restart the end device, it is shutting down the switch interfaces with BPDU errors, or it appears to flap the port.

What configuration do I need to use to make this work?

interface GigabitEthernet2/0/7
description *** CCTV ENCODER-201 ***
switchport access vlan 101
switchport mode access
switchport nonegotiate
channel-group 17 mode on
service-policy input CLASSIFY
!



interface GigabitEthernet3/0/7
description *** CCTV ENCODER-201 ***
switchport access vlan 101
switchport mode access
switchport nonegotiate
channel-group 17 mode on
service-policy input CLASSIFY
!
1
  • Did any answer help you? If so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you can provide and accept your own answer.
    – Ron Maupin
    Feb 19 '18 at 17:50
1

You are setting the Cisco switch to channel unconditionally (channel-group 17 mode on), which may be a good idea from one Cisco switch to another, but the industry-standard protocol to channel is LACP (channel-group 17 mode active), and you must usually use that when connecting to other vendors' switches or servers from a Cisco switch.

You also need to make sure that the server is configured for LAG with LACP, but server configurations are off-topic here. You could ask about that on Server Fault for a business network, or on Super User or Unix & Linux for a personal network.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.