0

enter image description here

I have setup as shown in this picture.

I configured a bind9 dns server on ubuntu (192.168.242.11) When I set this as the DNS server for the Test Machine, it can resolve hosts perfectly well.

When I set this as the DNS server for the Windows machine, it can't resolve any hosts, but I can ssh into both the test machine and machine running bind9. Can someone help me to understand/solve this issue.

The output of the ipconfig/ifconfig for all the machine is as below:

Windows Machine:

$ ipconfig

Windows IP Configuration

Ethernet adapter Local Area Connection 2:

   Connection-specific DNS Suffix  . : mylan
   Link-local IPv6 Address . . . . . : fe80::24e8:9096:7960:a471%14
   IPv4 Address. . . . . . . . . . . : 172.16.176.26
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . : 172.16.176.254

Tunnel adapter isatap.mylan:

Test Machine

$ ifconfig
ens3      Link encap:Ethernet  HWaddr fa:16:3e:98:89:eb
          inet addr:192.168.242.110  Bcast:192.168.243.255  Mask:255.255.254.0
          inet6 addr: fe80::f816:3eff:fe98:89eb/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1450  Metric:1
          RX packets:21507 errors:0 dropped:0 overruns:0 frame:0
          TX packets:6608 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:25769363 (25.7 MB)  TX bytes:651407 (651.4 KB)

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:175 errors:0 dropped:0 overruns:0 frame:0
          TX packets:175 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1
          RX bytes:12785 (12.7 KB)  TX bytes:12785 (12.7 KB)

DNS Server

$ ifconfig
ens3      Link encap:Ethernet  HWaddr fa:16:3e:6e:42:ad
          inet addr:192.168.242.11  Bcast:192.168.243.255  Mask:255.255.254.0
          inet6 addr: fe80::f816:3eff:fe6e:42ad/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1450  Metric:1
          RX packets:33315 errors:0 dropped:0 overruns:0 frame:0
          TX packets:14785 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:31733125 (31.7 MB)  TX bytes:1727701 (1.7 MB)

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:268 errors:0 dropped:0 overruns:0 frame:0
          TX packets:268 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1
          RX bytes:22934 (22.9 KB)  TX bytes:22934 (22.9 KB)

closed as off-topic by Ron Trunk, Teun Vink Sep 2 '17 at 19:02

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "NE is a site for to ask and provide answers about professionally managed networks in a business environment. Your question falls outside the areas our community decided are on topic. Please visit the help center for more details. If you disagree with this closure, please ask on Network Engineering Meta." – Ron Trunk, Teun Vink
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 2
    Just because SSH is allowed between the two networks doesn't mean that DNS is allowed. What is the configuration of the devices acting as gateways and what is in between the two networks? – YLearn Sep 2 '17 at 6:10
  • I am not sure about it. How can I find it out? – Koustubh Sep 2 '17 at 6:33
1

As YLearn alluded to, it sounds like either the routing device between the two networks is blocking the connection, or the DNS server isn't allowing DNS traffic from outside the LAN it is on.

  • Double check you entered the right dns ip address on the nic. Since you didn't do ipconfig /all we can't see what is trying to use. Usually, windows firewall doesn't block dns but temporarily disable it to "check it off the list" – Fixitrod Sep 4 '17 at 18:12

Not the answer you're looking for? Browse other questions tagged or ask your own question.