1

I have a Juniper EX2200-C switch that I am trying to setup and running into issues with. Unfortunately the Juniper website is not much help. I've managed to setup the device's root login and enabled DHCP on the management port for now. I have an Ethernet cable going from the management port on the switch (me0) to my internet provider's modem (Verizon FIOS). From the switch I can now ping external IP addresses so it looks like the default route it setup correctly.

What I would like to do is hook-up ge-0/0/0 to the back of my Internet provider's modem (Verizon FIOS), and then plug in my fixed devices to the other ge-0/0/# ports. The modem is running DHCP and hands out addresses to all of the devices on my network. I'd just like to use this switch to connect all of the devices together.

However, when I plug an Ethernet cable between the back of the FIOS modem and any of the 12 Gigabit Ethernet ports on the switch, it seems like the link is dead. The status light does not come on at all, even if I configure DHCP on the port and "commit and-quit".

# show interfaces ge-0/0/0
unit 0 {
     family inet {
         dhcp;
     }
}

Does each port have to be manually enabled with JunOS switches, and is there a command for that? I'm used to Cisco devices where the switch ports work out of the box. Or could this mean that my switch is defective? It seems odd that all 12 ports are not working though, yet the me0 and console ports are fine...

  • 1
    the ports should be enabled by default , can you post the output of show command ? – Mr.lock Sep 5 '17 at 4:39
  • Does the switch have any existing configuration or does it have default configuration? The ports should work of out the box. – Indigo Sep 5 '17 at 18:00
  • Did any answer help you? If so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you can provide and accept your own answer. – Ron Maupin Feb 19 '18 at 18:26
3

For layer 2 switching, these ports need to be configured for family ethernet-switching.

ge-0/0/1 {
    unit 0 {
        family ethernet-switching {
        }
    }
}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.