6

From an tftp server I'm trying to import the config to startup-config using

copy tftp startup-config 10.0.0.10 5006zl.cnf

The switch asks for confirmation y/n and when pressing y it just aborts saying that the config could not be loaded.

show logging -r shows

W 09/03/17 06:08:11 00158 update: AM1: line 0. Action is ignored in download
            mode.
I 09/03/17 06:08:10 00131 tftp: AM1: Transfer completed
W 09/03/17 06:05:45 00158 update: AM1: line 0. Action is ignored in download
            mode.
I 09/03/17 06:05:45 00131 tftp: AM1: Transfer completed
W 09/03/17 06:03:00 00158 update: AM1: line 0. Action is ignored in download

Flash information about the switch: show flash

Image             Size (bytes) Date     Version 
----------------- ------------ -------- --------------
Primary Image    :    16575066 09/01/16 KB.15.18.0013        
Secondary Image  :    30307157 03/30/17 KB.16.02.0018       

Boot ROM Version 
----------------
Primary Boot ROM Version   : KB.16.01.0006
Secondary Boot ROM Version : KB.16.01.0006

Default Boot Image   : Secondary
Default Boot ROM     : Primary

Running config on the switch: show running-config

; J9850A Configuration Editor; Created on release #KB.16.02.0020
; Ver #10:08.01.81.b3.ff.7c.59.fc.7b.ff.ff.fc.ff.ff.3f.ef:5a
......
......

Config on the tftp server is also

; J9850A Configuration Editor; Created on release #KB.16.02.0020
; Ver #10:08.01.81.b3.ff.7c.59.fc.7b.ff.ff.fc.ff.ff.3f.ef:5a

My suspicion is that the versions of running-config and show flash don't match. Is this known? How could I solve this?

Update 1

Output of sed -n l 5006zl.cnf and or cat -vEt 5006zl.cnf

; J9850A Configuration Editor; Created on release #KB.15.18.0013$
; Ver #0d:10.80.7c.00.f4.6b.ff.f7.fc.7f.ff.3f.ef:da$
hostname "r11-06-sw-11"$
module A type j9538a$
module B type j9538a$
module E type j9550a$
module F type j9538a$
fault-finder broadcast-storm sensitivity high$
fault-finder bad-driver sensitivity high$
fault-finder bad-transceiver sensitivity high$
fault-finder bad-cable sensitivity high$
fault-finder too-long-cable sensitivity high$
fault-finder over-bandwidth sensitivity high$
fault-finder loss-of-link sensitivity high$
fault-finder duplex-mismatch-hdx sensitivity high$
fault-finder duplex-mismatch-fdx sensitivity high$
fault-finder link-flap sensitivity high$
trunk E24 trk10 dt-lacp$
.....
.....
3
  • This may be due to invalid line breaks in the config on the TFTP server - all errors refer to line 0. You should check whether each line is terminated by \n (linefeed). – Zac67 Sep 5 '17 at 11:09
  • @Zac67 I've checked that though and all lines are terminated by $. See update. – Valentin Bajrami Sep 6 '17 at 7:54
  • As a test, try uploading the current conf to the TFTP server, and then check the line breaks in the output from the switch. Is this issue affecting several switches that you've tried to download this conf to, or just a single switch? – Stuggi Nov 27 '17 at 9:20
1

Incidentally, I stumbled on a likely explanation for the described problem. Your suspicion is most probably correct: the switch does seem to verify the firmware version in the config with the actually running version.

When exported using the add-ignore-tag option, the first line is changed to e.g.

; J9850A IGNORE Configuration Editor; Created on release #KB.15.18.0013$

If you edit the config to be imported in the same way it should work, regardless of the firmware version.

1
  • 1
    Hi Zac. Thank you for your reply. Unfortunately I cannot verify this answer sinice I don't work at that company anymore but I assume this could be the correct one. add-ignore-tag might be of importance here. I did not know such thing existed so glad I learned something new today. Viel dank! – Valentin Bajrami Jul 21 at 13:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.