2

I am new to this so forgive me for mistakes, but I feel like I am missing something here.

I am trying to use a loopback address as the router ID for Router0 in my network. I am typing in:

Router(config)#int loopback 0
Router(config-if)#ip address 1.1.1.1 255.255.255.255
Router(config-if)#
Router(config-if)#exit
Router(config)#do show ip int brief
Interface              IP-Address      OK? Method Status                Protocol 
FastEthernet0/0        150.45.101.1    YES manual up                    up 
FastEthernet1/0        unassigned      YES unset  administratively down down 
Serial2/0              200.200.200.3   YES manual up                    up 
Serial3/0              unassigned      YES unset  administratively down down 
FastEthernet4/0        unassigned      YES unset  administratively down down 
FastEthernet5/0        unassigned      YES unset  administratively down down 
Loopback0              1.1.1.1         YES manual up                    up
Router(config)#

So we can see that the loopback has been configured, but when I show the router ID it is still showing the serial interface as its ID.

Router(config)#do show ip ospf
 Routing Process "ospf 100" with ID 200.200.200.3
Supports only single TOS(TOS0) routes
 Supports opaque LSA
 It is an area border router
 SPF schedule delay 5 secs, Hold time between two SPFs 10 secs
 Minimum LSA interval 5 secs. Minimum LSA arrival 1 secs
 Number of external LSA 0. Checksum Sum 0x000000
 Number of opaque AS LSA 0. Checksum Sum 0x000000
 Number of DCbitless external and opaque AS LSA 0
 Number of DoNotAge external and opaque AS LSA 0
 Number of areas in this router is 2. 2 normal 0 stub 0 nssa
 External flood list length 0
    Area BACKBONE(0) (Inactive)
        Number of interfaces in this area is 0
        Area has no authentication
        SPF algorithm executed 5 times
        Area ranges are
        Number of LSA 2. Checksum Sum 0x0137ce
        Number of opaque link LSA 0. Checksum Sum 0x000000
        Number of DCbitless LSA 0
        Number of indication LSA 0
        Number of DoNotAge LSA 0
        Flood list length 0
    Area 1
        Number of interfaces in this area is 1
        Area has no authentication
        SPF algorithm executed 2 times
        Area ranges are
        Number of LSA 0. Checksum Sum 0x000000
        Number of opaque link LSA 0. Checksum Sum 0x000000
        Number of DCbitless LSA 0
        Number of indication LSA 0
        Number of DoNotAge LSA 0
        Flood list length 0

To resolve this problem I tried this:

Router(config)#do clear ip ospf process
Reset ALL OSPF processes? [no]: y
Router(config)#

But when I run this command again I am getting the same results:

Router(config)#do show ip ospf
 Routing Process "ospf 100" with ID 200.200.200.3
Supports only single TOS(TOS0) routes
 Supports opaque LSA
 It is an area border router
 SPF schedule delay 5 secs, Hold time between two SPFs 10 secs
 Minimum LSA interval 5 secs. Minimum LSA arrival 1 secs
 Number of external LSA 0. Checksum Sum 0x000000
 Number of opaque AS LSA 0. Checksum Sum 0x000000
 Number of DCbitless external and opaque AS LSA 0
 Number of DoNotAge external and opaque AS LSA 0
 Number of areas in this router is 2. 2 normal 0 stub 0 nssa
 External flood list length 0
    Area BACKBONE(0) (Inactive)
        Number of interfaces in this area is 0
        Area has no authentication
        SPF algorithm executed 5 times
        Area ranges are
        Number of LSA 2. Checksum Sum 0x0137ce
        Number of opaque link LSA 0. Checksum Sum 0x000000
        Number of DCbitless LSA 0
        Number of indication LSA 0
        Number of DoNotAge LSA 0
        Flood list length 0
    Area 1
        Number of interfaces in this area is 1
        Area has no authentication
        SPF algorithm executed 2 times
        Area ranges are
        Number of LSA 0. Checksum Sum 0x000000
        Number of opaque link LSA 0. Checksum Sum 0x000000
        Number of DCbitless LSA 0
        Number of indication LSA 0
        Number of DoNotAge LSA 0
        Flood list length 0

And here is the running-config:

Router(config-if)#do show running-config

Building configuration...

Current configuration : 887 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
ip cef
no ipv6 cef
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
 ip address 150.45.101.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet1/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial2/0
 ip address 200.200.200.3 255.255.255.0
!
interface Serial3/0
 no ip address
 shutdown
!
interface FastEthernet4/0
 no ip address
 shutdown
!
interface FastEthernet5/0
 no ip address
 shutdown
!
router ospf 100
 log-adjacency-changes
 network 150.45.101.0 0.0.0.7 area 0
 network 200.200.200.0 0.0.0.3 area 0
!
ip classless
!
ip flow-export version 9
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
end

As we can see the router ID did not change, what is it that I am doing wrong here?

8
  • You need to give us more of the configuration. For example, the OSPF configuration could have a specific router ID configured (recommended as a best practice). The best thing is to edit your question with the full router configuration. – Ron Maupin Sep 13 '17 at 21:05
  • Unfamiliar with how to make it show up exactly as is shown on packet tracer, so you may have to edit the post again, but is this what you are looking for when you are asking for the full router configuration? Everything I have pasted here is the only thing I have done thus far on this router. – ComingofAge Sep 13 '17 at 21:29
  • What I mean is, edit your question to include the full running configuration (show running-config). Simply paste it into the question, and use the Preformatted Text ({}) button on it. – Ron Maupin Sep 13 '17 at 21:32
  • Okay I see, added the running-config. – ComingofAge Sep 13 '17 at 22:24
  • Likely, this is a bug in Packet Tracer. There are many small problems that you will find in it. You could try removing the OSPF (no router ospf 100), then add it back to see if it picks up the loopback. If not, it may be that you are not including that interface in the OSPF process. It is hard to say what Packet Tracer is doing. The best practice is to specifically set the OSPF router ID with the router-id <router-id> command. – Ron Maupin Sep 13 '17 at 22:29
6

Simply clearing the process may not be enough to re-start the RID selection process. That said, as Ron points out in the comments, it is by far best practice to manually specify the router ID in OSPF (and, indeed, all dynamic protocols) to avoid this kind of thing.

0

do wr reload 200.200.200.3>>>1.1.1.1

Assuming you are using GNS3

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.