1

My goal is to see if the interface gets more than 2gbps of traffic, just to see if it's true.

So I created a policy map with ACL that matches all, and all actions - violate, conform are set to transmit.

It looks like this:

ipv4 access-list test_for_isp
 10 permit ipv4 any any
class-map match-any class_test_isp
 match access-group ipv4 test_for_isp
 end-class-map
! 
policy-map traffic_test
 class class_test_isp
  police rate 1900 mbps 
   conform-action transmit
   exceed-action transmit
   violate-action transmit
  ! 
 ! 
 class class-default
 ! 
 end-policy-map

but i dont see any counters:

RP/0/RSP0/CPU0:ASR02#show policy-map interface all
Mon Sep 18 13:38:16.435 Summer
node0_0_CPU0: 
TenGigE0/0/2/3 input: traffic_test
Class class_test_simcentric
  Classification statistics          (packets/bytes)     (rate - kbps)
    Matched             :                   0/0                    0
    Transmitted         : N/A 
    Total Dropped       :                   0/0                    0
  Policing statistics                (packets/bytes)     (rate - kbps) 
    Policed(conform)    :                   0/0                    0
    Policed(exceed)     :                   0/0                    0
    Policed(violate)    :                   0/0                    0
    Policed and dropped :                   0/0                  
Class class-default
  Classification statistics          (packets/bytes)     (rate - kbps)
    Matched             :                   0/0                    0
    Transmitted         : N/A 
    Total Dropped       : N/A

So, please advise,

  1. Is my configuration bad?
  2. Are there any additional statistics that should be enabled?
  3. Maybe there're any other ways to see burst/peak rates on interfaces - using IOS XR.
  • 2
    Are you applying the policy on the input or output? – Ron Trunk Sep 18 '17 at 12:05
1

You should use the following commands:

show qos interface TenGigE 0/0/2/3 input

show qos interface TenGigE 0/0/2/3 output

You can check further at Cisco Page

  • than you, seems my previuos command works. It was a problem that the only traffic i received in previous setup was a control plane traffic (BGP, ARP). – saddayz Sep 18 '17 at 16:28
  • Good to know that :)! – Hung Tran Sep 18 '17 at 16:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.