I´m Brasilian, so excuse me any gramar error.

I have a cisco router ASR1001 (IOS XE Version: 03.08.01.S) and I need to connect it to a service provider running BGP ipv4. This service provider gave me the ip address 187.16.221.69/21 to setup as subinterface with dot1q vlan id 3404 and it´s necessary to reach 5 ip addresses inside this same /21 network, which is: 187.16.216.252 - 187.16.216.253 - 187.16.216.254 - 187.16.223.253 - 187.16.223.254.

From this subinterface I can only reach 2 of this ip addresses: 187.16.223.253 - 187.16.223.254

The other 3 ips I cannot not reach at all: 187.16.216.252 - 187.16.216.253 - 187.16.216.254.

I changed the connection of this service provider to a Switch Cisco 3560G configuring the same subinterface and I can reach all the 5 ip addresses without problem.

The service provider says that my router is not been able to learn 2048 (arp) mac address and because of that I cannot reach all the ip addresses of this network.

Anybody has any idea what kind of configuration could I check on the router to fix this problem ?


Follow more information and part of the configurations:

enter image description here

Now I need to reach these 5 ips and stablish bgp connection with them. It works only with 2 ip addresses. As I can see, the 5 ip addresses are on the same network, so they should work as L2 to reach all the ips of this network.

enter image description here

I trully believe that there is some kind of configuration that is not allowing the router to see this whole L2 /21 network, only part of it.

I cannot even ping the first 3 ips, only the 2 last ones from the router. But if I change this configuration to the switch I can reach all the 5 ips thru ping without problem.


    SPO_RT_BGP_02#show run
    Building configuration...

    Current configuration : 11911 bytes

!
! Last configuration change at 17:06:22 UTC Wed Sep 20 2017 by xxxxxxx
!
version 15.3
service timestamps debug datetime msec
service timestamps log datetime msec
no platform punt-keepalive disable-kernel-core
!
hostname SPO_RT_BGP_02
!
boot-start-marker
boot-end-marker
!
!
vrf definition Mgmt-intf
 !
 address-family ipv4
 exit-address-family
 !
 address-family ipv6
 exit-address-family
!
!
aaa new-model
!
!
aaa authentication login xxxxxxx local
aaa authorization console
aaa authorization config-commands
!
!
!
!
!
aaa session-id common
!
!
!
!
!


!
!
!
!
!
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
username xxxxxx privilege 15 password 0 xxxxxxx
!
redundancy
 mode none
!
!
!
ip tftp source-interface GigabitEthernet0
!
track 133 ip sla 133 reachability
!
track 187 ip sla 187 reachability
!
!
!
!
!
!
!
!
interface GigabitEthernet0/0/0
 no ip address
 negotiation auto
!
interface GigabitEthernet0/0/0.204
 description CLI_INTERNET_ATAQUE_PUBLICIDADE
 encapsulation dot1Q 204
 ip address XXX.XXX.XXX.XXX XXX.XXX.XXX.XXX
 standby 204 ip XXX.XXX.XXX.XXX
 standby 204 priority 160
 standby 204 preempt
!
interface GigabitEthernet0/0/0.2000
 description BGP com Level3
 encapsulation dot1Q 2000
 ip address XXX.XXX.XXX.XXX XXX.XXX.XXX.XXX
!
interface GigabitEthernet0/0/0.3000
 description BGP com VIVO
 encapsulation dot1Q 3000
 ip address XXX.XXX.XXX.XXX XXX.XXX.XXX.XXX
!
interface GigabitEthernet0/0/0.3404
 encapsulation dot1Q 3404
 ip address 187.16.221.69 255.255.248.0
!
interface GigabitEthernet0/0/1
 no ip address
 negotiation auto
!
interface GigabitEthernet0/0/1.1900
 description BGP com ALGAR
 encapsulation dot1Q 1900
 ip address XXX.XXX.XXX.XXX XXX.XXX.XXX.XXX
!
interface GigabitEthernet0/0/1.2500
 description BGP com AMERICANET
 encapsulation dot1Q 2500
 ip address XXX.XXX.XXX.XXX XXX.XXX.XXX.XXX
!
interface GigabitEthernet0/0/2
 no ip address
 negotiation auto
!
interface GigabitEthernet0/0/2.21
 description REDE_VALIDA_INTERNA_DADOS
 encapsulation dot1Q 21
 ip address XXX.XXX.XXX.XXX XXX.XXX.XXX.XXX
 standby 21 ip XXX.XXX.XXX.XXX
 standby 21 priority 160
 standby 21 preempt
!
interface GigabitEthernet0/0/2.22
 encapsulation dot1Q 22
 ip address XXX.XXX.XXX.XXX XXX.XXX.XXX.XXX
 standby 22 ip XXX.XXX.XXX.XXX
 standby 22 priority 160
 standby 22 preempt
!
interface GigabitEthernet0/0/2.24
 description REDE_VALIDA_INTERNA_VPNS_E_VOZ
 encapsulation dot1Q 24
 ip address XXX.XXX.XXX.XXX XXX.XXX.XXX.XXX
!
interface GigabitEthernet0/0/2.39
 description CLIENTE_TMCO
 encapsulation dot1Q 39
 ip address XXX.XXX.XXX.XXX XXX.XXX.XXX.XXX
!
interface GigabitEthernet0/0/3
 no ip address
 negotiation auto
!
interface GigabitEthernet0/0/3.25
 description REDE_VALIDA_VERAZ_II
 encapsulation dot1Q 25
 ip address XXX.XXX.XXX.XXX XXX.XXX.XXX.XXX
 standby 25 ip XXX.XXX.XXX.XXX
 standby 25 priority 160
 standby 25 preempt
!
interface GigabitEthernet0/0/3.26
 description REDE_VALIDA_VPN_CONCENTRADOR
 encapsulation dot1Q 26
 ip address XXX.XXX.XXX.XXX XXX.XXX.XXX.XXX
 standby 26 ip XXX.XXX.XXX.XXX
 standby 26 priority 160
 standby 26 preempt
!
interface GigabitEthernet0/0/3.27
 description REDE_VALIDA_SERVER_C5_E_SIMMODE
 encapsulation dot1Q 27
 ip address XXX.XXX.XXX.XXX XXX.XXX.XXX.XXX
 standby 27 ip XXX.XXX.XXX.XXX
 standby 27 priority 160
 standby 27 preempt
!
interface GigabitEthernet0/0/3.28
 description REDE_VALIDA_VPN_FOCO
 encapsulation dot1Q 28
 ip address XXX.XXX.XXX.XXX XXX.XXX.XXX.XXX
 standby 28 ip XXX.XXX.XXX.XXX
 standby 28 priority 160
 standby 28 preempt
!
interface GigabitEthernet0/0/3.1000
 encapsulation dot1Q 1000
 ip address XXX.XXX.XXX.XXX XXX.XXX.XXX.XXX
!
interface GigabitEthernet0/0/3.2381
 description REDE_VALIDA_OSASCO_TELES
 encapsulation dot1Q 2381
 ip address XXX.XXX.XXX.XXX XXX.XXX.XXX.XXX
!
interface GigabitEthernet0/0/3.2385
 description REDE_VALIDA_JAGUARE_TELES
 encapsulation dot1Q 2385
 ip address XXX.XXX.XXX.XXX XXX.XXX.XXX.XXX
!
interface GigabitEthernet0
 vrf forwarding Mgmt-intf
 no ip address
 shutdown
 negotiation auto
!
router bgp XXXXXX
 no bgp enforce-first-as
 bgp log-neighbor-changes
 neighbor 187.16.216.252 remote-as 20121
 neighbor 187.16.216.252 description PTT_LGC
 neighbor 187.16.216.253 remote-as 26162
 neighbor 187.16.216.253 description PTT_RS1
 neighbor 187.16.216.254 remote-as 26162
 neighbor 187.16.216.254 description PTT_RS2
 neighbor 187.16.223.253 remote-as 26162
 neighbor 187.16.223.253 description PTT_RS3
 neighbor 187.16.223.254 remote-as 26162
 neighbor 187.16.223.254 description PTT_RS4
 neighbor XXX.XXX.XXX.XXX remote-as XXXX
 neighbor XXX.XXX.XXX.XXX description BGP com AMERICANET
 neighbor XXX.XXX.XXX.XXX remote-as XXXXX
 neighbor XXX.XXX.XXX.XXX description BGP_VIVO
 neighbor XXX.XXX.XXX.XXX remote-as XXXXX
 neighbor XXX.XXX.XXX.XXX description BGP com LEVEL3 CJARDIM
 !
 address-family ipv4
  network XXX.XXX.XXX.XXX mask XXX.XXX.XXX.XXX
  network XXX.XXX.XXX.XXX mask XXX.XXX.XXX.XXX
  network XXX.XXX.XXX.XXX mask XXX.XXX.XXX.XXX
  network XXX.XXX.XXX.XXX mask XXX.XXX.XXX.XXX
  network XXX.XXX.XXX.XXX mask XXX.XXX.XXX.XXX
  network XXX.XXX.XXX.XXX mask XXX.XXX.XXX.XXX
  network XXX.XXX.XXX.XXX mask XXX.XXX.XXX.XXX
  network XXX.XXX.XXX.XXX mask XXX.XXX.XXX.XXX
  neighbor 187.16.216.252 activate
  neighbor 187.16.216.252 soft-reconfiguration inbound
  neighbor 187.16.216.252 prefix-list nobogons in
  neighbor 187.16.216.252 prefix-list ptt out
  neighbor 187.16.216.253 activate
  neighbor 187.16.216.253 soft-reconfiguration inbound
  neighbor 187.16.216.253 prefix-list nobogons in
  neighbor 187.16.216.253 prefix-list ptt out
  neighbor 187.16.216.254 activate
  neighbor 187.16.216.254 soft-reconfiguration inbound
  neighbor 187.16.216.254 prefix-list nobogons in
  neighbor 187.16.216.254 prefix-list ptt out
  neighbor 187.16.223.253 activate
  neighbor 187.16.223.253 soft-reconfiguration inbound
  neighbor 187.16.223.253 prefix-list nobogons in
  neighbor 187.16.223.253 prefix-list ptt out
  neighbor 187.16.223.254 activate
  neighbor 187.16.223.254 soft-reconfiguration inbound
  neighbor 187.16.223.254 prefix-list nobogons in
  neighbor 187.16.223.254 prefix-list ptt out
  neighbor XXX.XXX.XXX.XXX activate
  neighbor XXX.XXX.XXX.XXX soft-reconfiguration inbound
  neighbor XXX.XXX.XXX.XXX prefix-list nobogons in
  neighbor XXX.XXX.XXX.XXX prefix-list bgp_americanet out
  neighbor XXX.XXX.XXX.XXX activate
  neighbor XXX.XXX.XXX.XXX soft-reconfiguration inbound
  neighbor XXX.XXX.XXX.XXX prefix-list nobogons in
  neighbor XXX.XXX.XXX.XXX prefix-list BGPmask24 out
  neighbor XXX.XXX.XXX.XXX activate
  neighbor XXX.XXX.XXX.XXX soft-reconfiguration inbound
  neighbor XXX.XXX.XXX.XXX prefix-list nobogons in
  neighbor XXX.XXX.XXX.XXX prefix-list bgp_level3 out
 exit-address-family
!
ip forward-protocol nd
!
no ip http server
ip route XXX.XXX.XXX.XXX XXX.XXX.XXX.XXX Null0
ip route XXX.XXX.XXX.XXX XXX.XXX.XXX.XXX Null0
ip route XXX.XXX.XXX.XXX XXX.XXX.XXX.XXX Null0
ip route XXX.XXX.XXX.XXX XXX.XXX.XXX.XXX Null0
ip route XXX.XXX.XXX.XXX XXX.XXX.XXX.XXX Null0
ip route XXX.XXX.XXX.XXX XXX.XXX.XXX.XXX Null0
ip route XXX.XXX.XXX.XXX XXX.XXX.XXX.XXX XXX.XXX.XXX.XXX
ip route XXX.XXX.XXX.XXX XXX.XXX.XXX.XXX XXX.XXX.XXX.XXX
ip route XXX.XXX.XXX.XXX XXX.XXX.XXX.XXX Null0
ip route XXX.XXX.XXX.XXX XXX.XXX.XXX.XXX XXX.XXX.XXX.XXX
ip route XXX.XXX.XXX.XXX XXX.XXX.XXX.XXX XXX.XXX.XXX.XXX
ip route XXX.XXX.XXX.XXX XXX.XXX.XXX.XXX XXX.XXX.XXX.XXX
ip route XXX.XXX.XXX.XXX XXX.XXX.XXX.XXX XXX.XXX.XXX.XXX
ip route XXX.XXX.XXX.XXX XXX.XXX.XXX.XXX XXX.XXX.XXX.XXX
ip route 192.168.1.0 255.255.255.0 2.2.2.1
ip route 192.168.2.0 255.255.254.0 2.2.2.1
ip route XXX.XXX.XXX.XXX XXX.XXX.XXX.XXX XXX.XXX.XXX.XXX
ip route XXX.XXX.XXX.XXX XXX.XXX.XXX.XXX XXX.XXX.XXX.XXX
!
!
ip prefix-list BGPmask24 seq 100 permit XXX.XXX.XXX.XXX/24
ip prefix-list BGPmask24 seq 110 permit XXX.XXX.XXX.XXX/24
ip prefix-list BGPmask24 seq 120 permit XXX.XXX.XXX.XXX/24
ip prefix-list BGPmask24 seq 130 permit XXX.XXX.XXX.XXX/24
ip prefix-list BGPmask24 seq 140 permit XXX.XXX.XXX.XXX/24
ip prefix-list BGPmask24 seq 150 permit XXX.XXX.XXX.XXX/24
ip prefix-list BGPmask24 seq 160 permit XXX.XXX.XXX.XXX/24
ip prefix-list BGPmask24 seq 170 permit XXX.XXX.XXX.XXX/24
ip prefix-list BGPmask24 seq 200 permit XXX.XXX.XXX.XXX/24
ip prefix-list BGPmask24 seq 210 permit XXX.XXX.XXX.XXX/24
ip prefix-list BGPmask24 seq 220 permit XXX.XXX.XXX.XXX/24
ip prefix-list BGPmask24 seq 230 permit XXX.XXX.XXX.XXX/24
ip prefix-list BGPmask24 seq 240 permit XXX.XXX.XXX.XXX/24
ip prefix-list BGPmask24 seq 250 permit XXX.XXX.XXX.XXX/24
!
ip prefix-list bgp_americanet seq 100 permit XXX.XXX.XXX.XXX/24
ip prefix-list bgp_americanet seq 109 permit XXX.XXX.XXX.XXX/24
ip prefix-list bgp_americanet seq 130 permit XXX.XXX.XXX.XXX/24
ip prefix-list bgp_americanet seq 140 permit XXX.XXX.XXX.XXX/24
ip prefix-list bgp_americanet seq 200 permit XXX.XXX.XXX.XXX/24
!
ip prefix-list bgp_level3 seq 100 permit XXX.XXX.XXX.XXX/24
ip prefix-list bgp_level3 seq 110 permit XXX.XXX.XXX.XXX/24
ip prefix-list bgp_level3 seq 120 permit XXX.XXX.XXX.XXX/24
ip prefix-list bgp_level3 seq 130 permit XXX.XXX.XXX.XXX/24
ip prefix-list bgp_level3 seq 140 permit XXX.XXX.XXX.XXX/24
ip prefix-list bgp_level3 seq 150 permit XXX.XXX.XXX.XXX/24
ip prefix-list bgp_level3 seq 200 permit XXX.XXX.XXX.XXX/24
!
ip prefix-list nobogons seq 10 deny 0.0.0.0/8
ip prefix-list nobogons seq 15 deny 2.2.2.0/24
ip prefix-list nobogons seq 20 deny 10.0.0.0/8
ip prefix-list nobogons seq 30 deny 127.0.0.0/8
ip prefix-list nobogons seq 40 deny 169.254.0.0/16
ip prefix-list nobogons seq 50 deny 172.16.0.0/12
ip prefix-list nobogons seq 60 deny 192.0.0.0/24
ip prefix-list nobogons seq 70 deny 192.0.2.0/24
ip prefix-list nobogons seq 80 deny 192.168.0.0/16
ip prefix-list nobogons seq 90 deny 198.18.0.0/15
ip prefix-list nobogons seq 100 deny 198.51.100.0/24
ip prefix-list nobogons seq 110 deny 203.0.113.0/24
ip prefix-list nobogons seq 120 deny 224.0.0.0/4
ip prefix-list nobogons seq 130 deny 240.0.0.0/4
ip prefix-list nobogons seq 140 permit 0.0.0.0/0 le 32
!
ip prefix-list ptt seq 10 permit XXX.XXX.XXX.XXX/24
ip sla 133
 icmp-echo XXX.XXX.XXX.XXX
 frequency 5
ip sla schedule 133 life forever start-time now
ip sla 187
 icmp-echo XXX.XXX.XXX.XXX
 frequency 5
ip sla schedule 187 life forever start-time now
access-list 10 permit 192.168.1.148
access-list 10 deny   any
access-list 105 deny   udp any eq snmp any
access-list 105 deny   udp any eq snmptrap any
access-list 105 permit ip any any
access-list 106 permit udp any eq snmp host 192.168.1.148
access-list 106 permit udp any eq snmptrap host 192.168.1.148
access-list 106 permit ip any any
!
snmp-server community XXXX RW 10
snmp-server location XXXX
snmp-server contact XXXXX@XXXXXXXXXXXXXX.XXX.XX
!
!
!
control-plane
!
 !
 !
 !
!
!
!
banner login ^CC
*************************************************************************
*                                                                       *
*                        XXXXXXXXXXXX                                   *
*                                                                       *
*                                                                       *
*                                                                       *
*                                                                       *
*   ATENCAO, ESTE EQUIPAMENTO E DE ACESSO RESTRITO. QUALQUER CONEXAO    *
*   SERA MONITORADA E LOGADA. USUARIOS QUE NAO POSSUEM PERMISSAO DE     *
*   ACESSO DEVERAO SAIR IMEDIATAMENTE.                                  *
*                                                                       *
*   ATTENTION, THIS IS A RESTRICTED ACCESS EQUIPMENT. ANY CONNECTIONS   *
*   ARE MONITORED AND LOGGED. USERS WITHOUT ACCESS PERMISSION THEY      *
*   WILL HAVE TO LEAVE IMMEDIATELY.                                     *
*                                                                       *
*************************************************************************
^C
!
line con 0
 privilege level 15
 login authentication xxxxx
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
 privilege level 15
 login authentication xxxxxx
!
!
end
  • You could always try setting static ARP table entries for those five IP addresses. – Ron Maupin Sep 20 '17 at 20:45
  • 1
    Please provide the router configuration. The ISP's answer makes no sense. – Ron Trunk Sep 20 '17 at 21:36
  • Thanks for the repply! Just added more info on my post. Pls let me know if it is enought. – Daniel Silva Sep 21 '17 at 11:55
  • 1
    Please include the entire router config. Use the preformatted text option instead of inserting a picture. – Ron Trunk Sep 21 '17 at 12:27
  • 1
    You should post an answer and accept it so that the question doesn't keep popping up forever, looking for an answer. – Ron Maupin Sep 26 '17 at 18:00

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.