1

My topology is as so

R0 as Hub

R1 and R2 as spoke

enter image description here

R2 has a loopback of 2.2.2.2, and R3 has a loopback of 3.3.3.3

R1 can ping these addresses, and is advertising 2.0.0.0 and 3.0.0.0 in RIPv2.

However, R2 and R3 don't seem to be getting these routes in their routing table when I run 'show ip route'

Auto summary isn't in effect, and RIP is running v2 on all routers.

Any help is appreciated.

Router 1 (HUB)
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
!
!
ip cef
no ipv6 cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface FastEthernet1/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial2/0
 ip address 172.12.123.1 255.255.255.0
 encapsulation frame-relay
 frame-relay interface-dlci 102
 frame-relay interface-dlci 103
!
interface Serial3/0
 no ip address
 shutdown
!
interface FastEthernet4/0
 no ip address
 shutdown
!
interface FastEthernet5/0
 no ip address
 shutdown
!
router rip
 version 2
 network 2.0.0.0
 network 3.0.0.0
 network 172.12.0.0
 no auto-summary
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end

-----------------------------------
R2 (SPOKE)
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
!
!
ip cef
no ipv6 cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback2
 ip address 2.2.2.2 255.255.255.0
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface FastEthernet1/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial2/0
 ip address 172.12.123.2 255.255.255.0
 encapsulation frame-relay
 frame-relay interface-dlci 201
!
interface Serial3/0
 no ip address
 shutdown
!
interface FastEthernet4/0
 no ip address
 shutdown
!
interface FastEthernet5/0
 no ip address
 shutdown
!
router rip
 version 2
 network 2.0.0.0
 network 172.12.0.0
 no auto-summary
!
ip classless
ip route 172.12.123.3 255.255.255.255 172.12.123.1 
ip route 2.2.2.2 255.255.255.255 172.12.123.1 
!
ip flow-export version 9
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end
------------------------------
R3
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
!
!
ip cef
no ipv6 cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback3
 ip address 3.3.3.3 255.255.255.0
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface FastEthernet1/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial2/0
 ip address 172.12.123.3 255.255.255.0
 encapsulation frame-relay
 frame-relay interface-dlci 301
!
interface Serial3/0
 no ip address
 shutdown
!
interface FastEthernet4/0
 no ip address
 shutdown
!
interface FastEthernet5/0
 no ip address
 shutdown
!
router rip
 version 2
 network 3.0.0.0
 network 172.12.0.0
 no auto-summary
!
ip classless
ip route 172.12.123.2 255.255.255.255 172.12.123.1 
ip route 3.3.3.3 255.255.255.255 172.12.123.1 
!
ip flow-export version 9
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end

Edit: Is it because R1 is learning of the loopbacks through S2/0, so it won't advertise them back out?

Edit2: I take that back, the interfaces are running frame relay, so that can't be it?

  • 1
    Please post your configuration of all devices. I recommend commenting with a pastebin.com link. From there, someone can edit your post with the configurations. – TDurden Sep 22 '17 at 0:32
  • Sorry, should've done that initially. – Josh Sep 22 '17 at 0:35
  • @TDurden, configuration should be embedded in the question using the preformatted format, as edited by Ron Maupin, so the whole content of the question remain available for future readers. – JFL Sep 22 '17 at 7:17
2

Edit: Is it because R1 is learning of the loopbacks through S2/0, so it won't advertise them back out?

Edit2: I take that back, the interfaces are running frame relay, so that can't be it?

What you are concerning is about IP split horizon on Frame Relay.

However, you should NOT have this issue as you are using multipoint physical interface Frame Relay on R1 and split horizon is disabled by default, BUT it could be the problem with packet-tracer IOS or the IOS version itself.

The best way of verifying is to run the following command on R1

`show ip int s2/0 | i Split horizon`

If you see Split horizon is enabled, then it is the issue. You can turn it off by issuing no ip split-horizon under R1's s2/0 configuration and check again.


On R1, the commands network 2.0.0.0 and network 3.0.0.0 are not working at all because the network command is to enable/run RIP on connected interface on device, not to "advertise".


Another point is on R2 and R3, you do not need two static routes as they are not neccessary and incorrect. For R2 and R3 to reach each other's interface and loopback IPs, add frame-relay map ip 172.12.123.3 201 broadcast on R2 and frame-relay map ip 172.12.123.2 301 broadcast on R3 . You can check frame-relay map with show frame-relay map


The best practice is to use point-point subinterfaces

  • It turns out split-horizon was enabled on R1's s2/0 interface, now R2 and R3 are getting the loopback routes via RIP. I created a new lab without static routes on R2 and R3, and as a result could not ping each other. I used the frame-relay commands you mentioned and it's working now. But why couldn't they ping each other if they have a 172.12.0.0 route through S2/0? Thanks so much for your help! – Josh Sep 22 '17 at 18:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.