Recently, I've been working on two spare switches which I need to stack at some point, but before I did that I needed the clear the config on both switches.

Unfortunately, I made the mistake of typing erase flash: instead of nvram: and it's obviously caused me a problem. Not a massive issue though as I could just load the IOS image of the other switch as they're both 2960x switches.

I've taken a USB drive and partitioned it to 2GB and formatted it as FAT16. When loading the USB onto the working switch, it accepts it without issues and allows me to copy the IOS image to usbflash0: and when doing a dir usbflash0:, it shows me the IOS image so I know it's all ready to go.

When I console into the switch that does not have an IOS image, it takes me to the boot loader which is expected. However, it's at this point that usbflash0: is not recognised, and displays the following:

enter image description here

I feel that I've done everything I can here with the USB stick. Is there specific software that I need to use to prepare a USB stick for the boot loader? I've tried diskpart and also Rufus, but it just seems to be the boot loader that doesn't like anything I've tried.

Please adivse.


  • 2
    Please, never use an image for text. Copy the text, paste it into your question, and use the Preformatted Text feature ({}).
    – Ron Maupin
    Sep 27, 2017 at 15:10
  • Usually I do. I apologise if this picture ruined your day and casted a dark cloud. Please explain to with a strong valid reason as to why I should "never" do this?
    – BabyPython
    Sep 27, 2017 at 15:18
  • 2
    This is from SE: "Images and screenshots can be a nice addition to a post, but please make sure the post is still clear and useful without them. Don't post images of code or error messages. Instead copy and paste or type the actual code/message into the post directly."
    – Ron Maupin
    Sep 27, 2017 at 15:28
  • 1
    Also: "Images are useful in a post, but make sure the post is still clear without them. If you post images of code or error messages, copy and paste or type the actual code or message into the post directly."
    – Ron Maupin
    Sep 27, 2017 at 15:30

4 Answers 4


Please do the following:

-shutdown the switch

-press Mode button while power on the switch to enter in switch: mode.

-set BAUD 115200


-copy the file

The random symbols are normal since you are transferring the file via console. So you can actually see the data flowing via the link. Just leave it for few hours and image will be uploaded.


1) Issue the flash_init command and the load_helper command switch: flash_init switch: load_helper

2) Issue the dir flash: command in order to view the contents of the Flash file system. After you have verified where the Cisco IOS image file resides, try to boot the image. Issue either the

boot flash:filename command or the boot flash:directory/filename

switch: boot flash:c2950-i6q4l2-mz.121-13.EA1.bin

3) If you issue the boot command and the result is in a successful bootup, either the default switch> prompt or the hostname> prompt displays

4) If you issue the boot command and the command does not result in a successful bootup, either the switch: prompt displays or you are stuck in a continuous reboot again. The only option to recover the switch is an Xmodem file transfer

  • Step 4 is my issue so thanks for clarifying. After looking into Xmodem file transfers, I can see that this is a very slow way of transferring files. Other people who have use Xmodem have changed the baud rate from the switch: prompt, but when changing this from 9600 to 57600 for example within Tera Term, it just fires off random characters and doesn't give another other output. I've tried applying set baud 57600 at the switch: prompt prior to this, and it doesn't make any difference. Any ideas as to how I can speed up the file transfer by changing this rate successfully?
    – BabyPython
    Sep 27, 2017 at 13:10

Your USB stick is not compatible with ROMMON. Partitioning it to 2GB doesn't make it a 2GB device. I've run into this too many times with too many devices. Your options are:

  • find a compatible usb stick
  • xmodem upload via the console (insanely slow)
  • tftpboot from the console

I came across the same problem. You have to insert the USB in switch first. Format the USB using "format usbflash0" and then remove the USB and copy the files from computer to the USB. Then insert the USB back in switch and you will see the files inn usbflash dir, and they are ready to be copied to flash.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.