6

I have a Juniper EX4600 switch which I'm using for host connectivity (obviously). Now I need to set up a VRRP/CARP between two hosts that are in the same vlan, and it's the default one. Surprisingly, it's not working. And the reason is that these two hosts simple don't see the multicast packets from each other, they do see only self-originating packets in tcpdump (so my VRRP cluster is in split-brain state permanently). Previously I have successfully set up such scheme on a variety of switches, including EX4600, and I see no big difference between them, except that in the case of the working VRRP on EX4600 I have all of the interfaces in non-default vlans. I was suspecting it's the igmp snooping feature that blocks the multicast, but it turns out there's no such thing configured on my switch:

emz@sw0-lynx# show | match igmp 

{master:0}[edit]
emz@sw0-lynx#

[...]
emz@sw0-lynx> show igmp snooping interface 
warning: multicast-snooping subsystem not running - not needed by configuration.

I've already posted this question on the Juniper community forums, but, unfortunately, both replies authors thought that I need the IGMP snooping feature, not the VRRP, so I should mention that I don't care at all about the IGMP snooping and I'm showing it here merely to show that this isn't the reason of VRRP packets getting blocked (at least as I understand it).

I've also tried to enable the IGMP snooping (in case I understand it wrong), it gave nothing. I also tried to experiment with various spanning-tree protocols (as far as I know this has nothing to do with the multicast, but just in case - as I was out of options, to see whether I do understand anything) - I tried rstp and vstp, and this also gave me nothing as I expected.

So, - prior to buying the support for EX4600 and asking in JTAC, I decided to try once more and ask in the community - how do I make the VRRP work in the EX4600 default vlan ? I'm aware about the solution "move everything into non-default one", but this requires outage, and furthermore, I want to solve this, - after all the default vlan is just a vlan.

closed as too broad by Ron Maupin Jul 7 '18 at 22:21

Please edit the question to limit it to a specific problem with enough detail to identify an adequate answer. Avoid asking multiple distinct questions at once. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • can you please post the output for "show version", "show chassis hardware", and the configuration? – Jordan Head Oct 4 '17 at 13:32
  • This answer explains the multicast of VRRP. It is not affected by IGMP or IGMP snooping because it uses a link-local multicast that cannot be routed, and therefore does not use IGMP to talk to a router. – Ron Maupin May 23 '18 at 11:22
  • Jesus, what does "too broad" means to you ? "They do see only self-originating packets in tcpdump" cannot be made more specific. I've just found an answer to my question, but, because it's been closed, it will never appear on this portal - thanks to you. Well, at least I'm leaving from here enlightened. – drookie Dec 6 '18 at 12:14
0

VRRP normally uses the multicast address range 224.0.0.0 - 224.0.0.255. This is also known as "local subnetwork" which means that it is not routable and there is also no need for mechanisms like IGMP. This should work out of the box. I assume you have some odd VRRP config on your hosts. Just a guess.

Not the answer you're looking for? Browse other questions tagged or ask your own question.