1

I have a /28 block of public IPs from Comcast. I'm trying to put a public IP directly on the ASA outside interface, but when I do I cannot ping 8.8.8.8 or the Comcast modem. Internal communication is fine, but there is no external or Internet connectivity.

Also, if I run packet tracer simulating from inside int 172.17.25.1 to outside 8.8.8.8 it says it's blocked by an implicit rule. However, I have even tried opening up both interfaces with any/any in/out and it still says it's blocked. I have also already enabled ICMP inspect.

I can't figure out why traffic is not being passed on the external interface even to a directly connected device.

The Comcast router is in virtual bridge mode.

Internet Settings
Gateway MAC Address 78:CD:8E:C2:D2:58
WAN MAC Address 78:CD:8E:C2:D2:5B
WAN DHCP IP Address 98.204.5.208
WAN DHCP IPv6 Address   ::/64
WAN DHCP IPv6 DNS (primary) ::
WAN DHCP IPv6 DNS (secondary)   ::
WAN DHCP Subnet Mask    255.255.248.0
WAN DHCP Default Gateway    98.204.0.1
WAN Internet IP Address 50.xx.xx.62
DNS (primary)   75.75.75.75
DNS (secondary) 75.75.76.76
DHCP Time Remaining 86h:12m:46s
Date    Oct-4-2017
Static IP Block 50.xx.xx.62/28

Here is my ASA config

ASA Version 9.6(3)1 
!
hostname ciscoasa
enable password lsiIw5sJErKSQdQv encrypted
xlate per-session deny tcp any4 any4
xlate per-session deny tcp any4 any6
xlate per-session deny tcp any6 any4
xlate per-session deny tcp any6 any6
xlate per-session deny udp any4 any4 eq domain
xlate per-session deny udp any4 any6 eq domain
xlate per-session deny udp any6 any4 eq domain
xlate per-session deny udp any6 any6 eq domain
passwd 2KFQnbNIdI.2KYOU encrypted
names

!
interface GigabitEthernet0/0
 description Uplink To ComRTR
 nameif outside
 security-level 0
 ip address 50.xx.xx.50 255.255.255.240 
!
interface GigabitEthernet0/1
 description Link To 1941
 nameif inside
 security-level 100
 ip address 172.17.25.1 255.255.255.0 
!
interface GigabitEthernet0/2
 shutdown
 no nameif
 no security-level
 no ip address
!
interface GigabitEthernet0/3
 shutdown
 no nameif
 no security-level
 no ip address
!
interface GigabitEthernet0/4
 shutdown
 no nameif
 no security-level
 no ip address
!
interface GigabitEthernet0/5
 shutdown
 no nameif
 no security-level
 no ip address
!
interface Management0/0
 management-only
 shutdown
 no nameif
 no security-level
 no ip address
!
interface GigabitEthernet1/0
 shutdown
 no nameif
 no security-level
 no ip address
!
interface GigabitEthernet1/1
 shutdown
 no nameif
 no security-level
 no ip address
!
interface GigabitEthernet1/2
 shutdown
 no nameif
 no security-level
 no ip address
!
interface GigabitEthernet1/3
 shutdown
 no nameif
 no security-level
 no ip address
!
interface GigabitEthernet1/4
 shutdown
 no nameif
 no security-level
 no ip address
!
interface GigabitEthernet1/5
 shutdown
 no nameif
 no security-level
 no ip address
!
boot system disk0:/asa963-1-smp-k8.bin
ftp mode passive
clock timezone EST -5
clock summer-time EDT recurring
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface
object-group protocol DM_INLINE_PROTOCOL_1
 protocol-object ip
 protocol-object icmp
object-group protocol DM_INLINE_PROTOCOL_2
 protocol-object ip
 protocol-object icmp
object-group protocol DM_INLINE_PROTOCOL_3
 protocol-object ip
 protocol-object icmp
access-list inside_access_in extended permit object-group DM_INLINE_PROTOCOL_1 any any 
access-list outside_access_in extended permit object-group DM_INLINE_PROTOCOL_2 any any 
access-list inside_access_out extended permit object-group DM_INLINE_PROTOCOL_3 any any 
pager lines 24
mtu outside 1500
mtu inside 1500
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-781-150.bin
no asdm history enable
arp timeout 14400
no arp permit-nonconnected
arp rate-limit 8192
nat (any,any) source static any any
access-group outside_access_in in interface outside
access-group inside_access_in in interface inside
access-group inside_access_out out interface inside
router ospf 1
 network 172.17.25.0 255.255.255.192 area 0
 area 0
 log-adj-changes
 redistribute static metric 10 metric-type 1 subnets
!
route inside 0.0.0.0 0.0.0.0 50.78.73.62 200
route inside 192.168.108.0 255.255.255.0 172.17.25.2 1
route inside 192.168.118.0 255.255.255.0 172.17.25.2 1
route inside 192.168.128.0 255.255.255.0 172.17.25.2 1
timeout xlate 3:00:00
timeout pat-xlate 0:00:30
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 sctp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
timeout conn-holddown 0:00:15
user-identity default-domain LOCAL
aaa authentication ssh console LOCAL 
http server enable
http 192.168.128.0 255.255.255.0 inside
http 172.17.25.0 255.255.255.192 inside
no snmp-server location
no snmp-server contact
crypto ipsec security-association pmtu-aging infinite
crypto ca trustpool policy
telnet timeout 5
ssh stricthostkeycheck
ssh 192.168.128.0 255.255.255.0 inside
ssh 10.2.10.0 255.255.255.0 inside
ssh 172.17.25.0 255.255.255.192 inside
ssh timeout 60
ssh key-exchange group dh-group1-sha1
console timeout 0
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
ntp server 129.6.15.30 source outside prefer
ntp server 129.6.15.28 source outside
dynamic-access-policy-record DfltAccessPolicy
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum client auto
  message-length maximum 512
  no tcp-inspection
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map 
  inspect ftp 
  inspect h323 h225 
  inspect h323 ras 
  inspect ip-options 
  inspect netbios 
  inspect rsh 
  inspect rtsp 
  inspect skinny  
  inspect esmtp 
  inspect sqlnet 
  inspect sunrpc 
  inspect tftp 
  inspect sip  
  inspect xdmcp 
  inspect icmp 
  inspect icmp error 
!
service-policy global_policy global
prompt hostname context 
no call-home reporting anonymous
call-home
 profile CiscoTAC-1
  no active
  destination address http https://tools.cisco.com/its/service/oddce/services/DDCEService
  destination address email callhome@cisco.com
  destination transport-method http
  subscribe-to-alert-group diagnostic
  subscribe-to-alert-group environment
  subscribe-to-alert-group inventory periodic monthly 9
  subscribe-to-alert-group configuration periodic monthly 9
  subscribe-to-alert-group telemetry periodic daily
Cryptochecksum:fc639883d1937e59daa8933d5d290814
: end
4

You will never be able to ping from the INSIDE interface IP address of the ASA to any OUTSIDE IP address. The ASA does not allow this.

interface GigabitEthernet0/0
 description Uplink To ComRTR
 nameif outside
 security-level 0
 ip address 50.78.73.50 255.255.255.240

The OUTSIDE interface is connecting to the 50.78.73.48/28 subnet.

The route command is incorrect.

The show run output provided by you states that:

route INSIDE 0.0.0.0 0.0.0.0 50.78.73.62 200

The correct OUTPUT will be:

route OUTSIDE 0.0.0.0 0.0.0.0 50.78.73.62

!This is where your Internet facing comms are.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.