1

This is a weird one

I have 2 7960 ip phones using cme with a 2811 router, they worked flawlessly, then one decided to stop picking up so i opened it to re attach the handset spring.

Then I connected it again and now it won't boot properly? It tells me "tftp file not found" I have factory reset it several times and the other phone works fine and gets an ip and it's number.

What do I do? Is the phone broken? Before it said about the tftp error it was giving another error about protocol or something. This has now gone and will only display the tftp error and I don't know what to do!

  • Did any answer help you? If so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you can provide and accept your own answer. – Ron Maupin Feb 19 '18 at 19:37
2

It's just a guess, but sounds like dirt/corrosion in the network socket. Do you get any networking from bad phone at all? Can you plug something in on the "access" ether socket (ie the socket for the PC) of the bad phone and find out if it gets good networking?

| improve this answer | |
  • One thing I have seen is that the pins in the socket get knocked out of alignment. – Ron Maupin Oct 8 '17 at 16:12
  • Which socket? The poe one? – AvidPontoon Oct 8 '17 at 16:52
  • Plug phone into ether switch as normal, which is marked I believe "10/100 SW". Plug laptop or network analyser into "access socket" which is I believe marked "10/100 PC". See if laptop networking functions well: if not, perhaps "SW" socket is damaged, as traffic to the switch has to go down here to get to the PC. Unplug from "SW" and plug into laptop directly. From what works/doesn't you can deduce where the fault might be. – jonathanjo Oct 8 '17 at 18:19
  • Hope it's nothing software related as I won't have the skills to fix it – AvidPontoon Oct 8 '17 at 18:22
  • Unfortunately I have plugged it in and I can get internet access on the pc plugged into it and it stop shows the same error! Damn – AvidPontoon Oct 8 '17 at 19:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.