1

I'm pretty new to networking. I'm working on creating some vlans, assigning them some ports, and then trying to configure one of those vlans as the native vlan. here's what I have done.

Switch(config)#vlan 10
Switch(config-vlan)#name accounts
Switch(config-vlan)#exit
Switch(config)#vlan 20
Switch(config-vlan)#name sales
Switch(config-vlan)#exit
Switch(config)#vlan 30
Switch(config-vlan)#name marketing
Switch(config-vlan)#exit
Switch(config)#vlan 153
Switch(config-vlan)#name Management&Native
Switch(config-vlan)#exit
Switch(config)#vlan 771 
Switch(config-vlan)#name blackhole
Switch(config-vlan)#exit
Switch(config)#int range f0/1-6
Switch(config-if-range)#swi
Switch(config-if-range)#switchport mode a
Switch(config-if-range)#switchport mode access 
Switch(config-if-range)#switchport access vlan 10
Switch(config-if-range)#no shut
Switch(config-if-range)#exit
Switch(config)#int range f0/7-12
Switch(config-if-range)#switchport mode access
Switch(config-if-range)#switchport access vlan 20
Switch(config-if-range)#no shut
Switch(config-if-range)#exit
Switch(config)#int range f0/13-18
Switch(config-if-range)#switchport mode access
Switch(config-if-range)#switchport access vlan 30
Switch(config-if-range)#exit
Switch(config)#int range f0/19-21
Switch(config-if-range)#switchport mode access
Switch(config-if-range)#switchport access vlan 771
Switch(config-if-range)#shutdown
Switch(config-if-range)#exit
Switch(config)#int range f0/22-24
Switch(config-if-range)#switchport mode trunk
Switch(config-if-range)#switchport trunk allowed vlan 10,20,30,153
Switch(config-if-range)#switchport trunk native vlan 153
Switch(config-if-range)#exit

I'm getting the error message :

%CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEthernet0/22 (153), with Switch FastEthernet0/21 (1).

I haven't been able to figure out why the error persists. Huge thanks to anyone who answers in advance. Would appreciate it.

1

This is because the port f0/22 of this Switch is trunking VLAN 153 as native VLAN while the port f0/21 of another Switch does not (by default, it is trunking vlan 1 as native VLAN)

  • this Switch (f0/22) <==> (f0/21) another Switch

You need to configure the port f0/21 of another Switch to be the same as port f0/22 of this switch and make sure number of VLANs and VLAN IDs are identical on both devices.

3
  • thank you very much. ill configure all other switches accordingly. – Bibhushan Oct 17 '17 at 12:37
  • @Bibhushan Try to solve this issue on another Switch (port f0/21) first and let us know the result. – Hung Tran Oct 17 '17 at 12:39
  • OR turn off CDP. This isn't actually an error; it could've been done on purpose. CDP requires a heterogeneous network. – Ricky Oct 17 '17 at 20:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.