2

To give some context, here is my setup:

  ----(10.0.0.1 - S0/0/0) R1 (S0/1/0 - 10.0.1.1)----
  |                                                |
  |                                                |
  |                                                |
  (10.0.0.2 - S0/0/0)                              (10.0.1.2 - S0/0/0)
  R3                                               R2
  (172.16.0.1 - FE0/0)                             
  |                                                
  |                                                
  |
  S1
  |
  |
  (172.16.0.2)
  PC1

If I try to ping from PC1 to R3, it works fine pinging 172.16.0.1 and 10.0.0.2; but if I try to ping 10.0.0.1 from PC1, it doesn't work.

Here are some configs:

R3 interfaces:

interface FastEthernet0/0
 ip address 172.16.0.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0/0
 ip address 10.0.0.2 255.255.255.0
!
ip forward-protocol nd
no ip http server
no ip http secure-server

R3 routes:

Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is 10.0.0.1 to network 0.0.0.0

S*    0.0.0.0/0 [1/0] via 10.0.0.1
      10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        10.0.0.0/24 is directly connected, Serial0/0/0
L        10.0.0.2/32 is directly connected, Serial0/0/0
      172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.16.0.0/24 is directly connected, FastEthernet0/0
L        172.16.0.1/32 is directly connected, FastEthernet0/0

R1 interfaces:

interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0/0
 ip address 10.0.0.1 255.255.255.0
!
interface Serial0/1/0
 ip address 10.0.1.1 255.255.255.0
!

R1 routes:

Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
C        10.0.0.0/24 is directly connected, Serial0/0/0
L        10.0.0.1/32 is directly connected, Serial0/0/0
C        10.0.1.0/24 is directly connected, Serial0/1/0
L        10.0.1.1/32 is directly connected, Serial0/1/0

2 Answers 2

5

Notice that R1 has no route to PC1. Routers learn routes in three ways:

  1. Directly connected networks
  2. Statically configured routes
  3. Through a routing protocol

Since R1 is not connected to the 172.16.0.0/24 network, you have two options: create a static route in R1, or run a routing protocol between R3 and R1 to advertise the route from R3 to R1.

A statically configured route in R1 would look something like:

ip route 172.16.0.0 255.255.255.0 10.0.0.2
2

From R1's routing table, I can see that R1 does not have a route to the 172.16.0.0 network. In other words, R1 doesn't know where to forward the packet to reach PC1. You need to add a route to R1's table, either with a static route, or configure a routing protocol.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.