1

I am trying to get DHCP to work on a VLAN. I have 3 VLANS and they are .10, .11, .12.

.11 and .12 are working fine, they are getting ip addresses and their corresponding gateways from the DHCP server.

.10 hosts are getting ip addresses but are not getting their .10 gateway.

My DHCP server is 192.168.10.254 and is connected to the .10 Switch for VLAN 10.

Here is my VLAN 10 setup for the switch. What could be stopping it from forwarding all information out to VLAN 10 hosts.

I have already set up DHCP Pools in the DHCP server also.

hostname Lan-Switch1
!
!
!
enable secret 5 $1$mERr$nXufIEw80DqfKWVQo3J4O.
enable password 7 080C557E080A16001D1908
!
!
!
!
!
ip routing
!
!
!
!
!
!
!
!
!
!
!
!
ip ssh version 1
ip domain-name man.inishtrahill.ie
ip name-server 192.168.10.254
!
!
spanning-tree mode rapid-pvst
spanning-tree portfast default
spanning-tree vlan 1-4094 priority 24576
!
!
!
!
!
!
interface FastEthernet0/1
 switchport access vlan 10
 switchport mode access
 spanning-tree portfast
 spanning-tree guard root
!
interface FastEthernet0/2
 switchport access vlan 10
 switchport mode access
 spanning-tree portfast
 spanning-tree guard root
!
interface FastEthernet0/3
 switchport access vlan 10
 switchport mode access
 spanning-tree portfast
 spanning-tree guard root
!
interface FastEthernet0/4
 switchport access vlan 10
 switchport mode access
 spanning-tree portfast
 spanning-tree guard root
!
interface FastEthernet0/5
 switchport access vlan 10
 switchport mode access
 spanning-tree portfast
 spanning-tree guard root
!
interface FastEthernet0/6
 switchport access vlan 10
 switchport mode access
 spanning-tree portfast
 spanning-tree guard root
!
interface FastEthernet0/7
 switchport access vlan 10
 switchport mode access
 spanning-tree portfast
 spanning-tree guard root
!
interface FastEthernet0/8
 switchport access vlan 10
 switchport mode access
 spanning-tree portfast
 spanning-tree guard root
!
interface FastEthernet0/9
 switchport access vlan 10
 switchport mode access
 spanning-tree portfast
 spanning-tree guard root
!
interface FastEthernet0/10
 switchport access vlan 10
 switchport mode access
 spanning-tree portfast
 spanning-tree guard root
!
interface FastEthernet0/11
 switchport access vlan 10
 switchport mode access
 spanning-tree portfast
 spanning-tree guard root
!
interface FastEthernet0/12
 switchport access vlan 10
 switchport mode access
 spanning-tree portfast
 spanning-tree guard root
!
interface FastEthernet0/13
 switchport access vlan 10
 switchport mode access
 spanning-tree portfast
 spanning-tree guard root
!
interface FastEthernet0/14
 switchport access vlan 10
 switchport mode access
 spanning-tree portfast
 spanning-tree guard root
!
interface FastEthernet0/15
 switchport access vlan 10
 switchport mode access
 spanning-tree portfast
 spanning-tree guard root
!
interface FastEthernet0/16
 switchport access vlan 10
 switchport mode access
 spanning-tree portfast
 spanning-tree guard root
!
interface FastEthernet0/17
 switchport access vlan 10
 switchport mode access
 spanning-tree portfast
 spanning-tree guard root
!
interface FastEthernet0/18
 switchport access vlan 10
 switchport mode access
 spanning-tree portfast
 spanning-tree guard root
!
interface FastEthernet0/19
 switchport access vlan 10
 switchport mode access
 spanning-tree portfast
 spanning-tree guard root
!
interface FastEthernet0/20
 switchport access vlan 10
 switchport mode access
 spanning-tree portfast
 spanning-tree guard root
!
interface FastEthernet0/21
 switchport access vlan 10
 switchport mode access
 spanning-tree portfast
 spanning-tree guard root
!
interface FastEthernet0/22
 switchport access vlan 10
 switchport mode access
 spanning-tree portfast
 spanning-tree guard root
!
interface FastEthernet0/23
 switchport access vlan 10
 switchport mode access
 spanning-tree portfast
 spanning-tree guard root
!
interface FastEthernet0/24
 switchport access vlan 10
 switchport mode access
 spanning-tree portfast
 spanning-tree guard root
!
interface GigabitEthernet0/1
 description Connection to Switch 2 GigabitEthernet0/1
 switchport trunk native vlan 999
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet0/2
 description Connection to Switch 3 GigabitEthernet0/1
 switchport trunk native vlan 999
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan10
 description classroom 1 and classroom 2
 ip address 192.168.10.1 255.255.255.0
!
interface Vlan11
 description classroom 3 and classroom 4
 ip address 192.168.11.1 255.255.255.0
 ip helper-address 192.168.10.254
!
interface Vlan12
 description secretary and principal
 ip address 192.168.12.1 255.255.255.0
 ip helper-address 192.168.10.254
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
logging 192.168.10.254
line con 0
 exec-timeout 6 50
 password 7 080C556D061716181E0E
 logging synchronous
 login
!
line aux 0
!
line vty 0 4
 exec-timeout 5 30
 password 7 080C557A0C150B1206
 logging synchronous
 login
line vty 5 15
 exec-timeout 5 30
 password 7 080C557E080A16001D1908
 logging synchronous
 login
!
!
ntp authentication-key 1 md5 0832494D1B1C112713181F13253920 7
ntp server 192.168.10.254 key 0
!
end


Lan-Switch1# 
  • It is a similar question, my apologies. I just cant seem to understand why I cant get it working correctly when the other ones do work correctly. – GreenCoder Nov 2 '17 at 21:25
  • I fixed the problem. The DHCP Pool for .10 was conflicting with a default pool also with a .10 start address. I just changed the default. Everything is working now. – GreenCoder Nov 2 '17 at 21:36
  • Did any answer help you? If so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you can provide and accept your own answer. – Ron Maupin Feb 19 '18 at 20:01
2

Since you're getting an IP address DHCP seems to be working correctly. The default gateway for a VLAN must be configured in the DHCP scope server options on the DHCP server.

|improve this answer|||||
  • Its working now thankfully. One Pool conflicting with another. Every host on every VLAN has all the details they need now. Everything can ping Everything now. – GreenCoder Nov 2 '17 at 21:42
-1

Ideally there is a single DHCP server located on a unique subnet. You simply add an ip helper-address (in Cisco IOS lingo) to each subnet's gateway interface so that DHCP broadcast requests get unicast forwarded to the centralized DHCP server (or cluster of servers). In other words you should not need to deploy a single DHCP server for each subnet. Most network admins prefer to manage all DHCP scopes from a single box, it just makes things more tidy/easy.

|improve this answer|||||
  • how could i improve my answer? is my answer wrong? – Ronnie Royston Nov 3 '17 at 15:03
  • I didn't downvote, but your answer doesn't seem to address the OPs question/problem. It's more like "general advice." – Ron Trunk Nov 3 '17 at 15:32
  • ty, I edited a bit. Oh well... – Ronnie Royston Nov 3 '17 at 15:50
  • You'll notice that the OP has ip helper already configured. The OP is asking why one out of several subnets is not getting addresses. – Ron Trunk Nov 3 '17 at 16:44
  • not on VLAN10. but my point is, ...I ain't reading all that! :-) – Ronnie Royston Nov 3 '17 at 17:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.