2

I am trying to add two IPPHONES in a VLAN and it does not seem to be working as the phones are not receiving their ip addresses. I have a router going through a switch and the phones are then connected to the switch. I am following this https://edsonvuma.wordpress.com/2013/06/10/configuring-voip-basic-level_packet-tracer/ tutorial.

What is the best or most common method of adding these phones? Here is my three switch Configurations and my diagram enter image description here

Lan-Switch1:

interface FastEthernet0/1
 switchport access vlan 10
 switchport mode access
 spanning-tree portfast
 spanning-tree guard root
!
interface FastEthernet0/2
 switchport access vlan 10
 switchport mode access
 spanning-tree portfast
 spanning-tree guard root
!
interface FastEthernet0/3
 switchport access vlan 10
 switchport mode access
 spanning-tree portfast
 spanning-tree guard root
!
interface FastEthernet0/4
 switchport access vlan 10
 switchport mode access
 spanning-tree portfast
 spanning-tree guard root
!
interface FastEthernet0/5
 switchport access vlan 10
 switchport mode access
 spanning-tree portfast
 spanning-tree guard root
!
interface FastEthernet0/6
 switchport access vlan 10
 switchport mode access
 spanning-tree portfast
 spanning-tree guard root
!
interface FastEthernet0/7
 switchport access vlan 10
 switchport mode access
 spanning-tree portfast
 spanning-tree guard root
!
interface FastEthernet0/8
 switchport access vlan 10
 switchport mode access
 spanning-tree portfast
 spanning-tree guard root
!
interface FastEthernet0/9
 switchport access vlan 10
 switchport mode access
 spanning-tree portfast
 spanning-tree guard root
!
interface FastEthernet0/10
 switchport access vlan 10
 switchport mode access
 spanning-tree portfast
 spanning-tree guard root
!
interface FastEthernet0/11
 switchport access vlan 10
 switchport mode access
 spanning-tree portfast
 spanning-tree guard root
!
interface FastEthernet0/12
 switchport access vlan 10
 switchport mode access
 spanning-tree portfast
 spanning-tree guard root
!
interface FastEthernet0/13
 switchport access vlan 10
 switchport mode access
 spanning-tree portfast
 spanning-tree guard root
!
interface FastEthernet0/14
 switchport access vlan 10
 switchport mode access
 spanning-tree portfast
 spanning-tree guard root
!
interface FastEthernet0/15
 switchport access vlan 10
 switchport mode access
 spanning-tree portfast
 spanning-tree guard root
!
interface FastEthernet0/16
 switchport access vlan 10
 switchport mode access
 spanning-tree portfast
 spanning-tree guard root
!
interface FastEthernet0/17
 switchport access vlan 10
 switchport mode access
 spanning-tree portfast
 spanning-tree guard root
!
interface FastEthernet0/18
 switchport access vlan 10
 switchport mode access
 spanning-tree portfast
 spanning-tree guard root
!
interface FastEthernet0/19
 switchport access vlan 10
 switchport mode access
 spanning-tree portfast
 spanning-tree guard root
!
interface FastEthernet0/20
 switchport access vlan 10
 switchport mode access
 spanning-tree portfast
 spanning-tree guard root
!
interface FastEthernet0/21
 switchport access vlan 10
 switchport mode access
 spanning-tree portfast
 spanning-tree guard root
!
interface FastEthernet0/22
 switchport access vlan 10
 switchport mode access
 spanning-tree portfast
 spanning-tree guard root
!
interface FastEthernet0/23
 switchport access vlan 10
 switchport mode access
 spanning-tree portfast
 spanning-tree guard root
!
interface FastEthernet0/24
 switchport access vlan 10
 switchport mode access
 spanning-tree portfast
 spanning-tree guard root
!
interface GigabitEthernet0/1
 description Connection to Switch 2 GigabitEthernet0/1
 switchport trunk native vlan 999
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet0/2
 description Connection to Switch 3 GigabitEthernet0/1
 switchport trunk native vlan 999
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan10
 description classroom 1 and classroom 2
 ip address 192.168.10.1 255.255.255.0
!
interface Vlan11
 description classroom 3 and classroom 4
 ip address 192.168.11.1 255.255.255.0
 ip helper-address 192.168.10.254
!
interface Vlan12
 description secretary and principal
 ip address 192.168.12.1 255.255.255.0
 ip helper-address 192.168.10.254
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
logging 192.168.10.254
line con 0
 exec-timeout 6 50
 password 7 080C556D061716181E0E
 logging synchronous
 login
!
line aux 0
!
line vty 0 4
 exec-timeout 5 30
 password 7 080C557A0C150B1206
 logging synchronous
 login
line vty 5 15
 exec-timeout 5 30
 password 7 080C557E080A16001D1908
 logging synchronous
 login
!
!
ntp authentication-key 1 md5 0832494D1B1C112713181F13253920 7
ntp server 192.168.10.254 key 0
!
end

Lan-Switch2:

spanning-tree mode rapid-pvst
spanning-tree portfast default
!
interface FastEthernet0/1
 switchport access vlan 11
 switchport mode access
 spanning-tree portfast
 spanning-tree guard root
!
interface FastEthernet0/2
 switchport access vlan 11
 switchport mode access
 spanning-tree portfast
 spanning-tree guard root
!
interface FastEthernet0/3
 switchport access vlan 11
 switchport mode access
 spanning-tree portfast
 spanning-tree guard root
!
interface FastEthernet0/4
 switchport access vlan 11
 switchport mode access
 spanning-tree portfast
 spanning-tree guard root
!
interface FastEthernet0/5
 switchport access vlan 11
 switchport mode access
 spanning-tree portfast
 spanning-tree guard root
!
interface FastEthernet0/6
 switchport access vlan 11
 switchport mode access
 spanning-tree portfast
 spanning-tree guard root
!
interface FastEthernet0/7
 switchport access vlan 11
 switchport mode access
 spanning-tree portfast
 spanning-tree guard root
!
interface FastEthernet0/8
 switchport access vlan 11
 switchport mode access
 spanning-tree portfast
 spanning-tree guard root
!
interface FastEthernet0/9
 switchport access vlan 11
 switchport mode access
 spanning-tree portfast
 spanning-tree guard root
!
interface FastEthernet0/10
 switchport access vlan 11
 switchport mode access
 spanning-tree portfast
 spanning-tree guard root
!
interface FastEthernet0/11
 switchport access vlan 11
 switchport mode access
 spanning-tree portfast
 spanning-tree guard root
!
interface FastEthernet0/12
 switchport access vlan 11
 switchport mode access
 spanning-tree portfast
 spanning-tree guard root
!
interface FastEthernet0/13
 switchport access vlan 11
 switchport mode access
 spanning-tree portfast
 spanning-tree guard root
!
interface FastEthernet0/14
 switchport access vlan 11
 switchport mode access
 spanning-tree portfast
 spanning-tree guard root
!
interface FastEthernet0/15
 switchport access vlan 11
 switchport mode access
 spanning-tree portfast
 spanning-tree guard root
!
interface FastEthernet0/16
 switchport access vlan 11
 switchport mode access
 spanning-tree portfast
 spanning-tree guard root
!
interface FastEthernet0/17
 switchport access vlan 11
 switchport mode access
 spanning-tree portfast
 spanning-tree guard root
!
interface FastEthernet0/18
 switchport access vlan 11
 switchport mode access
 spanning-tree portfast
 spanning-tree guard root
!
interface FastEthernet0/19
 switchport access vlan 11
 switchport mode access
 spanning-tree portfast
 spanning-tree guard root
!
interface FastEthernet0/20
 switchport access vlan 11
 switchport mode access
 spanning-tree portfast
 spanning-tree guard root
!
interface FastEthernet0/21
 switchport access vlan 11
 switchport mode access
 spanning-tree portfast
 spanning-tree guard root
!
interface FastEthernet0/22
 switchport access vlan 11
 switchport mode access
 spanning-tree portfast
 spanning-tree guard root
!
interface FastEthernet0/23
 switchport access vlan 11
 switchport mode access
 spanning-tree portfast
 spanning-tree guard root
!
interface FastEthernet0/24
 switchport access vlan 11
 switchport mode access
 spanning-tree portfast
 spanning-tree guard root
!
interface GigabitEthernet0/1
 description Connection to switch 1 GigabitEthernet0/1
 switchport trunk native vlan 999
 switchport mode trunk
!
interface GigabitEthernet0/2
 description UNUSED
 switchport trunk native vlan 999
 switchport mode trunk
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan10
 description classroom 1 and classroom 2
 ip address 192.168.10.2 255.255.255.0
!
logging 192.168.10.254
!
!
!
line con 0
 password 7 080C556D061716181E0E
 logging synchronous
 login
 exec-timeout 6 50
!
line vty 0 4
 login
line vty 5 15
 login
!
!
end

Lan-Switch3:

spanning-tree mode rapid-pvst
spanning-tree portfast default
!
interface FastEthernet0/1
 switchport access vlan 12
 switchport mode access
 switchport voice vlan 12
 spanning-tree portfast
!
interface FastEthernet0/2
 switchport access vlan 12
 switchport mode access
 switchport voice vlan 12
 spanning-tree portfast
!
interface FastEthernet0/3
 switchport access vlan 12
 switchport mode access
 switchport voice vlan 12
 spanning-tree portfast
!
interface FastEthernet0/4
 switchport access vlan 12
 switchport mode access
 switchport voice vlan 12
 spanning-tree portfast
!
interface FastEthernet0/5
 switchport access vlan 12
 switchport mode access
 switchport voice vlan 12
 spanning-tree portfast
!
interface FastEthernet0/6
 switchport access vlan 12
 switchport mode access
 switchport voice vlan 12
 spanning-tree portfast
!
interface FastEthernet0/7
 switchport access vlan 12
 switchport mode access
 switchport voice vlan 12
 spanning-tree portfast
!
interface FastEthernet0/8
 switchport access vlan 12
 switchport mode access
 switchport voice vlan 12
 spanning-tree portfast
!
interface FastEthernet0/9
 switchport access vlan 12
 switchport mode access
 switchport voice vlan 12
 spanning-tree portfast
!
interface FastEthernet0/10
 switchport access vlan 12
 switchport mode access
 switchport voice vlan 12
 spanning-tree portfast
!
interface FastEthernet0/11
 switchport access vlan 12
 switchport mode access
 spanning-tree portfast
!
interface FastEthernet0/12
 switchport access vlan 12
 switchport mode access
 spanning-tree portfast
!
interface FastEthernet0/13
 switchport access vlan 12
 switchport mode access
 spanning-tree portfast
!
interface FastEthernet0/14
 switchport access vlan 12
 switchport mode access
 spanning-tree portfast
!
interface FastEthernet0/15
 switchport access vlan 12
 switchport mode access
 spanning-tree portfast
!
interface FastEthernet0/16
 switchport access vlan 12
 switchport mode access
 spanning-tree portfast
!
interface FastEthernet0/17
 switchport access vlan 12
 switchport mode access
 spanning-tree portfast
!
interface FastEthernet0/18
 switchport access vlan 12
 switchport mode access
 spanning-tree portfast
!
interface FastEthernet0/19
 switchport access vlan 12
 switchport mode access
 spanning-tree portfast
!
interface FastEthernet0/20
 switchport access vlan 12
 switchport mode access
 spanning-tree portfast
!
interface FastEthernet0/21
 switchport access vlan 12
 switchport mode access
 spanning-tree portfast
!
interface FastEthernet0/22
 switchport access vlan 12
 switchport mode access
 spanning-tree portfast
!
interface FastEthernet0/23
 switchport access vlan 12
 switchport mode access
 spanning-tree portfast
!
interface FastEthernet0/24
 switchport access vlan 12
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/1
 description Connection to Switch1 GigabitEthernet0/2
 switchport trunk native vlan 999
 switchport mode trunk
!
interface GigabitEthernet0/2
 description UNUSED
 switchport trunk native vlan 999
 switchport mode trunk
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan10
 description classroom 1 and classroom 2
 ip address 192.168.10.3 255.255.255.0
!
logging 192.168.10.254
!
!
!
line con 0
 password 7 080C556D061716181E0E
 logging synchronous
 login
 exec-timeout 6 50
!
line vty 0 4
 login
line vty 5 15
 login
!
!
end
2
  • Since you've changed the question, I deleted my original answer. Your configurations look mostly correct. Are your phones getting addresses on the .12 subnet? If not, have you verified the correct scope on the DHCP server?
    – Ron Trunk
    Nov 3 '17 at 16:40
  • No addresses are being given to phones on the .12 subnet.
    – GreenCoder
    Nov 4 '17 at 10:00
1

First of all, you need to enable IP routing on your Lan-Switch1, which I do not see in your configuration, then verify the following points:

  • You can reach/ping DHCP server (192.168.10.254) from Int VLAN 12 on Lan-Switch1.
  • VLAN 12 are configured on all network devices.
  • DHCP service is on and DHCP scope for IP Phone are correctly configured on DHCP server (192.168.10.254).
  • Configure a Voice port on Lan-Switch1 and test your IP Phone by connecting it to this port:

Updated answer:

Below is my setup. Both IP_Phone and PC (in VLAN 12 on Switch1) can get the IP addresses from DHCP server:

enter image description here enter image description here

enter image description here

//COnfiguration on Switch0

Vlan 10
 name Classroom1_2
Vlan 11
 name Classroom3_4
vlan 12   
 name Secretary_Principal
!
ip routing  
!
interface FastEthernet0/24
 description DHCP Server
 switchport access vlan 10
 switchport mode access
!
interface GigabitEthernet0/1
 description Switch1 (g0/1)
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface Vlan10
 description classroom 1 and classroom 2
 ip address 192.168.10.1 255.255.255.0
!
interface Vlan11
 description classroom 3 and classroom 4
 ip address 192.168.11.1 255.255.255.0
 ip helper-address 192.168.10.254
!
interface Vlan12
 description secretary and principal
 ip address 192.168.12.1 255.255.255.0
 ip helper-address 192.168.10.254



 //Configuration on Switch1
Vlan 10
 name Classroom1_2
vlan 12   
 name Secretary_Principal
!
interface FastEthernet0/1
 description IP_Phone
 switchport access vlan 12
 switchport mode access
 switchport voice vlan 12
 spanning-tree portfast
!
interface FastEthernet0/2
 description PC
 switchport access vlan 12
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/1
 description Switch0 (g0/1)
 switchport mode trunk
!
interface Vlan10
 description classroom 1 and classroom 2
 ip address 192.168.10.3 255.255.255.0
!

I hope it is helpful.

6
  • ip routing is enabled. I checked my configuration again. it states "ip routing" after I do the show run command.
    – GreenCoder
    Nov 4 '17 at 10:11
  • i can ping the DHCP server from Lan-Switch1
    – GreenCoder
    Nov 4 '17 at 10:12
  • @GreenCoder Can you ping DHCH server from Int VLAN 12? And try with all the points I listed out.
    – Hung Tran
    Nov 4 '17 at 11:38
  • It has worked. Each of the two phones are now getting .12 addresses 192.168.12.111 and 192.168.12.112. Is there any way I can now put a phone number of each of the two phones? Do I need a 2811 router for that? as I have seen it done that way in examples
    – GreenCoder
    Nov 4 '17 at 15:06
  • 1
    @GreenCoder, that is a different question, and it should be asked in a new question. It is also very broad, so you should narrow the scope of the question.
    – Ron Maupin
    Nov 4 '17 at 15:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.