1

During a migration various L2 equipment will be replaced with all Cisco L3 switches and over time traffic migrated to routed subnets instead of trunked. There are two straightforward approaches that come to mind for connections between sites (all of this is private fiber or private microwave so there is L2 connectivity between ach).

One is trunked VLAN's, where adjacent switches can also share a VLAN used for their adjacent interfaces. So the single port that connects two sites together over microwave has (say) VLANS 10,20,30,40,50 allowed, where 10 is used just for adjacency, and 20,30,40,50 are legacy vlans that need to be trunked, and some other VLAN's not allowed carry new, routed traffic.

E.g. (example just relevant parts of one end):

interface GigabitEthernet 0/0
  switchport trunk allowed vlan 10,20,30
  switchport trunk encapsulation dot1q
  switchport mode trunk
interface VLAN10
  ip address 10.127.10.1 255.255.255.0

Another way is to set the port to routed (no switchport), and then use a subinterface for 10, subinterface for 20, etc. Like you would to a router. The routed traffic flows over the (non-sub) interface, the trunked VLAN's over each subinterface separately. E.g.

interface GigabitEthernet 0/0
  no switchport
  ip address 10.127.10.1 255.255.255.0
interface GigabitEthernet 0/0.1
  encapsulation dot1Q 20
interface GigabitEthernet 0/0.2
  encapsulation dot1Q 30

Is there a downside to the latter? I ask because from a transition standpoint, each trunked VLAN will later go away, and this way the subinterfaces could be removed as they go, leaving ultimately the interface with no subinterfaces, and no between-site trunked VLAN's at all, just routed ports and local VLAN's.

In simulating these in GNS3 I can't see any real difference in behavior.

The former is obviously cleaner looking for a lot of VLAN's being trunked, but the goal is to start removing these one by one leaving none, and conceptually I'm leaning toward the latter to be clear during changes.

Yet in many legacy sites when I look at ones with no user data trunked, yet I see VLAN's used to connect switches instead of setting the ports to "no switchport" (yes, in L2 only environments).

Is there a downside to using "no switchport" on a L3 switch over private fiber and private microwave to connect sites?

4

The difference is, in the first example, your VLANS can span several switches. In the second example, the VLANs terminate on the router interface.

As an example, with the first configuration, you can have other switch ports on VLAN 10, 20, or 30. You can also have a second trunk port to extend the VLANs to another switch.

With the second configuration, interface gi 0/0.20 is not part of the same L2 domain as a port on VLAN 20, nor a trunk port tagging packets for VLAN 20. It may seem counter-intuitive, but while both a trunk port and the subinterface tag packets with VID 20, they are not part of the same L2 domain.

  • Yes, and this is definitely a case of premature-inquiry. I had put this in GNS3 to test and had the routing working great, but never tested VLAN continuity. While you were answering I started doing it, and realized it was not working, and now I see why. Thank you. – Linwood Nov 4 '17 at 19:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.