1

enter image description here I couldn't get a successful ping from the router to the distribution switch

                       Distribution Switch

Dist_Switch#sh ru
Dist_Switch#sh running-config 
Building configuration...

Current configuration : 4493 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
service password-encryption
!
hostname Dist_Switch
!
!
!
no ip domain-lookup
ip domain-name 19HyperMarket_Sdn._Bhd.
!
username adam secret 5 $1$mERr$4dpRATIgxQacPVK0CfNV4/
!
!
spanning-tree mode pvst
spanning-tree vlan 10,20,30,40,50,99 priority 24576
!
interface Port-channel 1
 switchport trunk native vlan 99
 switchport mode trunk
!
interface Port-channel 4
 switchport trunk native vlan 99
 switchport mode trunk
!
interface FastEthernet0/1
 description Connection to Switch1
 switchport trunk native vlan 99
 switchport mode trunk
 channel-group 1 mode desirable
!
interface FastEthernet0/2
 description Connection to Switch1
 switchport trunk native vlan 99
 switchport mode trunk
 channel-group 1 mode desirable
!
interface FastEthernet0/3
 description Connection to Switch3
 switchport trunk native vlan 99
 switchport mode trunk
 channel-group 4 mode desirable
!
interface FastEthernet0/4
 description Connection to Switch3
 switchport trunk native vlan 99
 switchport mode trunk
 channel-group 4 mode desirable
!
interface FastEthernet0/5
 description These ports have been disabled
 shutdown
!
interface FastEthernet0/6
 description These ports have been disabled
 shutdown
!
interface FastEthernet0/7
 description These ports have been disabled
 shutdown
!
interface FastEthernet0/8
 description These ports have been disabled
 shutdown
!
interface FastEthernet0/9
 description These ports have been disabled
 shutdown
!
interface FastEthernet0/10
 description These ports have been disabled
 shutdown
!
interface FastEthernet0/11
 description These ports have been disabled
 shutdown
!
interface FastEthernet0/12
 description These ports have been disabled
 shutdown
!
interface FastEthernet0/13
 description These ports have been disabled
 shutdown
!
interface FastEthernet0/14
 description These ports have been disabled
 shutdown
!
interface FastEthernet0/15
 description These ports have been disabled
 shutdown
!
interface FastEthernet0/16
 description These ports have been disabled
 shutdown
!
interface FastEthernet0/17
 description These ports have been disabled
 shutdown
!
interface FastEthernet0/18
 description These ports have been disabled
 shutdown
!
interface FastEthernet0/19
 description These ports have been disabled
 shutdown
!
interface FastEthernet0/20
 description These ports have been disabled
 shutdown
!
interface FastEthernet0/21
 description These ports have been disabled
 shutdown
!
interface FastEthernet0/22
 description These ports have been disabled
 shutdown
!
interface FastEthernet0/23
 description These ports have been disabled
 shutdown
!
interface FastEthernet0/24
 description These ports have been disabled
 shutdown
!
interface GigabitEthernet0/1
 switchport mode trunk
!
interface GigabitEthernet0/2
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan99
 description Management Department Network
 mac-address 00e0.8fd5.2b01
 ip address 172.22.129.162 255.255.255.240
!
ip default-gateway 172.22.129.161
!
banner motd ^C

^C
!
!
!
line con 0
 logging synchronous
 login local
!
line vty 0 4
 login local
 transport input ssh
line vty 5 15
 login local
 transport input ssh
!
!
!
end
==================================================================================
                               Router
Router0#sh ru
Building configuration...

Current configuration : 3075 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
service password-encryption
!
hostname Router0
!
!
!
enable secret 5 $1$mERr$4dpRATIgxQacPVK0CfNV4/
!
!
!
!
!
!
no ip cef
no ipv6 cef
!
!
!
username adam privilege 15 secret 5 $1$mERr$4dpRATIgxQacPVK0CfNV4/
!
!
license udi pid CISCO2901/K9 sn FTX1524B6P2
!
!
!
!
!
!
!
!
!
no ip domain-lookup
ip domain-name 19HyperMarket_Sdn._Bhd.
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.0
!
interface GigabitEthernet0/0
 description Local Network Link
 no ip address
 duplex auto
 speed auto
!
interface GigabitEthernet0/0.10
 description Connection to Sales VLAN
 encapsulation dot1Q 10
 ip address 172.22.128.1 255.255.255.0
!
interface GigabitEthernet0/0.20
 description Connection to Finance VLAN
 encapsulation dot1Q 20
 ip address 172.22.129.1 255.255.255.192
!
interface GigabitEthernet0/0.30
 description Connection to Admin VLAN
 encapsulation dot1Q 30
 ip address 172.22.129.65 255.255.255.224
!
interface GigabitEthernet0/0.40
 description Connection to IT VLAN
 encapsulation dot1Q 40
 ip address 172.22.129.97 255.255.255.224
!
interface GigabitEthernet0/0.50
 description Connection to Inventory & Delivery VLAN
 encapsulation dot1Q 50
 ip address 172.22.129.129 255.255.255.224
!
interface GigabitEthernet0/0.99
 description Connection to Management VLAN
 encapsulation dot1Q 99 native
 ip address 172.22.129.161 255.255.255.240
!
interface GigabitEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
ip classless
!
ip flow-export version 9
!
!
!
banner motd ^C


^C
!
!
!
!
line con 0
 logging synchronous
 login local
!
line aux 0
!
line vty 0 4
 login local
 transport input ssh
line vty 5 15
 login local
 transport input ssh
!
!
!
end
  • Where are all the layer 2 VLANs? I don't see them configured on the 2960 switch and i don't see VTP client mode configured either. Also what interface are you pinging on the switch? You don't have any default routes or default gateway on the router. – user36472 Nov 7 '17 at 10:11
2

It is because of native vlan mismatch between Router (g0/0, g0/0.99) and Dist_Switch (g0/1):

Dist_Switch#
interface GigabitEthernet0/1
 switchport mode trunk

Router0#
interface GigabitEthernet0/0.99
 description Connection to Management VLAN
 encapsulation dot1Q 99 native
 ip address 172.22.129.161 255.255.255.240

To fix this, you should configure G0/1 on Dist_Switch to trunk specific VLANs and VLAN 99 as native VLAN:

Dist_Switch#
 interface GigabitEthernet0/1
  switchport trunk native vlan 99
  switchport trunk allowed vlan 10,20,30,40,50,99
  switchport mode trunk
| improve this answer | |
  • you are spot on! i really appreciate it thank you – BitterSoda Nov 7 '17 at 10:39
  • Glad to hear it works and you are welcome! – Hung Tran Nov 7 '17 at 10:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.