8

I am trying to upgrade from 6.0.2.U6.5c to nxos.7.0.3.I4.7, before upgrade i want to make sure it pass all checks but i got this error. This switch isn't in production yet but want to make sure it goes well and smooth. Am i doing something wrong?

show version:

Software
  BIOS:      version 2.6.0
  loader:    version N/A
  kickstart: version 6.0(2)U6(5c)
  system:    version 6.0(2)U6(5c)
  Power Sequencer Firmware:
             Module 1: version v1.0
  SFP uC:    version 2.12
  BIOS compile time:       08/06/2014
  kickstart image file is: bootflash:///n3000-uk9-kickstart.6.0.2.U6.5c.bin
  kickstart compile time:  4/6/2016 22:00:00 [04/07/2016 05:46:42]
  system image file is:    bootflash:///n3000-uk9.6.0.2.U6.5c.bin
  system compile time:     4/6/2016 22:00:00 [04/07/2016 06:14:31]

Verifying image impact and it FAIL

switch# show install all impact system bootflash:nxos.7.0.3.I4.7.bin
Installer is forced disruptive

Verifying image bootflash:/n3000-uk9-kickstart.6.0.2.U6.5c.bin for boot variable "kickstart".
[########################################] 100% -- SUCCESS

Verifying image bootflash:/nxos.7.0.3.I4.7.bin for boot variable "system".
[########################################] 100% -- SUCCESS

Verifying image type.
[########################################] 100% -- SUCCESS

Extracting "system" version from image bootflash:/nxos.7.0.3.I4.7.bin.
[#                                       ]   0% -- FAIL. Return code 0x404F0003 (SRG file not present/cannot be opened).
Pre-upgrade check failed. Return code 0x40930012 (SRG extraction failed).

I do have enough space too:

switch# dir
       4096    Nov 06 20:29:22 2017  .patch/
        168    Nov 06 17:48:27 2017  20171106_174415_poap_3725_init.log
          0    Nov 13 14:31:14 2017  20171113_143114_poap_3935_init.log
        173    Nov 14 14:03:20 2017  dhclient_log
        640    Oct 21 23:06:15 2013  license_FOC1734R15X_13_1.lic
   37857280    Nov 06 19:52:06 2017  n3000-uk9-kickstart.6.0.2.U6.5c.bin
  206969903    Nov 06 19:47:52 2017  n3000-uk9.6.0.2.U6.5c.bin
  702663680    Nov 13 20:53:54 2017  nxos.7.0.3.I4.7.bin
       1024    Nov 06 20:29:05 2017  sprom_cstruct_2_0_0
       1024    Nov 06 20:29:40 2017  sprom_cstruct_3_0_0
       4096    Jan 29 23:00:20 2010  vdc_2/
       4096    Jan 29 23:00:20 2010  vdc_3/
       4096    Jan 29 23:00:20 2010  vdc_4/
       4096    Nov 06 20:29:23 2017  virtual-instance/

Usage for bootflash://
 1078501376 bytes used
  816668672 bytes free
 1895170048 bytes total

Notes: I have also verify no TCP connection is opened base on this bug https://bst.cloudapps.cisco.com/bugsearch/bug/CSCut84783/?referring_site=bugquickviewredir

  • Have you checked whether the tmp directory is not full? When the extract process is running it's using the /var/tmp directory as the buffer. You can check with show system internal dir /var/tmp or show system internal flash – user36472 Nov 14 '17 at 17:35
  • You can also reload the switch to clear the temp data. Then you can use the show install command. – user36472 Nov 14 '17 at 17:38
  • I did reload many many time but same result, /tmp is empty i have confirm that too. – Satish Nov 14 '17 at 18:00
  • There seem to be some old articles about 4.2 to 5.2 upgrades where the SRG extraction failure error meant to you had to do some intermediate upgrades. Might not be relevant but perhaps worth a look. – Todd Wilcox Nov 14 '17 at 18:14
  • @ToddWilcox is right, i think you need to upgrade to another smaller version first and then to the version you want to upgrade to. – user36472 Nov 14 '17 at 18:15
4

Soution:

For testing i have download 7.0(3)I4(4) nx-os file but same issue, no luck :(

But then i decided just Install instead of verification and it works!

switch# install all nxos bootflash:nxos.7.0.3.I4.4.bin
Installer is forced disruptive

Verifying image bootflash:/nxos.7.0.3.I4.4.bin for boot variable "nxos".
[########################################] 100% -- SUCCESS

Verifying image type.
[########################################] 100% -- SUCCESS

Extracting "nxos" version from image bootflash:/nxos.7.0.3.I4.4.bin.
[########################################] 100% -- SUCCESS

Extracting "bios" version from image bootflash:/nxos.7.0.3.I4.4.bin.
[########################################] 100% -- SUCCESS

Performing runtime checks.
[########################################] 100% -- SUCCESS

Performing module support checks.
[########################################] 100% -- SUCCESS

Notifying services about system upgrade.
[########################################] 100% -- SUCCESS



Compatibility check is done:
Module  bootable          Impact  Install-type  Reason
------  --------  --------------  ------------  ------
     1       yes      disruptive         reset  Unsupported in new image, module needs to be powered off



Images will be upgraded according to following table:
Module             Image         Running-Version             New-Version  Upg-Required
------  ----------------  ----------------------  ----------------------  ------------
     1         kickstart            6.0(2)U6(5c)             7.0(3)I4(4)           yes
     1              bios      v4.0.0(12/05/2016)      v3.8.0(01/25/2016)            no
     1            SFP-uC                   v2.12                    v0.0            no


Switch will be reloaded for disruptive upgrade.
Do you want to continue with the installation (y/n)?  [n] y 

Chicken dinner!

show version:

Software
  BIOS: version 4.0.0
  NXOS: version 7.0(3)I4(4)
  BIOS compile time:  12/05/2016
  NXOS image file is: bootflash:///nxos.7.0.3.I4.4.bin
  NXOS compile time:  10/24/2016 15:00:00 [10/24/2016 22:44:16]


Hardware
  cisco Nexus3000 C3064PQ Chassis
  Intel(R) Celeron(R) CPU        P4505  @ 1.87GHz with 3903432 kB of memory.
  Processor Board ID FOC17211CBG

  Device name: switch
  bootflash:    1596672 kB
  usb1:               0 kB (expansion flash)
2

Due to big changes in the new NX-OS version 7 there is only a few upgrade possibilities. From Cisco release note whitepapers:

You can perform an In-Service Software Upgrade (ISSU) from the following release to Cisco NX-OS Release 7.0(3)I7(1):

  • 7.0(3)I6(1)
  • 7.0(3)i5(2)
  • 7.0(3)i5(1)

The only supported method of upgrading is install all from Release 6.0(2)U6(3) due to the need to upgrade the BIOS. Without the Release 7.0(3)I7(1) BIOS, the 7.0(3)I7(1) image will not load.

Link to article: https://www.cisco.com/c/en/us/td/docs/switches/datacenter/nexus3000/sw/release/70371/n3k_70371_nxos_rn.html#_Toc453307910

  • I have upgraded to 6.0(2)U6(8) but still getting same error, also i have upgrade BIOS from 2.6 to 4.0.0 latest but still same issue. I don't care about ISSU at this point because this switch is in lab not in production. – Satish Nov 14 '17 at 19:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.