5

I am trying to set up a Cisco ASA 5505 firewall on my network, with some important stipulations. I get two usable static IPs from my ISP, one of which I want to use for "home-traffic", and the other for "work-traffic". 3 interfaces are active at the moment, one being the outside interface, one given the 10.1.0.0/24 subnet, and one given the 10.0.0.0/24 subnet.

The way I have it setup at the moment doesn't appear to be working, however. The "home-network" subnet appears to be working fine, with the NAT translating the private IPs in the 10.0.0.0/24 range to the first public IP. I then went to setup NAT on the other interface (for work), and configured it so that it would translate the work subnet to the second public IP. This does not seem to work at all.

Am I doing this setup correctly, or have I missed the point entirely?

: Saved
:
ASA Version 8.2(5) 
!
hostname io-firewall
enable password OqFyPF1LKWo.0KDG encrypted
passwd OqFyPF1LKWo.0KDG encrypted
names
name 24.156.39.1 primary-isp-gateway description Suddenlink ISP Gateway
!
interface Ethernet0/0
!
interface Ethernet0/1
 switchport access vlan 2
!
interface Ethernet0/2
 switchport access vlan 12
!
interface Ethernet0/3
 shutdown
!
interface Ethernet0/4
 shutdown
!
interface Ethernet0/5
 shutdown
!
interface Ethernet0/6
 shutdown
!
interface Ethernet0/7
 shutdown
!
interface Vlan1
 nameif outside
 security-level 0
 ip address 24.156.39.89 255.255.255.0 
!
interface Vlan2
 nameif internal-home
 security-level 50
 ip address 10.0.0.1 255.255.255.0 
!
interface Vlan12
 no forward interface Vlan2
 nameif internal-work
 security-level 50
 ip address 10.1.0.1 255.255.255.0 
!
boot config disk0:/startup-config
ftp mode passive
clock timezone MST -7
dns domain-lookup outside
dns server-group DefaultDNS
 name-server 8.8.8.8
 name-server 8.8.4.4
same-security-traffic permit intra-interface
access-list internal-work_nat_outbound extended permit ip 10.1.0.0 255.255.255.0 any 
access-list internal-home_nat_outbound extended permit ip 10.0.0.0 255.255.255.0 any 
pager lines 24
logging enable
logging asdm informational
mtu outside 1500
mtu internal-home 1500
mtu internal-work 1500
ip verify reverse-path interface outside
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
global (outside) 101 interface
global (outside) 102 24.156.39.90 netmask 255.255.255.0
nat (internal-home) 101 access-list internal-home_nat_outbound
nat (internal-work) 102 access-list internal-work_nat_outbound
route outside 0.0.0.0 0.0.0.0 primary-isp-gateway 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
http server enable
http 10.0.0.0 255.255.255.0 internal-home
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
telnet timeout 5
ssh timeout 5
ssh version 2
console timeout 0
dhcpd address 10.0.0.2-10.0.0.5 internal-home
dhcpd dns 8.8.8.8 8.8.4.4 interface internal-home
dhcpd enable internal-home
!
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
ntp server 40.85.153.82 source outside
ntp server 13.65.88.161 source outside prefer
ssl encryption aes128-sha1 aes256-sha1
webvpn
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map global_policy
 class inspection_default
  inspect icmp 
!
service-policy global_policy global
prompt hostname context 
no call-home reporting anonymous
call-home
 profile CiscoTAC-1
  no active
  destination address http https://tools.cisco.com/its/service/oddce/services/DDCEService
  destination address email callhome@cisco.com
  destination transport-method http
  subscribe-to-alert-group diagnostic
  subscribe-to-alert-group environment
  subscribe-to-alert-group inventory periodic monthly
  subscribe-to-alert-group configuration periodic monthly
  subscribe-to-alert-group telemetry periodic daily
Cryptochecksum:006736c3cf70dab2a88371d0462dd20b
: end
no asdm history enable
  • You don't assign additional addresses. The ASA (and PIX) will "proxy-arp" for the additional addresses it's assigned to handle. It's not like IOS where you add secondary addresses. – Ricky Beam Nov 17 '17 at 5:18
  • @RickyBeam thats what I seem to have gathered from Googling online, however, I cannot access the internet from the "internal-work" vlan. I think it has to do with the licensing restrictions but I can't be sure. – duper51 Nov 17 '17 at 5:53
  • Did any answer help you? If so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you could provide and accept your own answer. – Ron Maupin Feb 21 '18 at 20:21
1

The issue is likely at the part netmask 255.255.255.0 of:

global (outside) 102 24.156.39.90 netmask 255.255.255.0

Please change it to the following line and try again:

global (outside) 102 24.156.39.90

If it still does not, please update your question with the output of following packet-tracer command. I will update my answer accordingly:

packet-tracer input internal-work tcp 10.1.0.10 56789 8.8.8.8 443

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.