2

I'm not entirely sure what I'm doing wrong. I configured the inter-VLAN routing from the main router with the IP addresses I used as default router for the DHCP pools I also set in the main router. I set the spanning-tree VLANs and even added switchport native VLAN for all of the switches in the spanning tree. I added one of the switchport access to the first PC to test it, but it isn't working and I need some help. Here's my packet tracer file: https://drive.google.com/file/d/1g6yE9gmgRWFj6gWLt-FYNAylYLyYyqPV/view?usp=sharing

Here's the map of the network. None of the PCs can get DHCP. I also didn't hook up the Wireless AP because I wanted to make sure the PCs could get DHCP, first. The Main Router and 2 main switches are in the MDF and the other 6 function in the IDF. Network Map from Packet Tracer. This is how it's supposed to look, but it's not functioning properly.

Router:

Building configuration...

Current configuration : 3910 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
service password-encryption
!
hostname Router
!
!
!
enable password 7 0822404F1A0A
!
!
ip dhcp excluded-address 192.168.8.1 192.168.8.10
ip dhcp excluded-address 192.168.9.1 192.168.9.10
ip dhcp excluded-address 192.168.9.129 192.168.9.138
ip dhcp excluded-address 192.168.10.1 192.168.10.10
ip dhcp excluded-address 192.168.10.65 192.168.10.74
ip dhcp excluded-address 192.168.10.81 192.168.10.90
ip dhcp excluded-address 192.168.10.97 192.168.10.106
ip dhcp excluded-address 192.168.10.113 192.168.10.116
ip dhcp excluded-address 192.168.10.121 192.168.10.122
ip dhcp excluded-address 192.168.10.124 192.168.10.125
!
ip dhcp pool Students-ELEMENTARY-POOL
 network 192.168.8.0 255.255.255.0
 default-router 192.168.8.1
ip dhcp pool Wireless-ELEMENTARY-POOL
 network 192.168.9.0 255.255.255.128
 default-router 192.168.9.1
ip dhcp pool VoIP-ELEMENTARY-POOL
 network 192.168.9.128 255.255.255.128
 default-router 192.168.9.129
ip dhcp pool Faculty-ELEMENTARY-POOL
 network 192.168.10.0 255.255.255.192
 default-router 192.168.10.1
ip dhcp pool IP-Camera-ELEMENTARY-Pool
 network 192.168.10.64 255.255.255.240
 default-router 192.168.10.65
ip dhcp pool Admin-ELEMENTARY-POOL
 network 192.168.10.80 255.255.255.240
 default-router 192.168.10.81
ip dhcp pool Printer-ELEMENTARY-POOL
 network 192.168.10.96 255.255.255.240
 default-router 192.168.10.97
ip dhcp pool Staff-ELEMENTARY-POOL
 network 192.168.10.112 255.255.255.248
 default-router 192.168.10.113
ip dhcp pool Management-ELEMENTARY-POOL
 network 192.168.10.120 255.255.255.252
 default-router 192.168.10.121
ip dhcp pool Native-ELEMENTARY-POOL
 network 192.168.10.124 255.255.255.252
 default-router 192.168.10.125
!
!
!
no ip cef
no ipv6 cef
!
!
!
!
license udi pid CISCO2901/K9 sn FTX1524EIIO
!
!
!
!
!
!
!
!
!
no ip domain-lookup
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface GigabitEthernet0/0
 description MCE_MDF_Router to MCE_MDF_CoreSW1
 no ip address
 duplex auto
 speed auto
!
interface GigabitEthernet0/0.10
 encapsulation dot1Q 10
 ip address 192.168.10.81 255.255.255.240
!
interface GigabitEthernet0/0.20
 encapsulation dot1Q 20
 ip address 192.168.8.1 255.255.255.0
!
interface GigabitEthernet0/0.30
 encapsulation dot1Q 30
 ip address 192.168.10.113 255.255.255.248
!
interface GigabitEthernet0/0.40
 encapsulation dot1Q 40
 ip address 192.168.10.1 255.255.255.192
!
interface GigabitEthernet0/0.50
 encapsulation dot1Q 50
 ip address 192.168.10.97 255.255.255.240
!
interface GigabitEthernet0/0.60
 encapsulation dot1Q 60
 ip address 192.168.9.1 255.255.255.128
!
interface GigabitEthernet0/0.70
 encapsulation dot1Q 70
 ip address 192.168.9.129 255.255.255.128
!
interface GigabitEthernet0/0.80
 encapsulation dot1Q 80
 ip address 192.168.10.121 255.255.255.252
!
interface GigabitEthernet0/0.88
 encapsulation dot1Q 88
 ip address 192.168.10.65 255.255.255.240
!
interface GigabitEthernet0/0.99
 encapsulation dot1Q 99 native
 ip address 192.168.10.125 255.255.255.252
!
interface GigabitEthernet0/1
 no ip address
 duplex auto
 speed auto
!
interface GigabitEthernet0/1.10
 encapsulation dot1Q 10
 no ip address
!
interface GigabitEthernet0/1.20
 encapsulation dot1Q 20
 no ip address
!
interface GigabitEthernet0/1.99
 encapsulation dot1Q 99 native
 no ip address
!
interface Serial0/0/0
 no ip address
 clock rate 2000000
 shutdown
!
interface Serial0/0/1
 no ip address
 clock rate 2000000
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
ip classless
!
ip flow-export version 9
!
!
!
no cdp run
!
banner motd ^CNo Unauthorized Access^C
!
!
!
!
line con 0
 exec-timeout 15 0
 password 7 0822455D0A16
 logging synchronous
 login
!
line aux 0
!
line vty 0 4
 exec-timeout 15 0
 password 7 0822455D0A16
 logging synchronous
 login
line vty 5 15
 exec-timeout 15 0
 password 7 0822455D0A16
 logging synchronous
 login
!
!
!
end

MDF Switch Core 1:

Building configuration...

Current configuration : 3369 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
spanning-tree vlan 10,20,30,40,50,60 priority 24576
spanning-tree vlan 70,80,88,99 priority 28672
!
interface FastEthernet0/1
 description MCE_MDF_CoreSw1 to MCE_IDF_Switch1_STUDENT
 switchport trunk native vlan 99
 switchport mode trunk
 switchport nonegotiate
!
interface FastEthernet0/2
 description MCE_MDF_CoreSw1 to MCE_IDF_Switch2
 switchport access vlan 80
 switchport trunk native vlan 99
 switchport mode trunk
!
interface FastEthernet0/3
 description MCE_MDF_CoreSw1 to MCE_IDF_Switch3
 switchport access vlan 88
 switchport trunk native vlan 99
 switchport mode trunk
!
interface FastEthernet0/4
 description MCE_MDF_CoreSw1 to MCE_IDF_Switch4
 switchport trunk native vlan 99
 switchport mode trunk
!
interface FastEthernet0/5
 description MCE_MDF_CoreSw1 to MCE_IDF_Switch5
 switchport trunk native vlan 99
 switchport mode trunk
!
interface FastEthernet0/6
 description MCE_MDF_CoreSw1 to MCE_IDF_Switch6
 switchport trunk native vlan 99
 switchport trunk allowed vlan 10
 switchport mode trunk
!
interface FastEthernet0/7
 switchport trunk native vlan 99
 switchport mode trunk
!
interface FastEthernet0/8
 switchport trunk native vlan 99
 switchport mode trunk
!
interface FastEthernet0/9
 switchport trunk native vlan 99
 switchport mode trunk
!
interface FastEthernet0/10
 switchport trunk native vlan 99
 switchport mode trunk
!
interface FastEthernet0/11
 switchport trunk native vlan 99
 switchport mode trunk
!
interface FastEthernet0/12
 switchport trunk native vlan 99
 switchport mode trunk
!
interface FastEthernet0/13
 switchport trunk native vlan 99
 switchport mode trunk
!
interface FastEthernet0/14
 switchport trunk native vlan 99
 switchport mode trunk
!
interface FastEthernet0/15
 switchport trunk native vlan 99
 switchport mode trunk
!
interface FastEthernet0/16
 switchport trunk native vlan 99
 switchport mode trunk
!
interface FastEthernet0/17
 switchport trunk native vlan 99
 switchport mode trunk
!
interface FastEthernet0/18
 switchport trunk native vlan 99
 switchport mode trunk
!
interface FastEthernet0/19
 switchport trunk native vlan 99
 switchport mode trunk
!
interface FastEthernet0/20
 switchport trunk native vlan 99
 switchport mode trunk
!
interface FastEthernet0/21
 switchport trunk native vlan 99
 switchport mode trunk
!
interface FastEthernet0/22
 switchport trunk native vlan 99
 switchport mode trunk
!
interface FastEthernet0/23
 switchport trunk native vlan 99
 switchport mode trunk
!
interface FastEthernet0/24
 switchport access vlan 60
 switchport trunk native vlan 99
 switchport mode trunk
 switchport port-security maximum 60
 switchport port-security violation restrict 
!
interface GigabitEthernet0/1
 description MCE_MDF_CoreSw1 to MCE_MDF_Router
 switchport trunk native vlan 99
 switchport mode trunk
!
interface GigabitEthernet0/2
 description MCE_MDF_CoreSw1 to MCE_MDF_CoreSw2
 switchport trunk native vlan 99
 switchport mode trunk
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan80
 mac-address 0002.17d4.6101
 ip address 192.168.10.122 255.255.255.248
!
ip default-gateway 192.168.10.125
!
!
!
!
line con 0
!
line vty 0 4
 login
line vty 5 15
 login
!
!
!
end

MDF Switch Core 2:

Building configuration...

Current configuration : 3056 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
!
!
!
no spanning-tree vlan 10,60
spanning-tree mode pvst
spanning-tree extend system-id
spanning-tree vlan 70,80,88,99 priority 24576
spanning-tree vlan 10,20,30,40,50,60 priority 28672
!
interface FastEthernet0/1
 switchport access vlan 10
 switchport trunk native vlan 99
 switchport mode trunk
!
interface FastEthernet0/2
 switchport access vlan 20
 switchport trunk native vlan 99
 switchport mode trunk
!
interface FastEthernet0/3
 switchport access vlan 30
 switchport trunk native vlan 99
 switchport mode trunk
!
interface FastEthernet0/4
 switchport access vlan 40
 switchport trunk native vlan 99
 switchport mode trunk
!
interface FastEthernet0/5
 switchport access vlan 50
 switchport trunk native vlan 99
 switchport mode trunk
!
interface FastEthernet0/6
 switchport access vlan 60
 switchport trunk native vlan 99
 switchport mode trunk
!
interface FastEthernet0/7
 switchport trunk native vlan 99
 switchport mode trunk
!
interface FastEthernet0/8
 switchport trunk native vlan 99
 switchport mode trunk
!
interface FastEthernet0/9
 switchport trunk native vlan 99
 switchport mode trunk
!
interface FastEthernet0/10
 switchport trunk native vlan 99
 switchport mode trunk
!
interface FastEthernet0/11
 switchport trunk native vlan 99
 switchport mode trunk
!
interface FastEthernet0/12
 switchport trunk native vlan 99
 switchport mode trunk
!
interface FastEthernet0/13
 switchport trunk native vlan 99
 switchport mode trunk
!
interface FastEthernet0/14
 switchport trunk native vlan 99
 switchport mode trunk
!
interface FastEthernet0/15
 switchport trunk native vlan 99
 switchport mode trunk
!
interface FastEthernet0/16
 switchport trunk native vlan 99
 switchport mode trunk
!
interface FastEthernet0/17
 switchport trunk native vlan 99
 switchport mode trunk
!
interface FastEthernet0/18
 switchport trunk native vlan 99
 switchport mode trunk
!
interface FastEthernet0/19
 switchport trunk native vlan 99
 switchport mode trunk
!
interface FastEthernet0/20
 switchport trunk native vlan 99
 switchport mode trunk
!
interface FastEthernet0/21
 switchport trunk native vlan 99
 switchport mode trunk
!
interface FastEthernet0/22
 switchport trunk native vlan 99
 switchport mode trunk
!
interface FastEthernet0/23
 switchport trunk native vlan 99
 switchport mode trunk
!
interface FastEthernet0/24
 switchport access vlan 60
 switchport trunk native vlan 99
 switchport mode trunk
 switchport port-security maximum 60
 switchport port-security violation restrict 
!
interface GigabitEthernet0/1
 switchport trunk native vlan 99
 switchport mode trunk
!
interface GigabitEthernet0/2
 switchport trunk native vlan 99
 switchport mode trunk
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan80
 mac-address 0007.ecb7.0001
 ip address 192.168.10.123 255.255.255.248
!
ip default-gateway 192.168.10.125
!
!
!
!
line con 0
!
line vty 0 4
 login
line vty 5 15
 login
!
!
!
end

IDF Switch:

Building configuration...

Current configuration : 3363 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
interface FastEthernet0/1
 description MCE_IDF1_Switch1_STUDENT to PC0
 switchport access vlan 20
 switchport trunk native vlan 99
 switchport mode access
!
interface FastEthernet0/2
 switchport access vlan 20
 switchport trunk native vlan 99
 switchport mode access
!
interface FastEthernet0/3
 switchport access vlan 20
 switchport trunk native vlan 99
 switchport mode access
!
interface FastEthernet0/4
 switchport access vlan 20
 switchport trunk native vlan 99
 switchport mode access
!
interface FastEthernet0/5
 switchport access vlan 20
 switchport trunk native vlan 99
 switchport mode access
!
interface FastEthernet0/6
 switchport access vlan 20
 switchport trunk native vlan 99
 switchport mode access
!
interface FastEthernet0/7
 switchport access vlan 20
 switchport trunk native vlan 99
 switchport mode access
!
interface FastEthernet0/8
 switchport access vlan 20
 switchport trunk native vlan 99
 switchport mode access
!
interface FastEthernet0/9
 switchport access vlan 20
 switchport trunk native vlan 99
 switchport mode access
!
interface FastEthernet0/10
 switchport access vlan 20
 switchport trunk native vlan 99
 switchport mode access
!
interface FastEthernet0/11
 switchport access vlan 20
 switchport trunk native vlan 99
 switchport mode access
!
interface FastEthernet0/12
 switchport access vlan 20
 switchport trunk native vlan 99
 switchport mode access
!
interface FastEthernet0/13
 switchport access vlan 20
 switchport trunk native vlan 99
 switchport mode access
!
interface FastEthernet0/14
 switchport access vlan 20
 switchport trunk native vlan 99
 switchport mode access
!
interface FastEthernet0/15
 switchport access vlan 20
 switchport trunk native vlan 99
 switchport mode access
!
interface FastEthernet0/16
 switchport access vlan 20
 switchport trunk native vlan 99
 switchport mode access
!
interface FastEthernet0/17
 switchport access vlan 20
 switchport trunk native vlan 99
 switchport mode access
!
interface FastEthernet0/18
 switchport access vlan 20
 switchport trunk native vlan 99
 switchport mode access
!
interface FastEthernet0/19
 switchport access vlan 20
 switchport trunk native vlan 99
 switchport mode access
!
interface FastEthernet0/20
 switchport access vlan 20
 switchport trunk native vlan 99
 switchport mode access
!
interface FastEthernet0/21
 switchport access vlan 20
 switchport trunk native vlan 99
 switchport mode access
!
interface FastEthernet0/22
 switchport access vlan 20
 switchport trunk native vlan 99
 switchport mode access
!
interface FastEthernet0/23
 switchport access vlan 20
 switchport trunk native vlan 99
 switchport mode access
!
interface FastEthernet0/24
 switchport access vlan 20
 switchport trunk native vlan 99
 switchport mode access
!
interface GigabitEthernet0/1
 description MCE_IDF1_Switch1_STUDENT to MCE_MDF_CoreSw1
 switchport trunk native vlan 99
 switchport mode trunk
!
interface GigabitEthernet0/2
 description MCE_IDF1_Switch1_STUDENT to MCE_MDF_CoreSw2
 switchport trunk native vlan 99
 switchport mode trunk
!
interface Vlan1
 no ip address
 shutdown
!
!
!
!
line con 0
!
line vty 0 4
 login
line vty 5 15
 login
!
!
!
end

CDP from Router:

Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone
Device ID    Local Intrfce   Holdtme    Capability   Platform    Port ID

CDP from Core Switch 1:

Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone
Device ID    Local Intrfce   Holdtme    Capability   Platform    Port ID

CDP from Core Switch 2:

Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone
Device ID    Local Intrfce   Holdtme    Capability   Platform    Port ID
Switch       Gig 0/2          141            S       2960        Gig 0/2

CDP from IDF Switch 1 (STUDENTS):

Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone
Device ID    Local Intrfce   Holdtme    Capability   Platform    Port ID
Switch       Gig 0/2          177            S       2960        Fas 0/1

Spanning Tree from VLAN 10 on MDF Core Switch 1:

VLAN0010
  Spanning tree enabled protocol ieee
  Root ID    Priority    24586
             Address     0002.17D4.61B6
             This bridge is the root
             Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    24586  (priority 24576 sys-id-ext 10)
             Address     0002.17D4.61B6
             Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  20

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa0/2            Desg FWD 19        128.2    P2p
Fa0/3            Desg FWD 19        128.3    P2p
Fa0/4            Desg FWD 19        128.4    P2p
Fa0/1            Desg FWD 19        128.1    P2p
Fa0/5            Desg FWD 19        128.5    P2p
Fa0/6            Desg FWD 19        128.6    P2p
Gi0/2            Desg FWD 4         128.26   P2p
Gi0/1            Desg FWD 4         128.25   P2p
19
  • 2
    if you could give a little network diagram that would really help us help you also the config of the switch. – jonathanjo Nov 22 '17 at 15:42
  • 1
    Like a picture of what it's supposed to look like? Cause the instructions I was given were to build the network from scratch. – Joey Nov 22 '17 at 15:45
  • 2
    your problem is likely to be a missing config line or a mistake in interfaces or numbering ... so something which shows those: usually people use ASCII art or photo a pencil sketch. Very hard to diagnose without the config and at least a sense of what it's supposed to be. – jonathanjo Nov 22 '17 at 15:50
  • 3
    You need to edit your question to include a good description of how the networks is connected ( a diagram would be great), and the network device models and configurations. – Ron Maupin Nov 22 '17 at 17:00
  • 1
    Please port the configuration of the router, and one MDF and IDF switch. – Ron Trunk Nov 22 '17 at 19:05
2

1.

I could not use your packet-tracer file because it is not compatible with my 7.0 version.

Most of your configuration looks fine (except no spanning-tree vlan 10,60 on MDF_Core_2, and switchport trunk native vlan 99 on each access port for end devices. You should remove them) and I could apply them into the following case and all PCs could get IP addresses from Router.

enter image description here

Configuration:

On Router:

!
ip dhcp excluded-address 192.168.8.1 192.168.8.10
ip dhcp excluded-address 192.168.10.113 192.168.10.116
ip dhcp excluded-address 192.168.10.65 192.168.10.74
!
ip dhcp pool Students-ELEMENTARY-POOL
 network 192.168.8.0 255.255.255.0
 default-router 192.168.8.1
ip dhcp pool Staff-ELEMENTARY-POOL
 network 192.168.10.112 255.255.255.248
 default-router 192.168.10.113
ip dhcp pool IP-Camera-ELEMENTARY-Pool
 network 192.168.10.64 255.255.255.240
 default-router 192.168.10.65
!
interface GigabitEthernet0/0
 description MDF_Core_1 (g0/1)
 no ip address
 duplex auto
 speed auto
!
interface GigabitEthernet0/0.10
 encapsulation dot1Q 10
 ip address 192.168.10.81 255.255.255.240
!
interface GigabitEthernet0/0.20
 encapsulation dot1Q 20
 ip address 192.168.8.1 255.255.255.0
!
interface GigabitEthernet0/0.30
 encapsulation dot1Q 30
 ip address 192.168.10.113 255.255.255.248
!
interface GigabitEthernet0/0.40
 encapsulation dot1Q 40
 ip address 192.168.10.1 255.255.255.192
!
interface GigabitEthernet0/0.50
 encapsulation dot1Q 50
 ip address 192.168.10.97 255.255.255.240
!
interface GigabitEthernet0/0.60
 encapsulation dot1Q 60
 ip address 192.168.9.1 255.255.255.128
!
interface GigabitEthernet0/0.70
 encapsulation dot1Q 70
 ip address 192.168.9.129 255.255.255.128
!
interface GigabitEthernet0/0.80
 encapsulation dot1Q 80
 ip address 192.168.10.121 255.255.255.252
!
interface GigabitEthernet0/0.88
 encapsulation dot1Q 88
 ip address 192.168.10.65 255.255.255.240
!
interface GigabitEthernet0/0.99
 encapsulation dot1Q 99 native
 ip address 192.168.10.125 255.255.255.252
!

On MDF_Core_1

!
hostname MDF_Core_1
!
spanning-tree mode pvst
spanning-tree vlan 10,20,30,40,50,60 priority 24576
spanning-tree vlan 70,80,88,99 priority 28672
!
interface FastEthernet0/1
 description IDF_Switch_1 (f0/1)
 switchport trunk native vlan 99
 switchport mode trunk
!
interface FastEthernet0/2
 description PC_1
 switchport access vlan 20
 switchport mode access
!
interface GigabitEthernet0/1
 description Router (g0/0)
 switchport trunk native vlan 99
 switchport mode trunk
!
interface GigabitEthernet0/2
 description MDF_Core_2 (g0/2)
 switchport trunk native vlan 99
 switchport mode trunk
!

On MDF_Core_2:

!
hostname MDF_Core_2
!
spanning-tree mode pvst
spanning-tree vlan 70,80,88,99 priority 24576
spanning-tree vlan 10,20,30,40,50,60 priority 28672
!
interface FastEthernet0/1
 description IDF_Switch_1 (f0/2)
 switchport trunk native vlan 99
 switchport mode trunk
!
interface FastEthernet0/2
 description PC_3
 switchport access vlan 88
 switchport mode access
!
interface GigabitEthernet0/2
 description MDF_Core_1 (g0/2)
 switchport trunk native vlan 99
 switchport mode trunk
!

On IDF_Switch_1

!
hostname IDF_Switch_1
!
spanning-tree mode pvst
!
interface FastEthernet0/1
 description MDF_Core_1 (f0/1)
 switchport trunk native vlan 99
 switchport mode trunk
 switchport nonegotiate
!
interface FastEthernet0/2
 description MDF_Core_2 (f0/1)
 switchport trunk native vlan 99
 switchport mode trunk
 switchport nonegotiate
!
interface FastEthernet0/3
 description PC_0
 switchport access vlan 20
 switchport mode access
!
interface FastEthernet0/4
 description PC_2
 switchport access vlan 30
 switchport mode access
!
interface FastEthernet0/5
 description PC_4
 switchport access vlan 88
 switchport mode access
!

Show CDP neighbors:

At first, the Router could see the switch MDF_Core_1, but later it does not. I think it is the problem with packet-tracer application. The rest of devices are fine.

On Router:

Router#show cdp ne
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone
Device ID    Local Intrfce   Holdtme    Capability   Platform    Port ID
Router#

On MDF_Core_1:

MDF_Core_1#show cdp neighbors 
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone
Device ID    Local Intrfce   Holdtme    Capability   Platform    Port ID
MDF_Core_2   Gig 0/2          158            S       2960        Gig 0/2
IDF_Switch_1 
             Fas 0/1          138            S       2960        Fas 0/1
Router       Gig 0/1          151            R       C2900       Gig 0/0
Router       Gig 0/1          151            R       C2900       Gig 0/0.10
Router       Gig 0/1          151            R       C2900       Gig 0/0.20
Router       Gig 0/1          151            R       C2900       Gig 0/0.30
Router       Gig 0/1          151            R       C2900       Gig 0/0.40
Router       Gig 0/1          151            R       C2900       Gig 0/0.50
Router       Gig 0/1          151            R       C2900       Gig 0/0.60
Router       Gig 0/1          151            R       C2900       Gig 0/0.70
Router       Gig 0/1          151            R       C2900       Gig 0/0.80
Router       Gig 0/1          151            R       C2900       Gig 0/0.88
Router       Gig 0/1          151            R       C2900       Gig 0/0.99
MDF_Core_1#

On MDF_Core_2:

MDF_Core_2#show cdp ne
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone
Device ID    Local Intrfce   Holdtme    Capability   Platform    Port ID
MDF_Core_1   Gig 0/2          120            S       2960        Gig 0/2
IDF_Switch_1 
             Fas 0/1          167            S       2960        Fas 0/2
MDF_Core_2#

On IDF_Switch_1:

IDF_Switch_1#show cdp ne
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone
Device ID    Local Intrfce   Holdtme    Capability   Platform    Port ID
MDF_Core_2   Fas 0/2          154            S       2960        Fas 0/1
MDF_Core_1   Fas 0/1          148            S       2960        Fas 0/1
IDF_Switch_1#

All five PCs have received IP addresses from Router:

Router#show ip dhcp binding 
IP address       Client-ID/              Lease expiration        Type
                 Hardware address
192.168.8.12     00D0.D349.4C59           --                     Automatic
192.168.8.13     0001.9659.EA40           --                     Automatic
192.168.10.117   0060.70DD.5B08           --                     Automatic
192.168.10.75    0001.6445.404A           --                     Automatic
192.168.10.76    0001.C945.7A23           --                     Automatic
Router#

2.

I would suggest you build another lab with same topology in packet-tracer and ensure:

  • Connections (Switch-to-Switch and MDF_Core_1-to-Router) are correct (use show cdp neighbors).
  • All Vlans are configured properly on all switches (use show vlans)
  • Remove switchport trunk native vlan 99 under access ports and no spanning-tree vlan 10,60 on MDF_Core_2
  • Connect PCs at different layers of network (MDF and IDF switches) in different VLANs to see if you can the IP addresses there. This will help you to narrow down the issue.
  • Last but not least, on your trunk ports, use switchport trunk allowed vlan 10,20,30,40,50,60,70,80,88,99 to trunk only vlans your have in the network.

I hope it is helpful and you can find where the issue is.

0

Are you sure that all is ok with layer-1 ? I would start from there, in case if cdp is not disabled between the router and first core switch, then you have a l1 problem.

Check the port counters, try other cable - even if this shows that it's up. What is the length of the cable between router and switch? check arp if router learns anything from his core switch facing port, at the same time check the mac address table on switch side for router facing port. if it's empty you definitely have an L1 problem.

To get the DHCP server in this config you will need to ensure that you have a full valid L2 path from end device to router.

Otherwise you can use ip helper.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.