2

My network looks like this: enter image description here

For some reason there's no connectivity if I ping the machine named Server_TFTP from any of the Hosts. The router does however respond to pinging it. Apparently there's no data forwarding between different subnets since machines do not respond if they are in different ones, but they do if they are in the same.
The strange thing is, it behaves like this by default and at one point there were absolutely no problems with routing - that's why I'm confused. Does anyone have any idea, what's going on here and how can I fix the problem related to connectivity?

EDIT:

version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.2.1 192.168.2.10
ip dhcp excluded-address 192.168.3.1 192.168.3.10
!
ip dhcp pool lan_1
   network 192.168.3.0 255.255.255.0
   dns-server 8.8.8.8
   default-router 192.168.3.1
!
ip dhcp pool lan_2
   network 192.168.2.0 255.255.255.0
   dns-server 8.8.8.8
   default-router 192.168.2.1
!
no ip domain lookup
!
multilink bundle-name authenticated
!
archive
 log config
  hidekeys
!
ip tcp synwait-time 5
!
interface FastEthernet0/0
 ip address dhcp
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 192.168.1.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 192.168.2.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet2/0
 ip address 192.168.3.1 255.255.255.0
 duplex auto
 speed auto
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
no cdp log mismatch duplex
!
control-plane
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
6
  • 1
    You need to edit your question to include the router configuration. We cannot simply speculate or guess where the problem lies.
    – Ron Maupin
    Dec 6 '17 at 16:43
  • I have already added it. Dec 6 '17 at 16:51
  • Simply paste the configuration into your question, then use the Preformatted Test button ({}) on it.
    – Ron Maupin
    Dec 6 '17 at 16:55
  • I will assume you have no configurations on the switches, like VLANs, that would interfere. Are you trying to use the server name, or are you using the server IP address? You don't have DNS properly configured to use the name; your DNS is pointing to Google, and it is not going to have your server in its DNS. If you are using the name, the PCs will need some way to resolve the name to the IP address.
    – Ron Maupin
    Dec 6 '17 at 16:59
  • I'm trying to ping using IP addresses. Eg. ping 192.168.2.11 from 192.168.1.88. Currently there's no need for DNS; it doesn't seem to be related to the problem. The switches are just default "dumb" GNS3 switches. Dec 6 '17 at 17:03
2

Your configuration on Router looks fine. It is likely the IP address configuration issue at Server_TFTP end.

You need to verify the following things:

  1. IP address setting on Server_TFTP:

    • IP address: 192.168.1.88
    • Subnet mask: 255.255.255.0
    • Default Gateway: 192.168.1.1 (this is IP address of interface F0/! on Router)
  2. Server_TFTP is correctly connecting to interface F0/1 on Router, then ping 192.168.1.1 (Router F0/1). If failed, repeat steps 1 and 2.

  3. F1/0 and F2/0 on Router are NOT shutdown and Server_TFTP can ping Router's F1/0 and F2/0 IPs: 192.168.2.1 and 192.168.3.1. If failed, check the Default Gateway IP on this server at step 1.

  4. Hosts in LAN_1 and LAN_2 can receive IP addresses from Router and they can ping each other. Then test pinging to/from Server_TFTP.

I hope it is helpful and you can solve it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.