1

I have two routers, R2 AND R3, I've configured the RIP with no auto-summary, the serial interfaces are registered too but the routers can't see them, in this case, R2 se0/0/1 and R3se0/0/1. How can I fix it please.

R2#
Building configuration...

Current configuration : 792 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R2
!
!
ip cef
no ipv6 cef
!
!
spanning-tree mode pvst
!
!
interface FastEthernet0/0
 ip address 192.168.18.129 255.255.255.128
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial0/0/0
 ip address 172.17.0.2 255.255.255.252
!
interface Serial0/0/1
 ip address 10.1.1.9 255.255.255.252
!
interface Vlan1
 no ip address
 shutdown
!
router rip
 network 10.0.0.0
 network 172.17.0.0
 network 192.168.18.0
 no auto-summary
!
ip classless
!
ip flow-export version 9
!
!
!
no cdp run
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end

________

Gateway of last resort is not set

     172.17.0.0/30 is subnetted, 1 subnets
C       172.17.0.0 is directly connected, Serial0/0/0
     192.168.18.0/25 is subnetted, 1 subnets
C       192.168.18.128 is directly connected, FastEthernet0/0
R2#

_________________________________________

R3#s
Building configuration...

Current configuration : 829 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R3
!
!
ip cef
no ipv6 cef
!
!
spanning-tree mode pvst
!
!
interface FastEthernet0/0
 ip address 172.19.3.1 255.255.255.224
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial0/0/0
 ip address 172.17.0.13 255.255.255.252
!
interface Serial0/0/1
 ip address 10.1.1.10 255.255.255.252
 clock rate 2000000
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
router rip
 version 2
 network 10.0.0.0
 network 172.17.0.0
 network 172.19.0.0
 no auto-summary
!
ip classless
!
ip flow-export version 9
!
!
!
no cdp run
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end

______________
Gateway of last resort is not set

     172.17.0.0/30 is subnetted, 1 subnets
C       172.17.0.12 is directly connected, Serial0/0/0
     172.19.0.0/27 is subnetted, 1 subnets
C       172.19.3.0 is directly connected, FastEthernet0/0
R3#
2
  • Are those interfaces up/up? A router will not advertise a network on an interface that is down.
    – Ron Maupin
    Dec 6 '17 at 21:38
  • it is down, both sides red. How can I fix that please?
    – Allen
    Dec 6 '17 at 21:39
2

It looks like you have interface Serial0/0/1 configured as shutdown in R3. That means the link between the two routers is down. A route for an interface that is down is withdrawn from the routing table, and the router will not advertise a route that is not in its routing table, so the router will not advertise the route.

You must bring up the link, then the routers will advertise the network.

1

R2 is runing RIPv1. R3 is running RIPv2. They both have to speak the same protocol. And that has to be v2 as v1 isn't classless.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.