1

I am confused about why PC-A cannot ping PC-B. When pinging PC-B from PC-A, it is always time out, according to tracert, the packet stops at R3 g0/1.
But I think according to the route table, PC-A should be able to ping PC-B, because R1 knows how to get 192.168.3.0/24, R3 knows how to get 192.168.1.0/24 and R2 knows how to get both of them. Please tell me what is wrong here... Thank you in advance!

Route table of R1

Gateway of last resort is 0.0.0.0 to network 0.0.0.0

     172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C       172.16.1.0/30 is directly connected, Tunnel0
L       172.16.1.1/32 is directly connected, Tunnel0
     192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.1.0/24 is directly connected, GigabitEthernet0/1
L       192.168.1.1/32 is directly connected, GigabitEthernet0/1
B    192.168.3.0/24 [20/0] via 209.165.200.226, 00:00:00
     209.165.200.0/24 is variably subnetted, 3 subnets, 2 masks
C       209.165.200.224/30 is directly connected, Serial0/0/0
L       209.165.200.225/32 is directly connected, Serial0/0/0
C       209.165.200.226/32 is directly connected, Serial0/0/0
     209.165.201.0/24 is variably subnetted, 2 subnets, 2 masks
C       209.165.201.0/30 is directly connected, Loopback1
L       209.165.201.1/32 is directly connected, Loopback1
S*   0.0.0.0/0 is directly connected, Serial0/0/0

Route table of R2

Gateway of last resort is not set

B    192.168.1.0/24 [20/0] via 209.165.200.225, 00:00:00
B    192.168.3.0/24 [20/0] via 209.165.200.229, 00:00:00
     209.165.200.0/24 is variably subnetted, 6 subnets, 2 masks
C       209.165.200.224/30 is directly connected, Serial0/0/0
C       209.165.200.225/32 is directly connected, Serial0/0/0
L       209.165.200.226/32 is directly connected, Serial0/0/0
C       209.165.200.228/30 is directly connected, Serial0/0/1
C       209.165.200.229/32 is directly connected, Serial0/0/1
L       209.165.200.230/32 is directly connected, Serial0/0/1
     209.165.201.0/30 is subnetted, 1 subnets
B       209.165.201.0/30 [20/0] via 209.165.200.225, 00:00:00

Route table of R3

Gateway of last resort is 0.0.0.0 to network 0.0.0.0

     172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C       172.16.1.0/30 is directly connected, Tunnel0
L       172.16.1.2/32 is directly connected, Tunnel0
B    192.168.1.0/24 [20/0] via 209.165.200.230, 00:00:00
     192.168.3.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.3.0/24 is directly connected, GigabitEthernet0/1
L       192.168.3.1/32 is directly connected, GigabitEthernet0/1
     209.165.200.0/24 is variably subnetted, 3 subnets, 2 masks
C       209.165.200.228/30 is directly connected, Serial0/0/1
L       209.165.200.229/32 is directly connected, Serial0/0/1
C       209.165.200.230/32 is directly connected, Serial0/0/1
     209.165.201.0/30 is subnetted, 1 subnets
B       209.165.201.0/30 [20/0] via 209.165.200.230, 00:00:00
S*   0.0.0.0/0 is directly connected, Serial0/0/1

Configuration of R1

R1#show run
!
hostname R1
!
!
enable secret 5 $1$mERr$9cTjUIEqNGurQiFU.ZeCi1
!
no ip cef
no ipv6 cef
!
username R2 password 0 cisco
username user privilege 15 secret 5 $1$mERr$hx5rVt7rPNoS4wqbXKX7m0
!
!
license udi pid CISCO1941/K9 sn FTX1524DG51
!
!
no ip domain-lookup
ip domain-name West.com
!
spanning-tree mode pvst
!
interface Loopback1
 ip address 209.165.201.1 255.255.255.252
!
interface Tunnel0
 ip address 172.16.1.1 255.255.255.252
 mtu 1476
 tunnel source Serial0/0/0
 tunnel destination 209.165.200.229
!
!
interface GigabitEthernet0/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface GigabitEthernet0/1
 ip address 192.168.1.1 255.255.255.0
 ip nat inside
 duplex auto
 speed auto
!
interface Serial0/0/0
 ip address 209.165.200.225 255.255.255.252
 encapsulation ppp
 ppp authentication chap
 ip nat outside
 clock rate 128000
!
interface Serial0/0/1
 no ip address
 clock rate 2000000
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
router bgp 65010
 bgp log-neighbor-changes
 no synchronization
 neighbor 209.165.200.226 remote-as 65001
 network 192.168.1.0
 network 209.165.201.0 mask 255.255.255.252
!
ip nat inside source list 1 interface Serial0/0/0 overload
ip classless
ip route 0.0.0.0 0.0.0.0 Serial0/0/0 
!
ip flow-export version 9
!
!
access-list 1 permit 192.168.1.0 0.0.0.255
!
line con 0
 password cisco
 login
!
line aux 0
!
line vty 0 4
 password cisco
 login local
 transport input ssh
!
!
!
end

Configuration of R2

R2#show run
!
hostname R2
!
enable secret 5 $1$mERr$9cTjUIEqNGurQiFU.ZeCi1
!
no ip cef
no ipv6 cef
!
username R1 password 0 cisco
username user privilege 15 secret 5 $1$mERr$hx5rVt7rPNoS4wqbXKX7m0
!
!
license udi pid CISCO1941/K9 sn FTX1524FYUJ
!
no ip domain-lookup
!
!
spanning-tree mode pvst
!
interface GigabitEthernet0/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface GigabitEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial0/0/0
 ip address 209.165.200.226 255.255.255.252
 encapsulation ppp
 ppp authentication chap
!
interface Serial0/0/1
 ip address 209.165.200.230 255.255.255.252
 encapsulation ppp
 clock rate 128000
!
interface Vlan1
 no ip address
 shutdown
!
router bgp 65001
 bgp log-neighbor-changes
 no synchronization
 neighbor 209.165.200.225 remote-as 65010
 neighbor 209.165.200.229 remote-as 65030
!
ip classless
!
ip flow-export version 9
!
line con 0
 password cisco
 login
!
line aux 0
!
line vty 0 4
 password cisco
 login local
!
end

Configuration of R3

R3#show run
hostname R3
!
enable secret 5 $1$mERr$9cTjUIEqNGurQiFU.ZeCi1
!
no ip cef
no ipv6 cef
!
username user privilege 15 secret 5 $1$mERr$hx5rVt7rPNoS4wqbXKX7m0
!
!
license udi pid CISCO1941/K9 sn FTX1524D6LB
!
no ip domain-lookup
ip domain-name East.com
!
!
spanning-tree mode pvst
!
interface Tunnel0
 ip address 172.16.1.2 255.255.255.252
 mtu 1476
 tunnel source Serial0/0/1
 tunnel destination 209.165.200.225
!
!
interface GigabitEthernet0/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface GigabitEthernet0/1
 ip address 192.168.3.1 255.255.255.0
 ip nat inside
 duplex auto
 speed auto
!
interface Serial0/0/0
 no ip address
 clock rate 2000000
 shutdown
!
interface Serial0/0/1
 ip address 209.165.200.229 255.255.255.252
 encapsulation ppp
 ip nat outside
!
interface Vlan1
 no ip address
 shutdown
!
router bgp 65030
 bgp log-neighbor-changes
 no synchronization
 neighbor 209.165.200.230 remote-as 65001
 network 192.168.3.0
!
ip nat inside source list 3 interface Serial0/0/1 overload
ip classless
ip route 0.0.0.0 0.0.0.0 Serial0/0/1 
!
ip flow-export version 9
!
access-list 3 permit 192.168.3.0 0.0.0.255
!
line con 0
 password cisco
 login
!
line aux 0
!
line vty 0 4
 password cisco
 login local
 transport input ssh
!
end
  • You need to edit your question to include the router configurations. – Ron Maupin Dec 9 '17 at 21:21
  • Hello Ron, thanks for your reply, the configurations have been added. – Jiahao Cai Dec 9 '17 at 21:27
2

You don't seem to be advertising the tunnel endpoints via BGP. For example, R1 interface Tunnel0 has tunnel destination 209.165.200.229, but R1 has no route to 209.165.200.228/30. Also, R3 interface Tunnel0 has tunnel destination 209.165.200.225, but R3 has no route to 209.165.200.224/30.

You need to add the network statements to advertise those networks.

You also want to use BGP no auto-summary.

It looks like your current problem is that you have configured NAT on R1 and R3. The tunnel is supposed to bypass NAT, but you are not routing anything through the tunnel.

  • Hello Ron, thanks for your reply. The tunnel works ok I think, PC-A can ping 172.16.1.2, and after I added ip route 209.165.200.228 255.255.255.252 s0/0/0 on R1, it is still not working. I have checked my book, it uses the OSPF over the tunnel, and something like 172.16.2.0/24 [110/1001] via 172.16.12.2, 00:00:07, Tunnel0 should show up, but I do not understand why... – Jiahao Cai Dec 9 '17 at 22:05
  • When I shut down the tunnels, the result is the same, PC-A still cannot ping PC-B. – Jiahao Cai Dec 9 '17 at 22:08
  • You are not running OSPF. – Ron Maupin Dec 9 '17 at 22:09
  • I have solved it by adding static route, ip route 192.168.3.0 255.255.255.0 172.16.1.2 to R1 and ip route 192.168.1.0 255.255.255.0 172.16.1.1 to R2. PC-A and PC-B cannot ping each other because of NAT, and if we can make them go through the tunnel then problem solved because the tunnel is supposed to bypass NAT. Well, now I start to wonder why the tunnel will bypass NAT... – Jiahao Cai Dec 9 '17 at 22:58
  • The tunnel is an interface, but you do not NAT on the tunnel interface. You will probably find that using static routing is cheating for your exercise, and you need to run OSPF on the tunnel. – Ron Maupin Dec 9 '17 at 23:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.