4

In a Cisco ISR 4451 we install a EtherSwitch 48 Port Module. The ISR is working and the EtherSwitch Module too. Now I want to create a route from ISR to EtherSwitch and read some Manuals and Forum threads how to do that.

The easy way is to plug a cable from ISR to EtherSwitch and the other Way is to create a BDI Interface on the ISR and Connect via VLAN to the Ethernet-Internal Port. But I cant create the config as shown in the forum Threads.

On Cisco ISR I should create this config:

interface Ethernet-Internal 1/0/0
  service instance 1 ethernet
    encapsulation dot1q 50
    rewrite ingress tag pop 1
  !
end

interface BDI 1
  ip address 10.0.0.1 255.255.255.0
end

Here is the config of my ISR 4451

Building configuration...

Current configuration : 146 bytes
!
interface Ethernet-Internal1/0/0
 no negotiation auto
 service instance 1 ethernet
  encapsulation dot1q 50
  rewrite ingress tag pop 1
 !
end

interface BDI1
 ip address 10.1.20.4 255.255.255.0
end

And this config is for the Catalyst Module:

Building configuration...

Current configuration : 154 bytes
!
interface GigabitEthernet0/52
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 50
 switchport mode trunk
 switchport protected
end
interface Vlan50
 ip address 10.1.20.3 255.255.255.0
end

But the BDI Interface is still down. What is wrong in my configuration? Any Ideas how to do that?

3
  • 1
    In your first link almost at the bottom on support forums a user gives a configuration that uses SVI's instead and that seems to be working perfectly. Have you tried that? In accordance to the config you've borrowed from the forums, all users also give new configs. For instance a user is writing the BDI interface you also be mapped to the service instance. I suggest though you check what oleg.bogdanov has posted on ‎01-11-2016 11:38 AM - it's exactly the switch you have.
    – user36472
    Jan 5, 2018 at 7:07
  • 1
    I change the config as mentioned by Oleg.bogdanov now it works, there is no need for BDI interface. That was a wrong turn in my config.
    – kockiren
    Jan 5, 2018 at 8:45
  • Make sure your console settibgs are correct. And an enable secret password is required to access the switch module. Aug 23, 2018 at 0:50

1 Answer 1

5

As per OP's comment, here's a copy of the post from oleg.bogdanov on Cisco support forums, which turned out to be a better solution.

This is strictly copy/paste from Cisco support forums and has not been made by me. It's only to give someone else a hint to a solution.

oleg.bogdanov wrote:

Note that my platform is a 4451 with a SM-X-ES3-24-P, but it should be the same in your case. The 4000 series supports SVIs as of recent code. You enable SVI support like this:

ethernet-internal subslot 1/0
platform switchport svi

Then you have to reboot and you can just trunk your VLANs to the switch module like you would on any layer 3 switch:

Vlan 11
name some_vlan

Vlan 13
name other_vlan

interface Vlan11
description some vlan
ip address 10.10.10.2 255.255.255.0
standby 1 ip 10.10.10.1
standby 1 priority 105
standby 1 preempt
no shut

interface Vlan13
description some other vlan
ip address 10.20.20.2 255.255.255.0
standby 1 ip 10.20.20.1
standby 1 priority 105
standby 1 preempt
no shut

interface Ethernet-Internal1/0/0
description Trunk to internal switch module
switchport mode trunk
switchport trunk allowed vlan 11, 13

Note that once you log into your switch module (the command has been changed to 'hw-module session 1/0') don't try to restrict the VLANs on the uplink port. Just allow them all else you get more stupid errors.

interface GigabitEthernet0/26
description Trunk to host router
switchport trunk encapsulation dot1q
switchport mode trunk
switchport protected

Vlan 11
name some_vlan

Vlan 13
name other_vlan

E.g.

Switch#sh int trunk

Port Mode Encapsulation Status Native vlan
Gi0/1 on 802.1q trunking 1
Gi0/26 on 802.1q trunking 1

Port Vlans allowed on trunk
Gi0/1 11,13
Gi0/26 1-4094

Port Vlans allowed and active in management domain
Gi0/1 11,13
Gi0/26 1,11,13

Port Vlans in spanning tree forwarding state and not pruned
Gi0/1 11,13
Gi0/26 1,11,13
Switch#

Hopefully this helps people save some time. Cisco has very poor documentation on proper configuration of these switch modules so I'm not surprised TAC gave the nonsense answer of "use an external cable".

Source:

https://supportforums.cisco.com/t5/lan-switching-and-routing/configuring-a-sm-x-layer-2-3-etherswitch-service-module-on-a/td-p/2660930

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.