0

Got like 2 dozen devices on a given network.

Recently I've changed a module on 2 devices, and this resulted swapping their IP addresses, which wouldn't matter in my case.

  • device A has IP b of device B
  • device B has IP a of device A

As a result only 1 of them is accessible. There are no problems with the IP addresses, those are different, and devices can be accessed separately.

Once one of them gets accessible, the other gets unaccessible, and again and again. This changes like in 20-60 seconds.

Can it be that the MAC addresses are stored somewhere, and the router is somehow unable to determine which device has which IP assuming the 2 are the same and this gets only resolved when they answser to the packets.

Tried ping and ssh. Results are the same.

closed as off-topic by Ron Maupin Jan 5 '18 at 14:58

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "NE is a site for to ask and provide answers about professionally managed networks in a business environment. Your question falls outside the areas our community decided are on topic. Please visit the help center for more details. If you disagree with this closure, please ask on Network Engineering Meta." – Ron Maupin
If this question can be reworded to fit the rules in the help center, please edit the question.

  • First off, what type of equipment are you using and how is it connected? Secondly what configurations are you using? You could copy/paste your configuration to your question and sanitize any usernames, passwords and public IP addresses. – user36472 Jan 5 '18 at 12:10
  • I can't tell you more than these are devices running debian linux, are powered by POE, so got connection through wires. These are connected to a switch that is connected to a router. IP-s are set static, but DHCP is activated on the router. I don't have rights to config the router, it's provided by the administration of the client, the only thing i can see after a scan is that it's cisco. – ntj Jan 5 '18 at 12:21
  • Unfortunately, questions about networks you don't control are off-topic here. – user36472 Jan 5 '18 at 12:24
  • it may be difficult to answer if you cannot access the router or the switch management (this is one of the reason why network not under your control are off-topic here); but what I would try is running a tcpdump on each device to see what's going on. – JFL Jan 5 '18 at 12:28
  • Alright, I hope i find something strange in the dump, thanks. I would recommend to keep this post alive till I anwser it, even if it's off-topic, and assume I control network if problem is solved. – ntj Jan 5 '18 at 12:31
2

The 2 devices had the same MAC address.

Solution:

An option is to change address with macchanger.

macchanger -a eth0

and running

/etc/init.d/networking restart

solved the issue.

Not the answer you're looking for? Browse other questions tagged or ask your own question.