3

enter image description hereI have a Cisco 3650 with inter-vlan routing enabled. All vlans reach each other with no problems. The problem appeared when I connected an unmanaged switch to an interface on the cisco. I set up a vlan with the same ip range of the unmanaged switch, I also set up an interface vlan in the same ip range of the unmanaged switch. Now, when i'm on the exec mode on the cisco switch, i can reach all devices on the unmanaged switch, however, from any other valn, I cannot.

no aaa new-model
system mtu routing 1500
vtp domain h873.eur.nsroot.net
vtp mode transparent
ip subnet-zero
ip routing
vlan 116
 name PROD_VLAN_111
!
vlan 120,200
!
vlan 211
 name MGMT_PHY_211
!
vlan 212
 name MGMT_APP_212
!
!
!
!
interface GigabitEthernet0/1
 switchport access vlan 211
 switchport mode access
!
interface GigabitEthernet0/2  
 switchport access vlan 212
 switchport mode access
!
interface GigabitEthernet0/3
 switchport access vlan 116
 switchport mode access
!

interface GigabitEthernet0/11
 description Connection to Unmanaged Switch
 switchport access vlan 200
 switchport mode access
!

interface GigabitEthernet0/14
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet0/15
!
interface GigabitEthernet0/16
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet0/17
!
interface GigabitEthernet0/18
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet0/19
!
interface GigabitEthernet0/20
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet0/21
!
interface GigabitEthernet0/22
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet0/23
!
interface GigabitEthernet0/24
 switchport trunk encapsulation dot1q
 switchport mode trunk

interface Vlan1
 no ip address
!
interface Vlan116
 ip address 172.16.116.1 255.255.255.0
!
interface Vlan120
 ip address 10.11.120.1 255.255.255.0
!
interface Vlan200
ip address 192.168.1.100 255.255.255.0
!
interface Vlan211
 ip address 10.11.211.1 255.255.255.0
 !
  interface Vlan212
  ip address 10.11.212.1 255.255.255.0
 !
 router ospf 100
  log-adjacency-changes
  redistribute connected subnets
  network 172.16.116.0 0.0.0.255 area 0
 !
  ip default-gateway 192.168.1.165
  ip classless
 ip route 0.0.0.0 0.0.0.0 192.168.1.1
 ip http server
 ip http secure-server
 !

So for example, if i run "ping 192.168.1.100 source 10.11.211.1" the pings are fine, but if i run "ping 192.168.1.1 source 10.11.211.1" it is not successful. Any help would be much appreciated.

Switch#ping 192.168.1.1
 Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
 !!!!!
 Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/8 ms 

Switch#ping 192.168.1.1 source 10.11.211.1 Type escape sequence to abort.
 Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
 Packet sent with a source address of 10.11.211.1
 .....
 Success rate is 0 percent (0/5) 

Switch#ping 192.168.1.100 source 10.11.211.1
 Packet sent with a source address of 10.11.211.1
 !!!!!
 Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/9 ms
15
  • 3
    You need to edit your question to include the switch configuration.
    – Ron Maupin
    Jan 18, 2018 at 17:52
  • To which interface is the unmanaged switch connected?
    – Ron Maupin
    Jan 18, 2018 at 18:11
  • interface gig 0/11
    – absalah
    Jan 18, 2018 at 18:12
  • The description command is your friend. You should use it.
    – Ron Maupin
    Jan 18, 2018 at 18:19
  • 1
    You just wrote that the gateway for the hosts is 192.168.1.1. That will not work for any host not on that network. A gateway is the host on a network that knows how to reach other networks. In this case, it is the switch, and hosts on the 192.168.1.0/24 network should have their gateway set to 192.168.1.100, the switch SVI.
    – Ron Maupin
    Jan 18, 2018 at 18:32

3 Answers 3

2

If the hosts on the unmanaged switch have a gateway set to 192.168.1.1, then traffic from those hosts to a different network will be sent to that router, and if that router needs to send back to the switch on that network, it will not. Routers have split-horizon, meaning that they will not route back to the same network on which a packet is received.

You want the inter-VLAN routing to happen on the switch, not the WAN router, so the switch must be the gateway for all the hosts. The WAN router should inject the default route into OSPF, and you should not have a default route on the switch.

9
  • Then, I don't understand how the below ping is working from the switch:
    – absalah
    Jan 18, 2018 at 18:44
  • Switch#ping 192.168.1.1 Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds: !!!!! Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/8 ms
    – absalah
    Jan 18, 2018 at 18:44
  • 1
    Because the source of your pings is on the same network as your devices, so no routing is required.
    – Ron Trunk
    Jan 18, 2018 at 18:45
  • So basically, I need to change the topology so that the WAN router is connected directly to cisco switch?
    – absalah
    Jan 18, 2018 at 18:48
  • @absalah, you need to understand that frames are sent directly at layer-2, and packets sent to a different network are frames with the configured gateway address. You can ping anything on the same network because the frames are sent directly to the desintation host, but pinging to a different network, the packets are frames and sent directly to the configured gateway, then the gateway will strip the frame and add a frame for the the next network. A router will not route from a network back to the same network.
    – Ron Maupin
    Jan 18, 2018 at 18:50
3

The hosts on the unmanaged switch subnet need their default routes to point at the gateway you've created on the 3650. The hosts already routing through the 3650 can likely reach the new subnet but the new subnet's hosts need to understand to how to send traffic in return. I'd suggest that VLAN200 on the 3650 should potentially just assume the IP of the present default gateway.

0

It's not. Feasible at all to do inter-Vlan routing by deploying unmanaged switch inline . Unmanaged switch is not capable to create and modify and delete Vlans . So it's not feasible.

To accomplish your requirement deploy managed switch and further connect end host to managed switch allowing specific Vlan .

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.