3

I try to create a Vlan that route traffic through multiple Cisco Devices. For that I create a vlan13 on each device and setup a IP on the ISR and the Device attached to the Nexus also have a IP on the same subnet.

enter image description here

The setup is like this:

ISR 4451:

interface Vlan13
 description pfsense subnet
 ip address 10.1.1.49 255.255.255.240
end
interface Ethernet-Internal1/0/0
 description Trunk to internal switch module
 switchport trunk allowed vlan 1,11,13
 switchport mode trunk
end

SM-X

interface Vlan13
 ip address 10.1.1.51 255.255.255.240
end
interface GigabitEthernet0/2
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,13
 switchport mode trunk
end
interface GigabitEthernet0/52
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport protected
end

Nexus 3000

vlan 1,13
interface Ethernet1/16
  switchport access vlan 13
interface Ethernet1/47

I try to add switchport trunk encapsulation dot1q to the nexus config but the command is unavailable. Maybe this is the issue of my config. The Server attached to the Eth1/16 Port is configured with IP 10.1.1.50/28 and the IP 10.1.1.49 or 10.1.1.51 is not accessible from that server.

3
  • 1
    You need switchport mode trunk on Nexus Ethernet1/47. The encapsulation command is not needed as the Nexus always encapsulates. – user36472 Jan 19 '18 at 7:26
  • Thx, now it works. – kockiren Jan 19 '18 at 7:32
  • I'm glad it worked. I've converted my comment to an answer. :-) – user36472 Jan 19 '18 at 7:35
5

Converting comment to answer.

Ethernet1/47 was missing switchport mode trunk. The Nexus 3000 does not need an encapsulation command as it always encapsulates traffic on trunk ports.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.