2

Just for practice purpose i've created an network on Cisco packet tracer like this.

enter image description here

But i am not able to ping router 3 from any other devices.

Below are the configurations on each devices.

Router 3:

!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R3
!
!
ip cef
no ipv6 cef
!
!
spanning-tree mode pvst
!
!
interface FastEthernet0/0
 ip address 192.168.3.3 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 192.168.2.3 255.255.255.0
 duplex auto
 speed auto
!
interface Vlan1
 no ip address
 shutdown
!
router eigrp 1
 network 192.168.2.0
 network 192.168.3.0
 auto-summary
!
ip classless
!
ip flow-export version 9
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
end

Router 1:

!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R1
!
!
ip cef
no ipv6 cef
!
!
spanning-tree mode pvst
!
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet0/0.2
 encapsulation dot1Q 2
 ip address 192.168.1.1 255.255.255.0
!
interface FastEthernet0/0.4
 encapsulation dot1Q 4
 ip address 192.168.3.1 255.255.255.0
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan2
 mac-address 0060.3e65.9e01
 no ip address
!
router eigrp 1
 network 192.168.1.0
 network 192.168.3.0
 auto-summary
!
ip classless
!
ip flow-export version 9
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
end

Router 5:

!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R5
!
!
ip cef
no ipv6 cef
!
!
spanning-tree mode pvst
!
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet0/1.2
 encapsulation dot1Q 2
 ip address 192.168.1.5 255.255.255.0
!
interface FastEthernet0/1.3
 encapsulation dot1Q 3
 ip address 192.168.2.5 255.255.255.0
!
interface Vlan1
 no ip address
 shutdown
!
router eigrp 1
 network 192.168.1.0
 network 192.168.2.0
 auto-summary
!
ip classless
!
ip flow-export version 9
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
end

SW1:

!
version 12.2(37)SE1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname SW1
!
!
ip routing
!
!
spanning-tree mode pvst
!
!
interface FastEthernet0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet0/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet0/3
interface FastEthernet0/4
interface FastEthernet0/5
interface FastEthernet0/6
interface FastEthernet0/7
interface FastEthernet0/8
interface FastEthernet0/9
interface FastEthernet0/10
interface FastEthernet0/11
interface FastEthernet0/12
interface FastEthernet0/13
interface FastEthernet0/14
interface FastEthernet0/15
interface FastEthernet0/16
interface FastEthernet0/17
interface FastEthernet0/18
interface FastEthernet0/19
interface FastEthernet0/20
interface FastEthernet0/21
interface FastEthernet0/22
interface FastEthernet0/23
interface FastEthernet0/24
interface GigabitEthernet0/1
interface GigabitEthernet0/2
!
interface Vlan1
 ip address 192.168.0.254 255.255.255.0
!
interface Vlan2
 mac-address 0060.2f8a.1301
 ip address 192.168.1.254 255.255.255.0
!
router eigrp 1
 network 192.168.0.0
 network 192.168.1.0
 auto-summary
!
ip classless
!
ip flow-export version 9
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
line vty 5 15
 login
!
!
end

Here are additional info.

on router 1:-

R1#sh cdp nei
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone
Device ID    Local Intrfce   Holdtme    Capability   Platform    Port ID
R3           Fas 0/1          153            R       C2800       Fas 0/0

R1#sh ip int br
Interface              IP-Address      OK? Method Status                Protocol 
FastEthernet0/0        unassigned      YES unset  up                    up 
FastEthernet0/0.2      192.168.1.1     YES manual up                    up 
FastEthernet0/0.4      192.168.3.1     YES manual up                    up 
FastEthernet0/1        unassigned      YES manual up                    up 
Vlan1

R1#sh ip rou
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

D    192.168.0.0/24 [90/25628160] via 192.168.1.254, 00:08:21, FastEthernet0/0.2
C    192.168.1.0/24 is directly connected, FastEthernet0/0.2
D    192.168.2.0/24 [90/30720] via 192.168.1.5, 00:07:28, FastEthernet0/0.2
C    192.168.3.0/24 is directly connected, FastEthernet0/0.4

Router 3:-

R3#sh cdp nei
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone
Device ID    Local Intrfce   Holdtme    Capability   Platform    Port ID
R5           Fas 0/1          150            R       C2800       Fas 0/0
R1           Fas 0/0          130            R       C2800       Fas 0/1
R3#

R3#sh ip int br
Interface              IP-Address      OK? Method Status                Protocol 
FastEthernet0/0        192.168.3.3     YES manual up                    up 
FastEthernet0/1        192.168.2.3     YES manual up                    up 
Vlan1                  unassigned      YES unset  administratively down down
R3#

R3#sh ip rout
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

C    192.168.2.0/24 is directly connected, FastEthernet0/1
C    192.168.3.0/24 is directly connected, FastEthernet0/0

router 5:-

R5#sh cdp nei
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone
Device ID    Local Intrfce   Holdtme    Capability   Platform    Port ID
R3           Fas 0/0          152            R       C2800       Fas 0/1
R5#

R5#sh ip int br
Interface              IP-Address      OK? Method Status                Protocol 
FastEthernet0/0        unassigned      YES manual up                    up 
FastEthernet0/1        unassigned      YES unset  up                    up 
FastEthernet0/1.2      192.168.1.5     YES manual up                    up 
FastEthernet0/1.3      192.168.2.5     YES manual up                    up 
Vlan1                  unassigned      YES unset  administratively down down
R5#

R5#sh ip rou
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

D    192.168.0.0/24 [90/25628160] via 192.168.1.254, 00:08:33, FastEthernet0/1.2
C    192.168.1.0/24 is directly connected, FastEthernet0/1.2
C    192.168.2.0/24 is directly connected, FastEthernet0/1.3
D    192.168.3.0/24 [90/30720] via 192.168.1.1, 00:08:34, FastEthernet0/1.2

SW1:

SW1#sh cdp nei
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone
Device ID    Local Intrfce   Holdtme    Capability   Platform    Port ID
R5           Fas 0/2          177            R       C2800       Fas 0/1
R5           Fas 0/2          177            R       C2800       Fas 0/1.2
R5           Fas 0/2          177            R       C2800       Fas 0/1.3
R1           Fas 0/1          157            R       C2800       Fas 0/0
R1           Fas 0/1          157            R       C2800       Fas 0/0.2
R1           Fas 0/1          157            R       C2800       Fas 0/0.4
SW1#

SW1#sh ip int br
Interface              IP-Address      OK? Method Status                Protocol 
FastEthernet0/1        unassigned      YES unset  up                    up 
FastEthernet0/2        unassigned      YES unset  up                    up 
FastEthernet0/3        unassigned      YES unset  down                  down 
FastEthernet0/4        unassigned      YES unset  down                  down 
FastEthernet0/5        unassigned      YES unset  down                  down 
FastEthernet0/6        unassigned      YES unset  down                  down 
FastEthernet0/7        unassigned      YES unset  down                  down 
FastEthernet0/8        unassigned      YES unset  down                  down 
FastEthernet0/9        unassigned      YES unset  down                  down 
FastEthernet0/10       unassigned      YES unset  down                  down 
FastEthernet0/11       unassigned      YES unset  down                  down 
FastEthernet0/12       unassigned      YES unset  down                  down 
FastEthernet0/13       unassigned      YES unset  down                  down 
FastEthernet0/14       unassigned      YES unset  down                  down 
FastEthernet0/15       unassigned      YES unset  down                  down 
FastEthernet0/16       unassigned      YES unset  down                  down 
FastEthernet0/17       unassigned      YES unset  down                  down 
FastEthernet0/18       unassigned      YES unset  down                  down 
FastEthernet0/19       unassigned      YES unset  down                  down 
FastEthernet0/20       unassigned      YES unset  down                  down 
FastEthernet0/21       unassigned      YES unset  down                  down 
FastEthernet0/22       unassigned      YES unset  down                  down 
FastEthernet0/23       unassigned      YES unset  down                  down 
FastEthernet0/24       unassigned      YES unset  up                    up 
GigabitEthernet0/1     unassigned      YES unset  down                  down 
GigabitEthernet0/2     unassigned      YES unset  down                  down 
Vlan1                  192.168.0.254   YES manual up                    up 
Vlan2                  192.168.1.254   YES manual up                    up
SW1#

SW1#sh ip rou
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

C    192.168.0.0/24 is directly connected, Vlan1
C    192.168.1.0/24 is directly connected, Vlan2
D    192.168.2.0/24 [90/25628160] via 192.168.1.5, 00:09:46, Vlan2
D    192.168.3.0/24 [90/25628160] via 192.168.1.1, 00:10:40, Vlan2

Please help.

3
  • It would help if you would mark interfaces and subnets on your graphic. Also to debug this it would be helpful to see operational outputs (show ip route, show interface, ...) too. Feb 2, 2018 at 9:10
  • Hi Sebastian. I have added info. please let me know if you want to know something else. Thanks Feb 2, 2018 at 9:29
  • Did any answer help you? If so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you could provide and accept your own answer.
    – Ron Maupin
    Apr 1, 2018 at 20:11

2 Answers 2

3

The issue is L3 connections between R1/R5 and R3 are not correctly configured.

You did not configure interfaces on R1/R5 connecting to R3 with IP addresses.

#Router 1
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
!


#Router 5
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
!

You only configured F0/0 subinterfaces (on R1) and F0/1 subinterface (on R5) for connections up to L3 SW1, and this is wrong.

#Router 1
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet0/0.2
 encapsulation dot1Q 2
 ip address 192.168.1.1 255.255.255.0
!
interface FastEthernet0/0.4
 encapsulation dot1Q 4
 ip address 192.168.3.1 255.255.255.0
!



#Router 5
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet0/1.2
 encapsulation dot1Q 2
 ip address 192.168.1.5 255.255.255.0
!
interface FastEthernet0/1.3
 encapsulation dot1Q 3
 ip address 192.168.2.5 255.255.255.0
!

In this scenario, you do not need to use dot1q Trunking connections between R1/R5 and L3 SW1.

Fix your configuration again and ensure that you can reach the other end of connection before turn on EIGRP (or any routing protocol).

And you should remove 'auto-summary' under EIGRP configuration.

0

You have to remove auto-summary. Here you are a great explanation.

2
  • Thanks victor, i tried it but still the same. R3 is not learning any routes from EIGRP protocol. Feb 2, 2018 at 9:20
  • @KaranDesai did you also change the addressing as suggested?
    – DRP
    Feb 2, 2018 at 14:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.