2

Having an issue with a voice vlan setup but only on my Cisco stack, Brocade stack works. DHCP is on VLAN5 (for phone and pc) using Option 156 for voice VOIP is on VLAN100

Shoretel Phone1 and PC1 on the Brocade

 dual-mode  12
 no cdp enable
 inline power
 voice-vlan 100
 trust dscp

Shoretel Phone2 and PC2 on C9300

 switchport access vlan 12
 switchport mode access
 switchport voice vlan 100
 auto qos trust cos
 no cdp enable

I believe they are basically the same in configuration:

Trunk Vlan 100 (tagged)
Native vlan 12 (untagged)

I am unable to get DHCP on Phone2, PC2 works.

Any ideas?enter image description here

  • You may need to enable LLDP on the Cisco switch. It uses CDP by default, but LLDP must be specifically enabled. – Ron Maupin Feb 13 '18 at 22:13
  • Did any answer help you? If so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you could provide and accept your own answer. – Ron Maupin Apr 1 '18 at 20:42
1

Cisco switches use CDP (default) or LLDP to negotiate a trunk with a phone acting as a switch on an access interface. Since you are using non-Cisco phones, you must either enable LLDP (if your phone supports that), or you will need to configure the switch interface as a trunk.

To globally enable LLDP:

lldp run

Then, on each interface:

lldp transmit
lldp receive

Or, for a trunk on the interface:

switchport trunk allowed vlan 12,100
switchport trunk native vlan 12
switchport mode trunk
  • Thanks Ron, We are using DHCP option 156 instead of LLDP. I can see the VLAN assignments working correctly (phone2/vlan 12 & 100, PC2/vlan12). This is the same output that I get from the Brocade on phone1 and pc1 – FCCCSAM Feb 13 '18 at 22:37
  • Then you need to configure the Cisco interfaces as trunks. You have three choices: CDP, LLDP, or trunk. We had some phones that did not support CDP or LLDP, and the switch interfaces must be configured as trunks. The switch needs to know that it must have a trunk to send both VLANs. – Ron Maupin Feb 13 '18 at 22:40
  • Tried configuring as trunk and I'm getting the same results as switchport access vlan 12 switchport mode access switchport voice vlan 100 no cdp enable – FCCCSAM Feb 13 '18 at 22:47
  • 1
    This document explains more on how Cisco switches interact with phones. Also, when you use trunking, you will want the enable portfast on the interface so that you don't need to wait for STP. – Ron Maupin Feb 13 '18 at 22:56
0
YOU HAVE:
VLAN5 FOR DHCP
VLAN 100 FOR SHORETEL SERVER AND VOICE
VLAN 12 FOR DATA

HERE IS CONFIGS YOU SHOULD HAVE ON YOUR CISCO SWICH:

this is the configs for port connected to your phone/pc:

interface FastEthernet1/0/1
 switchport access vlan 12
 switchport mode access
 switchport voice vlan 100
 no cdp enable
 spanning-tree portfast
 switchport nonegotiate 

You also have to set up ip helper address to redirect DHCP requests to DHCP server on VLAN5 lets say DHCP server address is 192.168.5.5:

interface VLAN100
ip helper-address 192.168.5.5

 interface VLAN12
ip helper-address 192.168.5.5

The interface connected to brocade needs to be trunk:

interface FastEthernet1/0/24
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 5,100,12
 switchport mode trunk

And you have to have all these vlans configured on cisco

conf t
vlan5
name DHCP

vlan100
name VOICE

vlan12
name DATA

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.