1

When i load nxos.7.0.3.I2.2d.bin Software then FAN running very quiet in following speed

switch# sh environment fan detail
Fan:
---------------------------------------------------------------------------
Fan             Model                Hw     Direction       Status
---------------------------------------------------------------------------
Fan1(sys_fan1)  N9K-C9300-FAN2       --     front-to-back   Ok
Fan2(sys_fan2)  N9K-C9300-FAN2       --     front-to-back   Ok
Fan3(sys_fan3)  N9K-C9300-FAN2       --     front-to-back   Ok
Fan_in_PS1      --                   --     front-to-back   Ok
Fan_in_PS2      --                   --     front-to-back   None
Fan Zone Speed: Zone 1: 0x33
Fan Air Filter : NotSupported
Fan:
------------------------------------------------------------------
 Fan Tray            Fan   Fan Direction   Speed(%)  Speed(RPM)
------------------------------------------------------------------
Fan1(sys_fan1)      fan1    front-to-back    37        6136
Fan1(sys_fan1)      fan2    front-to-back    37        4895
Fan2(sys_fan2)      fan1    front-to-back    35        5825
Fan2(sys_fan2)      fan2    front-to-back    36        4753
Fan3(sys_fan3)      fan1    front-to-back    36        5973
Fan3(sys_fan3)      fan2    front-to-back    37        4838

But when i upgrade it with latest one nxos.7.0.3.I4.7.bin then it is running fast. Why?

switch# sh environment fan detail
Fan:
---------------------------------------------------------------------------
Fan             Model                Hw     Direction       Status
---------------------------------------------------------------------------
Fan1(sys_fan1)  N9K-C9300-FAN2       --     front-to-back   Ok
Fan2(sys_fan2)  N9K-C9300-FAN2       --     front-to-back   Ok
Fan3(sys_fan3)  N9K-C9300-FAN2       --     front-to-back   Ok
Fan_in_PS1      --                   --     front-to-back   Ok
Fan_in_PS2      --                   --     front-to-back   Shutdown
Fan Zone Speed: Zone 1: 0x80
Fan Air Filter : NotSupported
Fan:
------------------------------------------------------------------
 Fan Tray            Fan   Fan Direction   Speed(%)  Speed(RPM)
------------------------------------------------------------------
Fan1(sys_fan1)      fan1    front-to-back    62        10325
Fan1(sys_fan1)      fan2    front-to-back    63        8256
Fan2(sys_fan2)      fan1    front-to-back    59        9872
Fan2(sys_fan2)      fan2    front-to-back    62        8071
Fan3(sys_fan3)      fan1    front-to-back    61        10169
Fan3(sys_fan3)      fan2    front-to-back    62        8071
  • It appears the newer code runs the device at a higher temperature. – Ron Maupin Feb 16 '18 at 22:38
3

Is the second power supplied un-powered? The lack of airflow from the second PS is likely causing the other fans to spin up to compensate. This is likely a change in logic between the old and new versions. If the second PS is powered then try re-seating it to see if the condition improves and, if not, open a TAC case.

Also - there may be EPLD updates, especially when moving from a relatively old version of code. Make sure you're staying current on these, as there have definitely been PSU and fan controller updates in the last few years on the 9K platform.

| improve this answer | |
  • This switch is in lab and I just plug single power for test, I will try dual power. We don't have TAC support for this switch :( I will try to upgrade other firmware and see. Otherwise I will stick to old software. – Satish Feb 17 '18 at 17:28
1

I have asked same question in Cisco community and got answer from one of Cisco employee.

enter image description here

| improve this answer | |
  • That's a good answer, and you should accept it so that the question doesn't keep popping up forever, looking for an answer. – Ron Maupin Feb 19 '18 at 16:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.