1

When configuring OSPFv2 on a router, you type in

router ospf 10 

router-id 1.1.1.1 

network 10.0.0.0 0.0.0.3 area 0

for example. That way the network can be advertised per LSAs.

But in OSPFv3 it seems that there isn't such a command.

Unfortunately I haven't found anything by googling.

  • 2
    Removed the off-topic request for resources. – Ron Maupin Feb 18 '18 at 17:59
5

To run OSPF dual stack, just run OSPFv2 and OSPFv3 simultanously. They won't interfere because they are completely separate.

With OSPFv3, there is NO network command under OSPF process configuration section. The reason why is here: To enable OSPFv3 on interfaces, you have to configure ipv6 ospf command under interface configuration section of each interface. That way OSPFv3 knows what network to advertise.

Below is simple OSPFv3 configuration for your reference:

enter image description here

R1

!
ipv6 unicast-routing
ipv6 cef
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
 ipv6 address ...
 ipv6 enable
 ipv6 ospf 13 area 0
!
interface FastEthernet0/1
 ipv6 address ...
 ipv6 enable
 ipv6 ospf 13 area 2
!
ipv6 router ospf 13
 router-id 1.1.1.1
 log-adjacency-changes
!

R2

!
ipv6 unicast-routing
ipv6 cef
!
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
 ipv6 address ...
 ipv6 enable
 ipv6 ospf 13 area 0
!
ipv6 router ospf 13
 router-id 2.2.2.2
 log-adjacency-changes
!

R3

!
ipv6 unicast-routing
ipv6 cef
!
interface Loopback0
 ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet0/1
 ipv6 address ...
 ipv6 enable
 ipv6 ospf 13 area 2
!
ipv6 router ospf 13
 router-id 3.3.3.3
 log-adjacency-changes
!

You can find more helpful information at OSPF Implementation - OSPFv3 from the "Implementing Cisco IP Routing (ROUTE) Foundation Learning Guide" book.

| improve this answer | |
  • 2
    You should post whatever commands are there, links tend to break and are frowned upon, if there isn't any other information to sustain your answer. – DRP Feb 18 '18 at 14:25
  • 1
    DRP is right, you should post a solution from the link – user36472 Feb 18 '18 at 14:30
  • To put in the configuration with the IPv6-Adresses was just fine, thank you! – watchme Feb 18 '18 at 16:35
  • and do you know why there is no network command needed? Because ospfv3 is configured on an interface? But why isn't it done that way in ospfv2? Because then you won't have to type in those network-commands again. – watchme Feb 18 '18 at 16:39
  • 1
    @watchme Actually, OSPFv2 also supports this method of enabling OSPF on interface with ip ospf process_ID area area_ID command (starting from 12.3(11)T IOS release). And this way should be used at the beginning, instead of network command. However, the network command seems to be much more familiar to us. Personally, I think Cisco has "corrected" itself on OSPFv3 :) – Hung Tran Feb 18 '18 at 17:08
3

With OSPFv3, you assign an interface to an area by applying a command directly to the interface:

int g0/0
 ipv6 ospf 1 area 0

The interface will now run OSPFv3, if the process does not exist, it will be automatically created. If you are in an IPv6 only environment, you need to configure a router ID:

ipv6 router ospf 1
 router-id 2.2.2.2

You can configure stub areas etc under the IPv6 router OSPF process similar to OSPFv2

| improve this answer | |
  • So I can configure "area __ range ___ " and "network ____ area __" also with this method? – watchme Feb 18 '18 at 16:15
  • No, you don't use the network statement for OSPFv3 with this method, when you configure "ipv6 ospf 1 area 0" on the interface, the interface is enabled for OSPFv3, so you do not need the network statement – Karl Billington Feb 18 '18 at 16:23
  • If you are running dual-stack, you still need the network statement under the router ospf 1 for IPv4, but that is a different process for IPv4 – Karl Billington Feb 18 '18 at 16:24
  • So OSPFv3 explores(without any command) which network is attached to this interface by itself? And advertises it with LSAs? Why doesn't OSPFv2 do this? It would be easy, you just have to change the commands to be configured on that interface (so "int s0/1/0" and not in "router ospf 1") and read the configuration on that interface. That way you would never type in "network ___ " - commands again. – watchme Feb 18 '18 at 16:28
  • @watchme It might be easier in hindsight. But v2 was developed many years before v3, using different programming techniques. – Ron Trunk Feb 18 '18 at 16:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.