3

I want to configure HSRPv2 dual stack on my core-switches.

Information:

  • Access1 is in VLAN 64, Acess2 in VLAN 65 and Access 3 in VLAN 66
  • I have configured SVIs for each VLAN (IPv4 and IPv6).
  • in the backbone (The yellow area) I am running OSPF (Dual Stack).

Here's the topology:

enter image description here

Questions:

How can I configure HSRPv2 for both, IPv4 and IPv6? Do I have to use a different standby-number for each address-family? And which connection should be configured between Core 0 and Core1? Normal routing port or a trunk?

And when I configure HSRP for one SVI, how does the other router know that he should take part in this HSRP process? Just by configuring the same standby id one the other router?

3

How can I configure HSRPv2 for both, IPv4 and IPv6?

I don't know your IP address structure, but i'll just use 172.26.0.0/24 as an example and a random IPv6 address (Remember this is just basic configuration):

Core0# configure terminal
Core0(config)# interface Vlan2
Core0(config-if)# standby version 2
Core0(config-if)# ip address 172.26.0.2 255.255.255.0
Core0(config-if)# ipv6 address 2001:DB8:CAFE:2100::BAD1:1010/64
Core0(config-if)# standby 1 ip 172.26.0.1
Core0(config-if)# standby 1 priority 105
Core0(config-if)# standby 1 preempt
Core0(config-if)# standby 2 ipv6 autoconfig
Core0(config-if)# standby 2 priority 105
Core0(config-if)# standby 2 preempt
Core0(config-if)# end

Core1# configure terminal
Core1(config)# interface Vlan2
Core1(config-if)# standby version 2
Core1(config-if)# ip address 172.26.0.3 255.255.255.0
Core1(config-if)# ipv6 address 2001:DB8:CAFE:2100::BAD1:1020/64
Core1(config-if)# standby 1 ip 172.26.0.1
Core1(config-if)# standby 1 preempt
Core1(config-if)# standby 2 ipv6 autoconfig
Core1(config-if)# standby 2 preempt
Core1(config-if)# end

Do I have to use a different standby-number for each address-family?

Yes for each address family, the IPv4 standby group number has to be different from the IPv6 group, otherwise it wont work.

And which connection should be configured between Core 0 and Core1? Normal routing port or a trunk?

A normal trunk will suffice for HSRP to work.

And when I configure HSRP for one SVI, how does the other router know that he should take part in this HSRP process? Just by configuring the same standby id one the other router?

I explained that here: HSRP - How do routers with equal standby-group find each other?

  • "Not for each address family, but IPv4 and IPv6 numbers have to be different" - But that means for each address family, doesn't it? – watchme Feb 19 '18 at 16:11
  • @watchme yeah you are right. Fixed. – user36472 Feb 19 '18 at 16:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.