3

I am trying to find the reason why R1 doesn't have the default-route, propagated and generated by my Internet-PAT-Router, in his routing-table. The weird thing is, that R2 actually has an entry for the default-route!

I am sorry if it is a really weird simple error which is easy to find, but I just couldn't find it (even after long googling and comparing R1 and R2).

I am able to ping like this:

PC -----> R1
R1 -----> ABR
PC --!--> ABR
R1 --!--> Internet (I have simulated the Internet with a simple webserver)
R2 -----> Internet 
Router in the area down below the area 45 -----> Internet 

Gigabit-Interfaces are for the LAN-Networks which are configured as passive-interface.

Here's the overview over my network:

enter image description here

Configuration of R1:

en
 conf t
 no ip domain-lookup
 ipv6 unicast-routing

 int loopback 0
  ip address 1.1.1.1 255.255.255.255
  exit

 ipv6 router ospf 1
  router-id 1.1.1.1
  auto-cost reference-bandwidth 100000
  passive-interface g0/0
  area 45 range 2001:db8:18:4565::/56
  exit

 router ospf 1
  auto-cost reference-bandwidth 100000
  passive-interface g0/0
  area 45 range 10.45.65.0 255.255.255.0
  exit

 int s0/0/0
  ip address 10.45.0.6 255.255.255.252
  ipv6 address 2001:db8:18:4502::2/64
  ipv6 ospf 1 area 45
  ip ospf 1 area 45
  ip ospf hello-interval 3
  ipv6 ospf hello-interval 3
  no sh

 int g0/0
  ip address 10.45.65.1 255.255.255.0
  ipv6 add 2001:db8:18:4565::1/64
  no sh

  exit

 access-list 100 deny ip any host 224.0.0.5
 access-list 100 deny ip any host 244.0.0.6
 access-list 100 permit ip any any

 int g0/0
  ip access-group 100 in
 exit

Configuration of R2:

en
 conf t
 no ip domain-lookup
 ipv6 unicast-routing

 int loopback 0
  ip address 1.1.1.1 255.255.255.255
  exit

 ipv6 router ospf 1
  router-id 1.1.1.1
  auto-cost reference-bandwidth 100000
  exit

 router ospf 1
  auto-cost reference-bandwidth 100000
  network 10.45.0.0 0.0.0.3 area 45
  exit

 int s0/0/0
  ip address 10.45.0.2 255.255.255.252
  ipv6 address 2001:db8:18:4501::2/64
  ipv6 ospf 1 area 45
  ip ospf hello-interval 3
  ipv6 ospf hello-interval 3
  no sh

 int g0/0
  ip address 10.45.64.1 255.255.255.0
  ipv6 add 2001:db8:18:4564::1/64
  ipv6 ospf 1 area 45
  ip ospf hello-interval 3
  ipv6 ospf hello-interval 3
  no sh

  exit
  exit

Configuration of the ABR:

en
 conf t
 no ip domain-lookup
 ipv6 unicast-routing

 int loopback 0
  ip address 2.2.1.1 255.255.255.255
  exit

 ipv6 router ospf 1
  area 45 range 2001:db8:18:4500::/56
  auto-cost reference-bandwidth 100000
  router-id 2.2.1.1
  exit

 router ospf 1
  area 45 range 10.45.0.0 255.255.0.0
  area 0 range 10.0.0.0 255.255.0.0
  auto-cost reference-bandwidth 100000
  network 10.45.0.0 0.0.0.255 area 45
  network 10.0.0.0 0.0.0.255 area 0

 int s0/1/0
  ip add 10.45.0.1 255.255.255.252
  ipv6 add 2001:db8:18:4501::1/64
  ipv6 ospf 1 area 45
  ip ospf hello-interval 3
  ipv6 ospf hello-interval 3
  no sh

 int s0/1/1
  ip add 10.45.0.5 255.255.255.252
  ipv6 add 2001:db8:18:4502::1/64
  ipv6 ospf 1 area 45
  ip ospf hello-interval 3
  ipv6 ospf hello-interval 3
  no sh

 int s0/0/0
  ip add 10.0.0.2 255.255.255.252
  ipv6 add 2001:db8:18:0001::2/64
  ipv6 ospf 1 area 0
  ip ospf hello-interval 3
  ipv6 ospf hello-interval 3
  no sh

 int s0/0/1
  ip add 10.0.0.6 255.255.255.252
  ipv6 add 2001:db8:18:0002::2/64
  ipv6 ospf 1 area 0
  ip ospf hello-interval 3
  ipv6 ospf hello-interval 3
  no sh

  exit

This is the "show ip ospf int"-command on the ABR

Serial0/1/0 is up, line protocol is up
  Internet address is 10.45.0.1/30, Area 45
  Process ID 1, Router ID 2.2.1.1, Network Type POINT-TO-POINT, Cost: 64
  Transmit Delay is 1 sec, State POINT-TO-POINT, Priority 0
  No designated router on this network
  No backup designated router on this network
  Timer intervals configured, Hello 3, Dead 40, Wait 40, Retransmit 5
    Hello due in 00:00:02
  Index 1/1, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 1
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 1 , Adjacent neighbor count is 1
    Adjacent with neighbor 1.1.1.1
  Suppress hello for 0 neighbor(s)
Serial0/1/1 is up, line protocol is up
  Internet address is 10.45.0.5/30, Area 45
  Process ID 1, Router ID 2.2.1.1, Network Type POINT-TO-POINT, Cost: 64
  Transmit Delay is 1 sec, State POINT-TO-POINT, Priority 0
  No designated router on this network
  No backup designated router on this network
  Timer intervals configured, Hello 3, Dead 40, Wait 40, Retransmit 5
    Hello due in 00:00:02
  Index 2/2, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 1
  Last flood scan time is 0 msec, maximum is 0 msec
  Suppress hello for 0 neighbor(s)
Serial0/0/0 is up, line protocol is up
  Internet address is 10.0.0.2/30, Area 0
  Process ID 1, Router ID 2.2.1.1, Network Type POINT-TO-POINT, Cost: 64
  Transmit Delay is 1 sec, State POINT-TO-POINT, Priority 0
  No designated router on this network
  No backup designated router on this network
  Timer intervals configured, Hello 3, Dead 40, Wait 40, Retransmit 5
    Hello due in 00:00:02
  Index 3/3, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 1
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 1 , Adjacent neighbor count is 1
    Adjacent with neighbor 3.3.3.3
  Suppress hello for 0 neighbor(s)
Serial0/0/1 is up, line protocol is up
  Internet address is 10.0.0.6/30, Area 0
  Process ID 1, Router ID 2.2.1.1, Network Type POINT-TO-POINT, Cost: 64
  Transmit Delay is 1 sec, State POINT-TO-POINT, Priority 0
  No designated router on this network
  No backup designated router on this network
  Timer intervals configured, Hello 3, Dead 40, Wait 40, Retransmit 5
    Hello due in 00:00:02
  Index 4/4, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 1
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 1 , Adjacent neighbor count is 1
    Adjacent with neighbor 4.4.4.4
  Suppress hello for 0 neighbor(s)

And the command on R1 doesn't show anything.

  • Can you include "sh ip ospf int brief" from each router? Which router is generating the default route? – Ron Trunk Mar 1 '18 at 12:29
  • On R1, you have no network statement (for OSPFv2). – Ron Trunk Mar 1 '18 at 12:31
  • but on s0/0/0 I have configured "ip ospf 1 area 45" – watchme Mar 1 '18 at 12:48
  • or is this just for ospfv3? And the "show ip ospf int"-command on R1 doesn't show anything... so it is not taking part in OSPF... seems I really have to configure this with the network command – watchme Mar 1 '18 at 12:57
  • still not working – watchme Mar 1 '18 at 13:06
5

1.

The first issue is that you configured same Router-ID (RID) router-id 1.1.1.1 for R1 and R2 in area 45.

All OSPF router should have different RIDs across the OSPF network domain.

2.

And the reason PC1 cannot reach ABR (and other OSPF routers in the network also cannot reach the IPv4 and IPv6 addresses of R1's g0/0 interface) is that you did not enable either OSPFv2 or OSPFv3 on interface g0/0 of R1, thus the IPv4 subnet 10.45.65.0/24 and IPv6 network 2001:DB8:18:4565::/64 are unknown to other OSPF routers in the network:

 #On R1#
 !
 ipv6 router ospf 1
  router-id 1.1.1.1
  auto-cost reference-bandwidth 100000
  passive-interface g0/0
  area 45 range 2001:db8:18:4565::/56
  exit
 !
 router ospf 1
  auto-cost reference-bandwidth 100000
  passive-interface g0/0
  area 45 range 10.45.65.0 255.255.255.0
  exit
 !
 int g0/0
  ip address 10.45.65.1 255.255.255.0
  ipv6 add 2001:db8:18:4565::1/64
  no sh

The command area 45 range ... is to summarize the more specific routes/prefixes within this range, and it should be used only on ABRs.

To fix this issue, you can enable OSPFv2 and/or OSPFv3 on R1's interface g0/0 like you did on interface s0/0/0:

 int g0/0
  ...
  ...
  ipv6 ospf 1 area 45
  ip ospf 1 area 45
  no sh

Last but not least, you need to ensure that you run OSPFv2 and/or OSPFv3 consistently across your network (on necessary interfaces).

| improve this answer | |
  • Can you please add the mistake, that I configured the same router-id twice? I think thats easier for others to find the solution of this question then – watchme Mar 2 '18 at 12:51
  • @watchme Okay, no problem! – Hung Tran Mar 2 '18 at 17:08
2

The mistake was, that I configured the same router-id on both R1 and R2 and that doesn't work!

Two routers can have the same touter-id but not while having the same neighbor! A router cannot "do OSPF" by being connected with two router having the same router-id!

Nevertheless, as @Karl pointed out, having the same router-id configured on two or more routers is always a problem due to the LSAs which have the router-id of the advertising router included. In addition to that, more problems can occure.

But still, PC1, which is connected to R1, cannot ping the ABR...

| improve this answer | |
  • You would still have a lot of trouble if two routers had the same router ID even if they are not neighbours. They would both create router LSAs with the same router ID, other routers would pick one of the router LSAs, so only know about connections from one of the routers. There are many other things that would also brake like ABR and ASBR LSAs. Make sure all the routers in your network have different router IDs – Karl Billington Mar 1 '18 at 15:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.