1

For some reason, my Cisco router is not saving the command "ip nhrp map multicast dynamic". The command is recognized but not being saved to the configuration. I am not receiving any errors. Any idea why this is happening?

rtr-d1#sh run int tun1
Building configuration...

Current configuration : 327 bytes
!
interface Tunnel1
 ip vrf forwarding VRF
 ip address <network/22>
 no ip redirects
 ip mtu 1392
 ip nhrp authentication <key>
 ip nhrp network-id <id>
 ip tcp adjust-mss 1352
 tunnel source GigabitEthernet1
 tunnel mode gre multipoint
 tunnel key <key>
 tunnel protection ipsec profile <profile>
end

rtr-d1#config t
Enter configuration commands, one per line.  End with CNTL/Z.
rtr-d1(config)#int tun1
rtr-d1(config-if)#ip nhrp map multicast dynamic
rtr-d1(config-if)#do sh run int tun1
Building configuration...

Current configuration : 327 bytes
!
interface Tunnel1
 ip vrf forwarding VRF
 ip address <network/22>
 no ip redirects
 ip mtu 1392
 ip nhrp authentication <key>
 ip nhrp network-id <id>
 ip tcp adjust-mss 1352
 tunnel source GigabitEthernet1
 tunnel mode gre multipoint
 tunnel key <key>
 tunnel protection ipsec profile <profile>
end

rtr-d1(config-if)#
1

That is probably a default. Almost all default configurations simply do not show up in a regular show running-config.

The classic example is to set a switch interface to VLAN 1. You will not see that in the configuration because it is the default VLAN for a switch interface.

You can see this if set your timezone to utc 0 0, but you will not see that in the configuration because that is the default. If you set it to anything else, then you will see the command.

| improve this answer | |
  • On my other router, it shows in the "running-config". See below: RTR-C1#sh run int tun1 Building configuration... Current configuration : 358 bytes ! interface Tunnel1 ip vrf forwarding VRF ip address <network> no ip redirects ip mtu 1392 ip nhrp authentication <key> ip nhrp map multicast dynamic ip nhrp network-id <id> ip tcp adjust-mss 1352 tunnel source GigabitEthernet2 tunnel mode gre multipoint tunnel key <key> tunnel protection ipsec profile <profile> end – enter_display_name_here Mar 16 '18 at 17:27
  • Such things change between IOS versions. Are you sure you have the exact same (both major and minor) version on both? – Ron Maupin Mar 16 '18 at 17:29
  • The versions are different. Unfortunately, that is the only difference in configurations between the working and non-working DMVPN connection. – enter_display_name_here Mar 16 '18 at 17:30
  • I saw this in the Cisco documentation. 'Allows NHRP to automatically add spoke routers to the multicast NHRP mappings. Note Effective with Cisco IOS XE Denali 16.3 ip nhrp map multicast dynamic is enabled by default.' I am using 16.7.1. Maybe that's why it doesn't show up :) – enter_display_name_here Mar 16 '18 at 17:37
  • OK, it is now a default command, so you will not see it in the configurations. – Ron Maupin Mar 16 '18 at 17:38
1

to verify this default, try "show run all"

#show run all | inc Tunnel0|map multicast dyn

interface Tunnel0
 ip nhrp map multicast dynamic
 ipv6 nhrp map multicast dynamic
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.